Bug 225770 - Merge Review: freetype
Summary: Merge Review: freetype
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 18:40 UTC by Nobody's working on this, feel free to take it
Modified: 2008-12-09 21:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 21:53:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 18:40:09 UTC
Fedora Merge Review: freetype

http://cvs.fedora.redhat.com/viewcvs/devel/freetype/
Initial Owner: besfahbo@redhat.com

Comment 1 Julian Sikorski 2007-02-03 16:21:48 UTC
IIRC freetype has some rpath issues. I don't know how easily they can be rid of.

Comment 2 Roozbeh Pournader 2007-02-06 13:01:22 UTC
Bad news! <http://fedoraproject.org/wiki/Packaging/Guidelines#Legal> says that
the license must be in one of the three lists. Since FTL is nowhere on those
lists, unless FSF reviews it or OSI approves it, we may need to consider pango
and freetype GPL.

Comment 3 Behdad Esfahbod 2007-02-06 17:17:18 UTC
So we mark it as GPL.  Do you think anything will happen ever?!

Comment 4 Roozbeh Pournader 2007-02-07 11:58:51 UTC
(In reply to comment #3)
> So we mark it as GPL.  Do you think anything will happen ever?!

I don't get what is the question, but marking it as GPL will remove the blocker
on review.

Comment 5 Julian Sikorski 2007-06-01 18:31:22 UTC
RPATH problem still exists in 2.3.4-3.

Comment 6 Adam Jackson 2007-06-29 20:43:56 UTC
rpath buglet fixed in 2.3.4-4.

Comment 7 Kevin Kofler 2007-09-18 08:30:44 UTC
There's still some badness left:
* The Source: tag doesn't contain the full URL. Please change this to:
http://download.savannah.gnu.org/releases/freetype/freetype-%{version}.tar.bz2
(likewise for Source1 and Source2)
* The License tag should be "License: FTL or GPLv2+".
* Please ship the license files as %doc, e.g.:
%doc ChangeLog README docs/LICENSE.TXT docs/FTL.TXT docs/GPL.TXT

Comment 8 Behdad Esfahbod 2008-12-09 21:05:07 UTC
The license was already fixed.

* Tue Dec 09 2008 Behdad Esfahbod <besfahbo@redhat.com> 2.3.7-3
- Add full source URL to Source lines.
- Add docs to main and devel package.
- rpmlint is happy now.
- Resolves: #225770

Comment 9 Dennis Gilmore 2008-12-09 21:24:35 UTC
package is not approved, and cant be closed.

Comment 10 Kevin Kofler 2008-12-09 21:53:13 UTC
The package is OK now. All the issues were addressed. I also compared it with the freetype-freeworld package which passed review at Livna.

Merge review APPROVED.


Note You need to log in before you can comment on or make changes to this bug.