Bug 22578 - DRI fails on Matrox with XF86-4.0.2-0.1
DRI fails on Matrox with XF86-4.0.2-0.1
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: Mesa (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 22910 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-20 09:30 EST by Nils Philippsen
Modified: 2007-04-18 12:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-07 02:37:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2000-12-20 09:30:50 EST
Finally with 4.0.2, kernel-2.4 DRM and XF86 DRI for Matrox are compatible
again, but if I start e.g. one of the xscreensaver 3D hacks, it still uses
software rendering. If I start it with LIBGL_DEBUG=1, I can see that it
fails to resolve the symbol XF86DRIOpenFullScreen in
/usr/X11R6/lib/modules/dri/mga_dri.so although it is present in
/usr/X11R6/lib/modules/extensions/libdri.a -- but it isn't external:

--- 8< ---
nils@cognac:~> nm /usr/X11R6/lib/modules/extensions/libdri.a | grep
XF86DRIOpenFullScreen
00000800 t ProcXF86DRIOpenFullScreen
nils@cognac:~> nm --extern-only /usr/X11R6/lib/modules/extensions/libdri.a
| grep XF86DRIOpenFullScreen
nils@cognac:~>
--- >8 ---

From the other DRI modules I can see that they all reference that symbol,
so I suspect DRI is broken regardless of the video card.
Comment 1 Bill Nottingham 2000-12-20 11:55:34 EST
It worked on r128 last I checked (4.0.1Z era).
Comment 2 Nils Philippsen 2000-12-27 10:59:24 EST
Observing people will have noticed that the symbol in libdri.a is
ProcXF86DRIOpenFullScreen, not XF86DRIOpenFullScreen. Duh. Harald Hoyer
pointed out to me that the missing symbol somehow slipped into libGL.so
built with XFree86 (but not packaged).

I guess this should not be the case :-) as libGL is not per se the only means
to access DRI (or am I wrong here?).
Comment 3 Jeremy Katz 2001-01-05 23:51:58 EST
for the record, still broken in 4.0.2-0.2 (Jan 3 rawhide update)
Comment 4 Jeremy Katz 2001-01-06 13:24:49 EST
Okay, did some work on this last night.  The actual problem is in Mesa (hence
changing the component) because Mesa includes a snapshot of the XFree DRI GL
stuff from XFree 4.0.1.  Obviously some things have changed since then since DRI
is even still a moving target. I pulled similarly from 4.0.2 and have the
updated Mesa RPM/SRPM at http://katz.linuxpower.org/mesa/.  Unfortunately, it's
still not working for me on a r128 but I'm getting the exact problem I had when
I was running DRI CVS, so I think that the Mesa build at least is good and
should enable everything to work properly.  At least glxinfo seems to think so.
 If someone could verify that, I'd appreciate it so I don't chase ghosts.
Comment 5 Bill Crawford 2001-01-07 02:31:59 EST
Yeah, the new package you put up seems to work (>500 FPS with miniature gears
window, on G400)
Comment 6 Bill Crawford 2001-01-07 02:37:12 EST
*** Bug 22910 has been marked as a duplicate of this bug. ***
Comment 7 Bernhard Rosenkraenzer 2001-01-08 09:45:54 EST
Thanks, fixed.

Note You need to log in before you can comment on or make changes to this bug.