This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 225786 - Merge Review: gd
Merge Review: gd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:41 EST by Nobody's working on this, feel free to take it
Modified: 2010-01-06 07:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-06 07:56:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mmaslano: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:41:55 EST
Fedora Merge Review: gd

http://cvs.fedora.redhat.com/viewcvs/devel/gd/
Initial Owner: varekova@redhat.com
Comment 1 Marcela Mašláňová 2007-02-22 06:35:05 EST
Source:
W: gd mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 12)
Devel & progs:
W: gd-devel no-documentation

License: BSD-style -> only BSD
Source0: http://www.libgd.org/Releases/%{name}-%{version}.tar.bz2
Wrong, correct is: http://www.libgd.org/releases/%{name}-%{version}.tar.bz2
md5sum ok
Comment 2 Ivana Varekova 2007-02-22 07:57:43 EST
Fixed in gd-2.0.34-2.fc7.
Comment 3 Marcela Mašláňová 2007-02-23 04:52:23 EST
APPROVED
Comment 4 Patrice Dumas 2007-03-21 17:34:48 EDT
I noticed that the pkgconfig file created in a patch is not
right. Something dynamically linking against gd don't certainly 
need all the link flags, they are needed when doing a static 
linking, so the following should certainly be like
Libs.private: -lXpm -lX11 -ljpeg -lfontconfig -lfreetype -lpng12 -lz -lm
Moreover some of those have pkgconfig files, in that case it
should even be like
Requires.private: x11, xpm, fontconfig, freetype2
and the corresponding flags removed from Libs.private.

Not really a blocker, but it is important to have clean .pc
files to avoid over-linking, it creates bogus dependencies.
Comment 5 Patrice Dumas 2007-03-24 22:31:42 EDT
The default font path is wrong.
there is, in gd.h:
#ifndef DEFAULT_FONTPATH
....
#define DEFAULT_FONTPATH
"/usr/X11R6/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/truetype:/usr/X11R6/lib/X11/fonts/TTF:/usr/share/fonts/TrueType:/usr/share/fonts/truetype:/usr/openwin/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/Type1:/usr/lib/X11/fonts/Type1:/usr/openwin/lib/X11/fonts/Type1"

(This seems to be used in gdft.c. There is also
#define DEFAULT_FONTPATH "/usr/share/fonts/truetype"
but it reuse the value from gd.h since there is a
#ifndef DEFAULT_FONTPATH)

One possibility could be along
/usr/share/X11/fonts/TTF/:/usr/share/fonts/bitstream-vera/:/usr/share/fonts/dejavu-lgc/:/usr/share/fonts/default/Type1/:/usr/share/X11/fonts/Type1
And maybe tetex type1 fonts?

Since there is a
#ifndef DEFAULT_FONTPATH

It should be possible to change it in the CFLAGS.
Comment 6 Patrice Dumas 2007-06-01 04:32:15 EDT
Thos 2 issues are important and have consequences on gnuplot 
(bogus dependencies and the new png driver using gd is unusable).
Comment 7 Patrice Dumas 2007-08-23 11:52:39 EDT
The issues I point out should be fixed, reopening. In fact, 
these issues should have been raisen during the review. It 
may happen that a reviewer didn't saw an issue, but if a 
serious issue is raised later (and I think these are serious 
issues, they impact seriously other packages) normally 
either the reviewer should ask for these issues to be solved,
or the submitter should fix them before closing the review.
Comment 8 Patrice Dumas 2007-08-23 12:00:22 EDT
I can make patches if you want to, but something needs to be 
done, my remarks date from March.
Comment 9 Ivana Varekova 2007-09-04 10:19:10 EDT
Thanks for your comments, fixed in gd-2.0.34-3.fc8.
Comment 10 Patrice Dumas 2007-10-28 18:58:51 EDT
Static lib should be in a separate subpackage.

In the progs description, you should remove:

If you install
these, you must also install gd.

The /usr/share/fonts/liberation/ font directory should be added.

entities.html should not be shipped.

In the .pc file, Libs should be
Libs: -L${libdir} -ldg

Also (suggestion) I think it is better to have
Cflags: -I${includedir}
in case there is a way to override the variables in pkgconfig.
Comment 11 Patrice Dumas 2007-11-18 13:33:35 EST
There is a typo in the .pc file, and in my comment, should be

In the .pc file, Libs should be
Libs: -L${libdir} -lgd
Comment 12 Ivana Varekova 2007-11-19 08:29:27 EST
Thanks. Fixed in gd-2.0.35-2.fc9.
Comment 13 Patrice Dumas 2007-11-19 08:38:10 EST
There are other comments in Comment #10 that should be
taken into account.
Comment 14 Ivana Varekova 2007-11-19 10:53:12 EST
Thanks, fixed in gd-2.0.35-3.fc9. I want to remove libgd.a now I'm waiting to
feedback on fedora-devel list if there will be no complains I will remove it.
Comment 15 Patrice Dumas 2008-01-28 16:25:44 EST
I haven't seen any file under the GPL. (There is one which is more
bsd than mit, but it doesn't matter much).

I suggest adding NEWS to %doc.

Also I suggest adding INSTALL='install -p' to make install line
to keep timestamps.

I suggest removing the -f for rm such that it fails if files doesn't
exist anymore:
rm $RPM_BUILD_ROOT/%{_libdir}/libgd.la
rm $RPM_BUILD_ROOT/%{_libdir}/libgd.a

In case you didn't know, rpmlint says:
gd.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 16)
Comment 16 Patrice Dumas 2008-12-21 16:52:59 EST
Ping?
Comment 17 Ivana Varekova 2009-01-06 09:29:30 EST
Thanks. All points you mentioned should be fixed in gd-2.0.35-7.fc11. For now gd maintainer is Jiri Moskovcak so I'm adding him to cc.
Comment 18 Marcela Mašláňová 2009-11-30 04:14:19 EST
Problems in F-12:
gd.x86_64: W: shared-lib-calls-exit /usr/lib64/libgd.so.2.0.0 exit@GLIBC_2.2.5

In previous review was mentioned problem with -f in these commands, but it's okay now.
rm $RPM_BUILD_ROOT/%{_libdir}/libgd.la
rm $RPM_BUILD_ROOT/%{_libdir}/libgd.a

Could you comment the rpmlint's warning for finishing this review?
Comment 19 Jiri Moskovcak 2010-01-06 07:44:35 EST
(In reply to comment #18)
> Problems in F-12:
> gd.x86_64: W: shared-lib-calls-exit /usr/lib64/libgd.so.2.0.0 exit@GLIBC_2.2.5
> 
> In previous review was mentioned problem with -f in these commands, but it's
> okay now.
> rm $RPM_BUILD_ROOT/%{_libdir}/libgd.la
> rm $RPM_BUILD_ROOT/%{_libdir}/libgd.a
> 
> Could you comment the rpmlint's warning for finishing this review?  

It's called only in extremely rare cases when some serious error occurs, removing the exit would require to break the API.
Comment 20 Marcela Mašláňová 2010-01-06 07:56:10 EST
Ok, closing.

Note You need to log in before you can comment on or make changes to this bug.