Bug 22585 - ia64 redhat RPM dependency failure
ia64 redhat RPM dependency failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
http://www.redhat.com/WebX?13@120.BbB...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-20 11:15 EST by Quentin Neill
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-20 13:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Neill 2000-12-20 11:15:36 EST
On Intel IA64 machines, you can successfully build RPMs but they fail on
installation with the following errors: 

    rpm -ivh metro-x-5.2.0-1.20001205.glibc.ia64.rpm 
    error: failed dependencies: 
        ld-linux-ia64.so.1()(64bit) is needed by [rpm-name]
 
We tracked this down to the '/usr/lib/rpm/find-requires' and
'/usr/lib/rpm/find-provides' mechanisms. The new 'find-requires' script
that comes with <b>rpm-build-4.0.1-0.20</b>
is placing this string in the dependancy list; but the <b>rpm
executable</b> is not able to resolve this dependancy at install time.
Comment 1 Bill Nottingham 2000-12-20 11:31:33 EST
You need to have everything built with that version of RPM for dependencies
to be resolved correctly.

Try installing the new ia64 beta.
Comment 2 Quentin Neill 2000-12-20 13:38:21 EST
We experienced this problem when we installed a new beta we received from intel.
What 'new ia64 beta' specifically are you referring to?
And how can I tell what exact release we have installed?
Comment 3 Quentin Neill 2000-12-20 13:39:07 EST
P.S.  Thanks for the speedy response, let me know if there is a better way to
communicate,
notice I posted in the forums also.
Comment 4 Bill Nottingham 2000-12-20 14:48:02 EST
The beta that was released to the public yesterday.

ftp://ftp.redhat.com/pub/redhat/ia64/

(If whatever you have still uses ld-linux-ia64.so.1, it's
pretty old.)

You can judge the release by what /etc/redhat-release says;
it should say:

Red Hat Linux release 7.0 (Guinness)

ia64-list@redhat.com is the general list for discussion of the
ia64 release.


Comment 5 Quentin Neill 2000-12-21 11:15:16 EST
Thanks for the replies.

The version we have installed is 6.96.1 (without the '()(64bit)' in the
find-requires script) and the version which introduced the problem was 6.96.2
(with the '()(64bit)' string).

Unfortunately, we have step-A processors,;we read that the new 7.0 based beta is
not recommended for them, so we're stuck until we upgrade our hardware.

Meanwhile we have workedaround the problem.

Note You need to log in before you can comment on or make changes to this bug.