Bug 225854 - Merge Review: gperf
Merge Review: gperf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:57 EST by Nobody's working on this, feel free to take it
Modified: 2009-01-27 09:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 09:58:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
redhat: fedora‑review+


Attachments (Terms of Use)
gperf specfile (4.44 KB, text/plain)
2009-01-27 09:16 EST, Roman Rakus
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:57:25 EST
Fedora Merge Review: gperf

http://cvs.fedora.redhat.com/viewcvs/devel/gperf/
Initial Owner: laroche@redhat.com
Comment 1 Robert Scheck 2009-01-13 18:17:01 EST
Current package owner is rrakus, no laroche. Okay, so let's go for now:

[ DONE ] MUST: rpmlint must be run on every package
         $ rpmlint /var/lib/mock/fedora-10-x86_64/result/gperf-*
         gperf.src:9: E: prereq-use /sbin/install-info
         3 packages and 0 specfiles checked; 1 errors, 0 warnings.
         $
         -> See below, mentioned there and how to fix.
[  OK  ] MUST: The package must be named according to the Package Naming 
         Guidelines
[  OK  ] MUST: The spec file name must match the base package %{name} [...]
[  ??  ] MUST: The package must meet the Packaging Guidelines
[  OK  ] MUST: The package must be licensed with a Fedora approved license
         and meet the Licensing Guidelines
[  OK  ] MUST: The License field in the package spec file must match the 
         actual license
[FAILED] MUST: If (and only if) the source package includes the text of the 
         license(s) in its own file, then that file, containing the text of 
         the license(s) for the package must be included in %doc
         -> Add COPYING to %doc
[  OK  ] MUST: The spec file must be written in American English.
[  OK  ] MUST: The spec file for the package MUST be legible.
[  OK  ] MUST: The sources used to build the package must match the upstream 
         source, as provided in the spec URL. Reviewers should use md5sum for 
         this task. If no upstream URL can be specified for this package, 
         please see the Source URL Guidelines for how to deal with this.
         -> cc20e58975a38075440423c8fb85fd00  gperf-3.0.3.tar.gz
         -> cc20e58975a38075440423c8fb85fd00  gperf-3.0.3.tar.gz.1
         -> 3c535d2727eb0dca10ca87cefa03720a8280c7a2  gperf-3.0.3.tar.gz
         -> 3c535d2727eb0dca10ca87cefa03720a8280c7a2  gperf-3.0.3.tar.gz.1
[  OK  ] MUST: The package MUST successfully compile and build into binary 
         rpms on at least one primary architecture
[  N/A ] MUST: If the package does not successfully compile, build or work on 
         an architecture, then those architectures should be listed in the 
         spec in ExcludeArch. Each architecture listed in ExcludeArch MUST 
         have a bug filed in bugzilla, describing the reason that the package 
         does not compile/build/work on that architecture. The bug number MUST 
         be placed in a comment, next to the corresponding ExcludeArch line
[  OK  ] MUST: All build dependencies must be listed in BuildRequires, except 
         for any that are listed in the exceptions section of the Packaging 
         Guidelines ; inclusion of those as BuildRequires is optional. Apply 
         common sense.
[  N/A ] MUST: The spec file MUST handle locales properly. This is done by 
         using the %find_lang macro. Using %{_datadir}/locale/* is strictly 
         forbidden
[  N/A ] MUST: Every binary RPM package (or subpackage) which stores shared 
         library files (not just symlinks) in any of the dynamic linker's 
         default paths, must call ldconfig in %post and %postun. [10]
[  N/A ] MUST: If the package is designed to be relocatable, the packager must 
         state this fact in the request for review, along with the 
         rationalization for relocation of that specific package. Without 
         this, use of Prefix: /usr is considered a blocker. [11]
[  OK  ] MUST: A package must own all directories that it creates. If it does 
         not create a directory that it uses, then it should require a package 
         which does create that directory.
[  OK  ] MUST: A package must not contain any duplicate files in the %files 
         listing.
[  OK  ] MUST: Permissions on files must be set properly. Executables should 
         be set with executable permissions, for example. Every %files section 
         must include a %defattr(...) line.
         -> We're optional suggesting %defattr(-,root,root,-) rather current
[  OK  ] MUST: Each package must have a %clean section, which contains rm -rf
         %{buildroot} (or $RPM_BUILD_ROOT).
[  OK  ] MUST: Each package must consistently use macros.
[  OK  ] MUST: The package must contain code, or permissable content.
[  ??  ] MUST: Large documentation files must go in a -doc subpackage. (The 
         definition of large is left up to the packager's best judgement, but 
         is not restricted to size. Large can refer to either size or 
         quantity).
         -> gperf/doc/* is currently nearly unused, let's talk about why and so
[  ??  ] MUST: If a package includes something as %doc, it must not affect the 
         runtime of the application. To summarize: If it is in %doc, the 
         program must run properly if it is not present.
         -> First clarify point above...
[  N/A ] MUST: Header files must be in a -devel package.
[  N/A ] MUST: Static libraries must be in a -static package.
[  N/A ] MUST: Packages containing pkgconfig(.pc) files must 'Requires: 
         pkgconfig' (for directory ownership and usability).
[  N/A ] MUST: If a package contains library files with a suffix (e.g. 
         libfoo.so.1.1), then library files that end in .so (without suffix) 
         must go in a -devel package.
[  N/A ] MUST: In the vast majority of cases, devel packages must require the 
         base package using a fully versioned dependency: Requires: %{name} =
         %{version}-%{release}
[  N/A ] MUST: Packages must NOT contain any .la libtool archives, these must 
         be removed in the spec if they are built.
[  N/A ] MUST: Packages containing GUI applications must include a
         %{name}.desktop file, and that file must be properly installed with 
         desktop-file-install in the %install section. If you feel that your 
         packaged GUI application does not need a .desktop file, you must put 
         a comment in the spec file with your explanation.
[  OK  ] MUST: Packages must not own files or directories already owned by 
         other packages. The rule of thumb here is that the first package to 
         be installed should own the files or directories that other packages 
         may rely upon. This means, for example, that no package in Fedora 
         should ever share ownership with any of the files or directories 
         owned by the filesystem or man package. If you feel that you have a 
         good reason to own a file or directory that another package owns, 
         then please present that at package review time.
[  OK  ] MUST: At the beginning of %install, each package MUST run rm -rf
         %{buildroot} (or $RPM_BUILD_ROOT).
[  OK  ] MUST: All filenames in rpm packages must be valid UTF-8.

- Change BuildRoot e.g. to:
  BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

- Use _smpflags for make or explain, why/that it can't used, e.g.
  make %{?_smp_mflags}

- Kill "Prereq: /sbin/install-info" line, replace by
  Requires(post): /sbin/install-info
  Requires(preun): /sbin/install-info

- Shouldn't it be the following rather the current (add || :)?
  %preun
  if [ $1 = 0 ]; then
     /sbin/install-info --delete %{_infodir}/gperf.info.gz %{_infodir}/dir || :
  fi
  exit 0

- Please let us talk about why nearly nothing of gperf/doc/* currently ends up
  in the package, there's *.pdf, *.ps, *.html documentation. Reasons?
Comment 2 Roman Rakus 2009-01-19 07:32:27 EST
>[FAILED] MUST: If (and only if) the source package includes the text of the 
>         license(s) in its own file, then that file, containing the text of 
>         the license(s) for the package must be included in %doc
>         -> Add COPYING to %doc
Fixed.

>- Change BuildRoot e.g. to:
>  BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Fixed.

>- Use _smpflags for make or explain, why/that it can't used, e.g.
>  make %{?_smp_mflags}
Fixed.

>- Kill "Prereq: /sbin/install-info" line, replace by
>  Requires(post): /sbin/install-info
>  Requires(preun): /sbin/install-info
Fixed.

>- Shouldn't it be the following rather the current (add || :)?
>  %preun
>  if [ $1 = 0 ]; then
>     /sbin/install-info --delete %{_infodir}/gperf.info.gz %{_infodir}/dir || :
>  fi
>  exit 0
Is it necessary? Fixed.

>- Please let us talk about why nearly nothing of gperf/doc/* currently ends up
>  in the package, there's *.pdf, *.ps, *.html documentation. Reasons?
Added *.{html,ps,pdf}

fixed in gperf-3.0.3-5.fc11
Comment 3 Robert Scheck 2009-01-19 17:28:26 EST
Roman, thank you for taking action. I think, I've forgotten the suggestion
of preserving timestamps before and to avoid the usage of %makeinstall, thus
we recommend packagers to use instead:

  make DESTDIR=$RPM_BUILD_ROOT install INSTALL='install -p'

Regarding the documentation I'm not really happy. We've currently much more 
documentation rather rest of gperf inside of the package.

We've multiple options: Creating -docs subpackage and moving everything out 
there OR just kill the huge *.ps from %doc (*.ps vs. *.pdf seems to be a bit
redundant and *.pdf is usually better searchable) - last of it was accepted
and got told to be useful in Freenode #fedora-devel, #fedora-de by several 
packagers.

Choose what you like as packager and let me know. I can deal with both or
even a better option - afterwards we should be (hopefully) fine with review.
Comment 4 Roman Rakus 2009-01-27 09:16:47 EST
Created attachment 330088 [details]
gperf specfile

>Roman, thank you for taking action. I think, I've forgotten the suggestion
>of preserving timestamps before and to avoid the usage of %makeinstall, thus
>we recommend packagers to use instead:
>
>  make DESTDIR=$RPM_BUILD_ROOT install INSTALL='install -p'
>

Ok. I changed it to make install. But why to use install -p?

>Regarding the documentation I'm not really happy. We've currently much more 
>documentation rather rest of gperf inside of the package.
>
>We've multiple options: Creating -docs subpackage and moving everything out 
>there OR just kill the huge *.ps from %doc (*.ps vs. *.pdf seems to be a bit
>redundant and *.pdf is usually better searchable) - last of it was accepted
>and got told to be useful in Freenode #fedora-devel, #fedora-de by several 
>packagers.
>
>Choose what you like as packager and let me know. I can deal with both or
>even a better option - afterwards we should be (hopefully) fine with review.

I removed *.ps files.

I am including specfile for review. Maybe there is something more and I'd like to prevent many useless builds.
Comment 5 Robert Scheck 2009-01-27 09:37:12 EST
A 'install -p' makes install preserving the original timestamps of the files
it is installing (e.g. for stuff like man pages or non-generated files during
build). That's optional and nice to see for people (whether something changed
or not), but just suggested.

Spec file from comment #4 looks fine to me now, thus: APPROVED.

Thank you, Roman for solving the issues fast. Please close this bug report,
once you've applied the changes from comment #4 into CVS.
Comment 6 Roman Rakus 2009-01-27 09:58:03 EST
Hmm, I think, noone looks at timestamps, but ok.

Note You need to log in before you can comment on or make changes to this bug.