Bug 225880 - Merge Review: hal
Merge Review: hal
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Package Reviews List
:
Depends On: 161548
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:02 EST by Nobody's working on this, feel free to take it
Modified: 2012-06-15 12:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-21 05:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:02:23 EST
Fedora Merge Review: hal

http://cvs.fedora.redhat.com/viewcvs/devel/hal/
Initial Owner: davidz@redhat.com
Comment 1 Ralf Corsepius 2007-02-02 03:28:42 EST
MUSTFIX:
- package must not own
/usr/share/locale/*
and
/usr/share/locale/*/LC_MESSAGES

Package should use %find_lang


- Source0 is not an absolute URL


- *-devel contains *.pc
=> Requires: pkgconfig
Comment 2 Matthias Clasen 2007-02-03 22:45:10 EST
Fixed in hal-0.5.8.1-8.fc7
Comment 3 Patrice Dumas 2007-02-18 09:17:51 EST
Issues:

* use RPM_BUILD_ROOT or buildroot

*
BuildRequires: perl-XML-Parser
should certainly be replaced by
BuildRequires: perl(XML::Parser)

* Missing
Requires(post): /sbin/ldconfig
Requires(pre): /usr/sbin/useradd
Requires(postun): gawk, grep, coreutils, /sbin/ldconfig
I guessed that triggerpostun is associated with Requires(postun), maybe this
is wrong.

* There are no static libraries, the -devel %description should be updated

* /etc/dbus-1/system.d/hal.conf should certainly be %config(noreplace)

* Why is %doc commented out? And also
%{_datadir}/doc/hal-%{version}/conf/*
seems wrong to me but it's not completely obvious.

* remove Application; X-Red-Hat-Base; from desktop file Categories
remove X-Desktop-File-Install-Version=0.10 from desktop file

* --vendor should be fedora and not redhat. There is a cryptic comment
saying that it shouldn't change during release but I guess we are 
between releases...

* shouldn't hal-info be put in another package?

Suggestions:

* replace %defattr(-,root,root) with %defattr(-,root,root,-)

* replace
cp -f %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
with
cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
 


There is an issue of directory ownership for /usr/share/gtk-doc/html/,
but it is not obvious how to solve it.
Comment 4 David Zeuthen 2007-02-18 19:25:32 EST
In response to comment 3:

I've fixed most of this except making /etc/dbus-1/system.d/hal.conf
%config(noreplace). I've made it %config however as
/etc/dbus-1/system.d/hal.conf isn't a configuration at all; however some
developers like to tweak it around and as such their changes will be saved as
.rpmsave.

I've also cleaned up the %files sections of the spec file - please review if I
broke anything and if you think the spec file looks good now. Thanks.

This will appear in tomorrows Rawhide and I've uploaded the spec file and SRPM here

 http://people.redhat.com/davidz/hal.spec
 http://people.redhat.com/davidz/hal-0.5.9-0.git20070218.fc7.src.rpm

Thanks for reviewing this.
Comment 5 Patrice Dumas 2007-02-19 18:51:47 EST
(In reply to comment #4)
> In response to comment 3:
> 
> I've fixed most of this except making /etc/dbus-1/system.d/hal.conf
> %config(noreplace). I've made it %config however as
> /etc/dbus-1/system.d/hal.conf isn't a configuration at all; 

It defines the security policy of HAL, it is an obvious config
file. You may prefer to keep it under the packager responsibility,
but it is a config file. I am personally fine with having this file
%config, seems like a good compromise.

I think that 
%{_sysconfdir}/rc.d/init.d/haldaemon
shouldn't be %config.
Maybe you could use  %_initrddir for that file.

The Application category in .desktop file is deprecated.

What about putting hal-info in another package?
Comment 6 Matthias Clasen 2007-06-17 01:02:58 EDT
hal-info is a separate package by now; I agree that the invalid Application
category should be removed fron the desktop file; should probably be fixed
upstream though, not worth carrying a patch for.
Comment 7 Matthias Clasen 2007-08-10 23:26:28 EDT
The hal-gnome package (and with it the desktop file) is gone now.
Comment 8 Nicola Soranzo 2011-04-21 05:48:29 EDT
Hal has been deprecated in rawhide today, so I'm closing this Merge Review as WONTFIX.
Comment 9 Parag AN(पराग) 2012-06-15 12:27:04 EDT
This bug just popped out when I searched for packages under review but looks like this package was retired already.

Dropping the flag fedora-review?

Note You need to log in before you can comment on or make changes to this bug.