Bug 225883 - Merge Review: hesinfo
Merge Review: hesinfo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:03 EST by Nobody's working on this, feel free to take it
Modified: 2010-03-18 15:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-18 15:33:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgallagh: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:03:16 EST
Fedora Merge Review: hesinfo

http://cvs.fedora.redhat.com/viewcvs/devel/hesinfo/
Initial Owner: nalin@redhat.com
Comment 1 Stephen Gallagher 2010-02-19 09:51:14 EST
#  MUST: rpmlint must be run on every package. The output should be posted in the review.[1]

FAIL

hesinfo.src: W: no-url-tag
The URL tag is missing.

hesinfo.x86_64: W: no-url-tag
The URL tag is missing.

hesinfo.x86_64: E: non-standard-executable-perm /usr/bin/hesinfo 0555
A standard executable should have permission set to 0755. If you get this
message, it means that you have a wrong executable permissions in some files
included in your package.

hesinfo-debuginfo.x86_64: W: no-url-tag
The URL tag is missing.


# MUST: The package must be named according to the Package Naming Guidelines .

PASS

# MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. [2] .

PASS

# MUST: The package must meet the Packaging Guidelines .

PASS

# MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .

PASS

# MUST: The License field in the package spec file must match the actual license. [3]

PASS

# MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.[4]

N/A

# MUST: The spec file must be written in American English. [5]

PASS

# MUST: The spec file for the package MUST be legible. [6]

PASS (though I'd rather see the changelog at the bottom)

# MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.

PASS

# MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. [7]

PASS

# MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line. [8]

PASS

# MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.

PASS

# MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.[9]

N/A

# MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun. [10]

N/A

# MUST: Packages must NOT bundle copies of system libraries.[11]

PASS

# MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker. [12]

N/A

# MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. [13]

PASS

# MUST: A Fedora package must not list a file more than once in the spec file's %files listings. [14]

PASS

# MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example. Every %files section must include a %defattr(...) line. [15]

PASS

# MUST: Each package must have a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT). [16]

PASS

# MUST: Each package must consistently use macros. [17]

PASS

# MUST: The package must contain code, or permissable content. [18]

PASS

# MUST: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity). [19]

N/A

# MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present. [19]

PASS

# MUST: Header files must be in a -devel package. [20]

N/A

# MUST: Static libraries must be in a -static package. [21]

N/A

# MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for directory ownership and usability). [22]

N/A

# MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package. [20]

N/A

# MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name} = %{version}-%{release} [23]

N/A

# MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.[21]

N/A

# MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation. [24]

N/A

# MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time. [25]

PASS

# MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot} (or $RPM_BUILD_ROOT). [26]

PASS

# MUST: All filenames in rpm packages must be valid UTF-8. [27]

PASS



#  SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it. [28]

This needs to be done

# SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available. [29]

Translations are not present.

# SHOULD: The reviewer should test that the package builds in mock. [30]

PASS

# SHOULD: The package should compile and build into binary rpms on all supported architectures. [31]

PASS

# SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.

PASS

# SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity. [32]

N/A

# SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency. [23]

N/A

# SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb. [22]

N/A

# SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. [33]

N/A

# SHOULD: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.[34]

PASS
Comment 2 Nalin Dahyabhai 2010-02-19 10:16:50 EST
(In reply to comment #1)
> #  MUST: rpmlint must be run on every package. The output should be posted in
> the review.[1]
> 
> FAIL
> 
> hesinfo.src: W: no-url-tag
> The URL tag is missing.
> 
> hesinfo.x86_64: W: no-url-tag
> The URL tag is missing.
> 
> hesinfo-debuginfo.x86_64: W: no-url-tag
> The URL tag is missing.

I'm not aware of a suitable URL to use here.

> hesinfo.x86_64: E: non-standard-executable-perm /usr/bin/hesinfo 0555
> A standard executable should have permission set to 0755. If you get this
> message, it means that you have a wrong executable permissions in some files
> included in your package.

Fixing.
Comment 3 Stephen Gallagher 2010-02-19 10:24:05 EST
I believe that the correct URL here is:
http://ist.mit.edu/services/athena

as Hesiod and hesinfo originated as part of Project Athena. Perhaps an optional comment in the spec explaining why this is not fully accurate.
Comment 4 Nalin Dahyabhai 2010-02-19 15:23:35 EST
There's not much in the way of specific information there.  I'm not exactly keen on sending a Fedora user digging through MIT's site-specific docs to find what little there is about hesinfo and hesiod.  Is it alright with you if that just stays unset?
Comment 5 Stephen Gallagher 2010-02-19 15:33:36 EST
Works for me.
Comment 6 Nalin Dahyabhai 2010-02-19 15:44:15 EST
The other change has been made on the devel branch and tagged.  Is there anything else before, I guess, we close this one?
Comment 7 Stephen Gallagher 2010-02-19 15:58:05 EST
Could you post the fixed SPEC, just for a last look?
Comment 8 Nalin Dahyabhai 2010-02-19 16:25:57 EST
Might as well get it straight from CVS:
http://cvs.fedoraproject.org/viewvc/devel/hesinfo/hesinfo.spec?revision=1.9&view=markup

Note You need to log in before you can comment on or make changes to this bug.