Bug 225913 - Merge Review: irqbalance
Merge Review: irqbalance
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:07 EST by Nobody's working on this, feel free to take it
Modified: 2009-07-31 14:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-31 14:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lemenkov: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:07:19 EST
Fedora Merge Review: irqbalance

http://cvs.fedora.redhat.com/viewcvs/devel/irqbalance/
Initial Owner: nhorman@redhat.com
Comment 1 Peter Lemenkov 2009-07-27 15:22:08 EDT
I'll review it.
Comment 2 Neil Horman 2009-07-27 15:40:15 EDT
I'm sorry, whats the purpose of this review?
Comment 3 Jason Tibbitts 2009-07-27 15:46:22 EDT
All packages which were in Fedora Core at the time of the merge between Core and Extras need to be reviewed for compliance with the packaging guidelines.  Tickets were opened 2.5 years ago for this, but progress has been slow.
Comment 4 Neil Horman 2009-07-27 15:54:03 EDT
ah, that explains my confusion.  Thanks!
Comment 5 Peter Lemenkov 2009-07-28 06:07:57 EDT
The package is in so sorrow state, so it doesn't even builds on my machine.
OK,here is a list of issues:

* The package doesn't honours optflags. Moreover, it adds -Os ("optimize foir size") parameter to the list of GCC keys. I'm not sure whether it conflicts with our -O2, since I'm not keen in GCC tweaking. However, it may be easily removed at %prep stage (adding of something like that - sed -i s/-Os//g %{name}-%{version}/Makefile )

* ExclusiveArch directive should use macro %{ix86} instead of "i386 i586"

* Use Requires(Pre,Preun) instead of Prereq

* Unneeded Requires - /sbin/service

* BuildRoot MUST contain at least %{name}, %{version} and %{release}. See recommended values here:

https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRoot_tag

Although this directive is obsolete since F-10, I think it's a good idea to manually specify it, just in case, that the only spec will be used both in Fedora and in RHEL/EPEL/Whatever.

* No parallel make. See below my suggestions, regarding %build section.

* The long line above should be shortened ( rm -rf $RPM_BUILD_ROOT will be enough):
[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT; 

* rm -rf $RPM_BUILD_ROOT must be in %install section, and not in %build

* Both %build and %install sections are highly exaggerated. You don't need to manually create all these directories - "install" utility can do all this work for us.

* inconsistent use of macros. Sometimes you're using $RPM_BUILD_ROOT and sometimes %{buildroot}.

* No need to explicitly add Requires: glib2

* No URL tag.

* Summary ended with dot.

* %{_sysconfdir}/sysconfig/irqbalance should be marked ad config

That's all issues, I found so far in the spec-file, but there are some issues in the init-script as well:

[petro@Sulaco SPECS]$ rpmlint ../RPMS/ppc/irqbalance-*
irqbalance.ppc: W: obsolete-not-provided kernel-utils
irqbalance.ppc: E: malformed-line-in-lsb-comment-block # 
irqbalance.ppc: W: missing-lsb-keyword Required-Start in /etc/rc.d/init.d/irqbalance
irqbalance.ppc: W: missing-lsb-keyword Required-Stop in /etc/rc.d/init.d/irqbalance
irqbalance.ppc: W: service-default-enabled /etc/rc.d/init.d/irqbalance
irqbalance.ppc: W: service-default-enabled /etc/rc.d/init.d/irqbalance
2 packages and 0 specfiles checked; 1 errors, 5 warnings.
[petro@Sulaco SPECS]$ 

Actually, I'm not sure, whether this package should be started by default or not, but I'm sure other issues should be addressed.


Here is the spec-file with all my suggestions:

http://peter.fedorapeople.org/irqbalance.spec
Comment 7 Peter Lemenkov 2009-07-31 06:16:17 EDT
Fixed rpmlint error in the init-script and made some cosmetic changes in the spec-file:

http://peter.fedorapeople.org/irqbalance.spec
http://peter.fedorapeople.org/irqbalance-0.55-17.fc11.src.rpm
Comment 8 Peter Lemenkov 2009-07-31 14:05:39 EDT
Ok, I just uploaded my fixes and requested rebuild for devel branch.

I think this ticket can be closed now, and package is 

APPROVED.

Note You need to log in before you can comment on or make changes to this bug.