Bug 2259218 - Super+space shortcut does not work with some input methods
Summary: Super+space shortcut does not work with some input methods
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 39
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: GNOME SIG Unassigned
QA Contact: Fedora Extras Quality Assurance
URL: https://gitlab.gnome.org/GNOME/gnome-...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-19 16:03 UTC by Kan-Ru Chen
Modified: 2024-03-04 14:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-04 14:03:06 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Kan-Ru Chen 2024-01-19 16:03:52 UTC
This is already reported to upstream but I feel it should be a blocker for F40 so I'm reposting the bug here.

It affects ibus-cangjie, ibus-table-cangjie, ibus-chewing, ibus-libzhuyin, ibus-mozc and maybe more.

--- original report ---

Affected version

OS: Fedora 39
GNOME version: GNOME 45
Windowing: Wayland
Issue happens regardless of extensions installed.


Bug summary
Super+space inputs U+3000 (ideographic space / fullwidth space) instead of changing keyboard layouts in certain layouts when focused in any text field. Tested to affect both ibus-cangjie and ibus-table-cangjie, likely to affect other Chinese inputs too.

Steps to reproduce

Use a Cangjie input method (either ibus-cangjie or ibus-table-cangjie).
Change preferences to disable half-width forms or enable full-width punctuation.
Set keyboard to Chinese input.
Press super+space while focused in a text field.


What happened
U+3000 is inputted.

What did you expect to happen
GNOME switches to the previously used layout or enables keyboard layout select screen.

Other notes
Tested not to affect ibus-anthy. This was not an issue in versions GNOME 44 and prior.
Observed to affect only the individual input layout. (e.g. switching from English to Cangjie in a text field does not produce the error, but the reverse does.)

Reproducible: Always

Steps to Reproduce:
1. Setup any affected language and input method
2. Switch to the input method by Super+Space
3. Attempt to switch back to English by Super+Space again
Actual Results:  
Cannot switch to English, instead a white space is inserted.

Expected Results:  
Should be able to switch between input methods by Super+Space

Upstream bug report https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/7172

Comment 1 Fedora Blocker Bugs Application 2024-02-12 23:05:26 UTC
Proposed as a Blocker for 40-final by Fedora user kanru using the blocker tracking app because:

 Upstream bug https://gitlab.gnome.org/GNOME/mutter/-/issues/3209

This hinders the input method experience out of the box and often users don't know how to get out of the state.

Symptoms
- cannot switch input method - can be workaround by input methods, I prepared a pull request for ibus-chewing at https://src.fedoraproject.org/rpms/ibus-chewing/pull-request/2
- cannot invoke some <Super> key shortcuts like moving windows to workspaces. Might need a fix in mutter or ibus.

Comment 2 Kan-Ru Chen 2024-03-04 14:03:06 UTC
No longer reproducible during i18n test week.


Note You need to log in before you can comment on or make changes to this bug.