Bug 225952 - Merge Review: jrefactory
Merge Review: jrefactory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Spike
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:13 EST by Nobody's working on this, feel free to take it
Modified: 2010-10-28 08:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 08:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
SpikeFedora: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:13:46 EST
Fedora Merge Review: jrefactory

http://cvs.fedora.redhat.com/viewcvs/devel/jrefactory/
Initial Owner: dbhole@redhat.com
Comment 1 Spike 2010-10-27 05:15:21 EDT
I'll take this one.
Comment 2 Spike 2010-10-27 06:04:50 EDT
=== REQUIRED ITEMS ===
[x]  Rpmlint output:
jrefactory.src: W: name-repeated-in-summary C JRefactory
jrefactory.src: W: spelling-error %description -l en_US refactoring -> re factoring, re-factoring, factoring
jrefactory.noarch: W: name-repeated-in-summary C JRefactory
jrefactory.noarch: W: spelling-error %description -l en_US refactoring -> re factoring, re-factoring, factoring
jrefactory.noarch: W: no-documentation
3 packages and 1 specfiles checked; 0 errors, 5 warnings.

No problem.

[x]  Package is named according to the Package Naming Guidelines[1].
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines[2].
[x]  Package successfully compiles and builds into binary rpms.
[!]  Buildroot is correct (%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n))
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines[3,4].
[!]  License field in the package spec file matches the actual license.
License type:
[-]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[-]  All independent sub-packages have license of their own
[x]  Spec file is legible and written in American English.
[x]  Sources used to build the package matches the upstream source, as provided in the spec URL.
MD5SUM this package    : 7ec44de6d9973eb0d1dfbcf3f903c520
MD5SUM upstream package: 7ec44de6d9973eb0d1dfbcf3f903c520
[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines[5].
[x]  Package must own all directories that it creates.
[x]  Package requires other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[x]  Permissions on files are set properly.
[x]  Package has a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
[x]  Package consistently uses macros.
[x]  Package contains code, or permissable content.
[-]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[x]  Javadoc documentation files are generated and included in -javadoc subpackage
[!]  Packages have proper BuildRequires/Requires on jpackage-utils
[x]  Javadoc subpackages have Require: jpackage-utils
[-]  Package uses %global not %define
[-]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)
[!]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.


=== Other suggestions ===
[x]  If possible use upstream build method (maven/ant/javac)
[x]  Javadocs are placed in %{_javadocdir}/%{name}-%{version} with %{_javadocdir}/%{name} symlink
[x]  Jar files are installed to %{_javadir}/%{name}-%{version}.jar with %{_javadir}/%{name}.jar (unversioned) symlink
[-]  If package contains pom.xml files install it (including depmaps) even when building with ant 
[x]  Avoid having BuildRequires on exact NVR unless necessary
[x]  Package has BuildArch: noarch (if possible)
[x]  Latest version is packaged.
[x]  Reviewer should test that the package builds in mock.
Tested on: fedora-rawhide-i386



=== Issues ===
1. Buildroot
2. License: I'm not sure about the license tag. The upstream license (http://jrefactory.sourceforge.net/license.txt) looks like ASL 1.1, but where are the BSD and GPL+ parts?
3. Requires: At least jpackage-utils and java is need according to current java-packaging guidelines
4. Bundled jar are still present as backup files in jrefactory/jar/

=== Final Notes ===
1. A short comment on the patches used and the statements in prep would be nice. (why is PMDLookAndFeel.java removed etc).
Comment 3 Alexander Kurtakov 2010-10-28 08:00:59 EDT
> === Issues ===
> 1. Buildroot
Removed.

> 2. License: I'm not sure about the license tag. The upstream license
> (http://jrefactory.sourceforge.net/license.txt) looks like ASL 1.1, but where
> are the BSD and GPL+ parts?
There are sources using BSD and GPL licenses.
> 3. Requires: At least jpackage-utils and java is need according to current
> java-packaging guidelines
Fixed.
> 4. Bundled jar are still present as backup files in jrefactory/jar/
Fixed.
> 
> === Final Notes ===
> 1. A short comment on the patches used and the statements in prep would be
> nice. (why is PMDLookAndFeel.java removed etc).
Fixed.

http://koji.fedoraproject.org/koji/buildinfo?buildID=202307
Comment 4 Spike 2010-10-28 08:06:52 EDT
Ok, looks good. 

================
*** APPROVED ***
================
Comment 5 Alexander Kurtakov 2010-10-28 08:10:41 EDT
Package is approved.
Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.