Bug 225954 - Merge Review: junit
Merge Review: junit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:14 EST by Nobody's working on this, feel free to take it
Modified: 2009-12-04 15:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 15:10:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fitzsim: fedora‑review+


Attachments (Terms of Use)
Spec File (4.79 KB, patch)
2007-02-09 16:17 EST, Tania Bento
no flags Details | Diff
Spec File (4.76 KB, patch)
2007-02-09 16:46 EST, Tania Bento
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:14:00 EST
Fedora Merge Review: junit

http://cvs.fedora.redhat.com/viewcvs/devel/junit/
Initial Owner: dbhole@redhat.com
Comment 1 Tania Bento 2007-02-09 16:17:12 EST
Created attachment 147809 [details]
Spec File
Comment 2 Tania Bento 2007-02-09 16:46:44 EST
Created attachment 147817 [details]
Spec File

The one I previously posted was the wrong patch.  Sorry.
Comment 3 Tania Bento 2007-02-09 16:58:58 EST
Here are a list to my changes:

- I changed the License to CPL, because the Packaging Guidelines states that we
should use standard abbreviations and rpmlint generated a warning stating that
"Common Public License" was not recognized.

- I changed the Group to Development/Tools/Java from Development/Testing, as was
suggested by Tom.

- I switched the source back to junit3.8-2.zip because someone was misinformed
and had removed all the binaries.

- I removed "-rm -rf $RPM_BUILD_ROOT" from the %prep section because rpmlint
generated a warning stating that $RPM_BUILD_ROOT should not be touched in the
prep stage because it will break short circuiting .

- I added "-rm -rf $RPM_BUILD_ROOT" to the %install section because rpmlint
generated an error stating that we should clean $RPM_BUILD_ROOT this section.

- The %post and %postun sections for demo were removed because they were causing
an error while building.

- I had to "escape" the macros used in the %changelog because macros are
expanded in the %changelog section.

- The --excludes were added to aot-compile-rpm to solve a building error.  

If someone could kindly review this, that would be great.  Thanks.
Tania
Comment 4 Thomas Fitzsimmons 2007-02-09 17:59:06 EST
Your patch contains whitespace changes that make it hard to see the real
changes.  Can you repost a cleaner one?
Comment 5 Thomas Fitzsimmons 2007-02-12 18:52:57 EST
I see you were just running untabify.  I made a few more small changes and
committed this on your behalf.

$ rpmlint
/home/fitzsim/sources/rpms/junit/devel/i386/junit-demo-3.8.2-3jpp.1.i386.rpm
W: junit-demo no-documentation

OK because this is a sub-package and the base package contains documentation.

$ rpm -qp --provides
/home/fitzsim/sources/rpms/junit/devel/i386/junit-3.8.2-3jpp.1.i386.rpm
junit-3.8.2.jar.so  
junit = 3.8.2-3jpp.1

$ rpm -qp --requires
/home/fitzsim/sources/rpms/junit/devel/i386/junit-3.8.2-3jpp.1.i386.rpm
/bin/sh  
/bin/sh  
java-gcj-compat  
java-gcj-compat  
libc.so.6  
libc.so.6(GLIBC_2.1.3)  
libdl.so.2  
libgcc_s.so.1  
libgcc_s.so.1(GCC_3.0)  
libgcj_bc.so.1  
libm.so.6  
libpthread.so.0  
librt.so.1  
libz.so.1  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  

$ rpm -qp --provides
/home/fitzsim/sources/rpms/junit/devel/i386/junit-manual-3.8.2-3jpp.1.i386.rpm
junit-manual = 3.8.2-3jpp.1

$ rpm -qp --requires
/home/fitzsim/sources/rpms/junit/devel/i386/junit-manual-3.8.2-3jpp.1.i386.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

$ rpm -qp --provides
/home/fitzsim/sources/rpms/junit/devel/i386/junit-javadoc-3.8.2-3jpp.1.i386.rpm
junit-javadoc = 3.8.2-3jpp.1

$ rpm -qp --requires
/home/fitzsim/sources/rpms/junit/devel/i386/junit-javadoc-3.8.2-3jpp.1.i386.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

$ rpm -qp --requires
/home/fitzsim/sources/rpms/junit/devel/i386/junit-demo-3.8.2-3jpp.1.i386.rpm
java-gcj-compat  
java-gcj-compat  
junit = 3.8.2-3jpp.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

$ rpm -qp --provides
/home/fitzsim/sources/rpms/junit/devel/i386/junit-demo-3.8.2-3jpp.1.i386.rpm
junit-demo = 3.8.2-3jpp.1

$ rpm -qp --provides
/home/fitzsim/sources/rpms/junit/devel/i386/junit-debuginfo-3.8.2-3jpp.1.i386.rpmjunit-3.8.2.jar.so.debug
 
junit-debuginfo = 3.8.2-3jpp.1

$ rpm -qp --requires
/home/fitzsim/sources/rpms/junit/devel/i386/junit-debuginfo-3.8.2-3jpp.1.i386.rpm 
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

APPROVED.
Comment 6 Alexander Kurtakov 2009-10-01 03:51:18 EDT
This package is approved. Can we close the Merge review now?
Comment 7 Alexander Kurtakov 2009-12-04 15:10:12 EST
Long time in Fedora and review approved more than 2 years ago.

Note You need to log in before you can comment on or make changes to this bug.