Bug 225998 - Merge Review: libdmx
Merge Review: libdmx
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:20 EST by Nobody's working on this, feel free to take it
Modified: 2009-02-21 18:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 18:59:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oget.fedora: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:20:35 EST
Fedora Merge Review: libdmx

http://cvs.fedora.redhat.com/viewcvs/devel/libdmx/
Initial Owner: sandmann@redhat.com
Comment 1 Orcan Ogetbil 2009-01-17 21:07:17 EST
This pretty much has the same issues with libXinerama. I just copied/pasted the same bits from that review. Note that there are a few differences (the last two issues).

* Summary and especially the description are bizarre. Can you update them. You can find these on the manpage:
   DMX - X Window System DMX (Distributed Multihead X) extension

   The DMX extension provides support for communication with and control of Xdmx
   server.  Attributes of the Xdmx server and of the back-end screens attached to
   the server can be queried and modified via this protocol.

* rpmlint says
   libdmx.src:18: W: unversioned-explicit-obsoletes XFree86-libs
   libdmx.src:18: W: unversioned-explicit-obsoletes xorg-x11-libs
   libdmx.src:32: W: unversioned-explicit-obsoletes XFree86-devel
   libdmx.src:32: W: unversioned-explicit-obsoletes xorg-x11-devel
   libdmx.x86_64: E: zero-length /usr/share/doc/libdmx-1.0.2/README
   libdmx.x86_64: E: zero-length /usr/share/doc/libdmx-1.0.2/AUTHORS
   libdmx.x86_64: W: obsolete-not-provided XFree86-libs
   libdmx.x86_64: W: obsolete-not-provided xorg-x11-libs
   libdmx-devel.x86_64: W: obsolete-not-provided XFree86-devel
   libdmx-devel.x86_64: W: obsolete-not-provided xorg-x11-devel
The zero-length files are obviously not needed so they should be removed. The obsoletes look very problematic. Can you fix those (or alternatively explain them in the SPEC file as comments)?

* BR: libXau-devel is not needed. Afaict it is not used.

* BRs: libX11-devel pkgconfig and xorg-x11-proto-devel are not needed. They will be picked up by libXext-devel

* Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for directory ownership and usability). This applies to the devel package.

! Try to make use of the %{name} macro (e.g. files sections).

* Do we need this line?
   #%dir %{_mandir}/man3x

* There is no "make" command in the SPEC file. The "make" is done via "make install" which is not good. Please add a parallel "make" .


Adding Adam and Matthias to the CC since they were the last known maintainers. Sorry if this was not desired.
Comment 2 Adam Jackson 2009-02-21 15:06:10 EST
Most of this is fixed in 1.0.2-7.  Haven't touched %description yet, not really sure what's a good template.  Most of the X libs have a similar description, so it'd be nice to keep them consistent.
Comment 3 Jason Tibbitts 2009-02-21 17:50:12 EST
I went ahead and used
Summary: X.Org X11 DMX runtime library
%description
The X.Org X11 DMX (Distributed Multihead X) runtime library.

which seem to satisfy the usual goals for these tags (summary doesn't include package name, both are basically useful as an explanation and bizarre acronyms are expanded in the description.  They also don't stray overly from what other X packages are using. I guess the descriptions aren't grammatically sentences, but adding "This package contains" to them seems to be beyond pointless.

At this point I would approve this package were it my review, but that's Orcan's call.  I'm only sticking my head in here because ajax asked me to take a look.
Comment 4 Orcan Ogetbil 2009-02-21 18:59:54 EST
I gave the excerpt from the manpage just for this purpose, and "Most X libs do it this way" is really not a good defense. Anyhow, Jason's correction made things a little better. Since there is no real guideline that a packager must obey about the quality of the summary/description, I can't put a blocker.


----------------------------------------------
This Merge Review (libdmx) is APPROVED by oget
----------------------------------------------

Note You need to log in before you can comment on or make changes to this bug.