Bug 226024 - Merge Review: libgssapi
Merge Review: libgssapi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Susi Lehtola
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:24 EST by Nobody's working on this, feel free to take it
Modified: 2009-10-06 23:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-26 08:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
susi.lehtola: fedora‑review+


Attachments (Terms of Use)
Patch to spec file in devel branch that fixes all issues (2.16 KB, patch)
2009-07-16 08:23 EDT, Susi Lehtola
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:24:32 EST
Fedora Merge Review: libgssapi

http://cvs.fedora.redhat.com/viewcvs/devel/libgssapi/
Initial Owner: steved@redhat.com
Comment 1 Susi Lehtola 2009-07-16 07:59:51 EDT
Taking over review.
Comment 2 Susi Lehtola 2009-07-16 08:22:15 EDT
MUST: The spec file for the package is legible and macros are used consistently. NEEDSWORK
- Obsolete buildroot, obsolete PreReq usage.
- %configure done in %prep instead of %build, use of %buildroot in %configure.
- %makeinstall used instead of make install DESTDIR=%buildroot

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}. OK
MUST: The package must be licensed with a Fedora approved license and meet the  Licensing Guidelines. OK
MUST: The License field in the package spec file must match the actual license. OK
MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. OK
MUST: The package MUST successfully compile and build into binary rpms. OK
MUST: The spec file MUST handle locales properly. N/A

MUST: Optflags are used and time stamps preserved. NEEDSWORK
- Time stamps on headers are not preserved.

MUST: Packages containing shared library files must call ldconfig. OK
MUST: A package must own all directories that it creates or require the package that owns the directory. OK
MUST: Files only listed once in %files listings. OK
MUST: Debuginfo package is complete. OK

MUST: Permissions on files must be set properly. ~OK
- No need to set the permissions manually.

MUST: Clean section exists. OK
MUST: Large documentation files must go in a -doc subpackage. N/A

MUST: All relevant items are included in %doc. Items in %doc do not affect runtime of application. NEEDSWORK
- Missing COPYING.

MUST: Static libraries must be in a -static package. NEEDSWORK

MUST: Header files must be in a -devel package. OK
MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'. OK
MUST: If a package contains library files with a suffix then library files ending in .so must go in a -devel package. OK
MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency. OK

MUST: Packages does not contain any .la libtool archives. NEEDSWORK
- Can't drop them now, though, since they already exist in the package.

MUST: Desktop files are installed properly. N/A
MUST: No file conflicts with other packages and no general names. OK
MUST: Buildroot cleaned before install. OK
SHOULD: %{?dist} tag is used in release. OK
SHOULD: If the package does not include license text(s) as separate files from upstream, the packager should query upstream to include it. OK
SHOULD: The package builds in mock. OK
Comment 3 Susi Lehtola 2009-07-16 08:23:22 EDT
Created attachment 353975 [details]
Patch to spec file in devel branch that fixes all issues
Comment 4 Susi Lehtola 2009-07-16 08:24:02 EDT
Apply the patch in comment #3 to the devel branch and I'll approve the package.
Comment 5 Susi Lehtola 2009-08-05 07:24:16 EDT
ping steved
Comment 6 Peter Lemenkov 2009-09-25 06:18:56 EDT
All issues were addressed and fixed.

I just wondering who's still requiring static library, and I hope that someone will remove *.la file completely :) (can't do it by myself, since it will be a change in ABI).

I just updated cvs, and will rebuild it shortly.
Comment 7 Fedora Update System 2009-09-25 06:48:01 EDT
libgssapi-0.11-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libgssapi-0.11-7.fc11
Comment 8 Fedora Update System 2009-09-25 06:48:06 EDT
libgssapi-0.11-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libgssapi-0.11-7.fc10
Comment 9 Susi Lehtola 2009-09-25 08:58:33 EDT
Can you drop the static library altogether?

You can drop the .la files in rawhide, since ABI changes are allowed in rawhide.
Comment 10 Steve Dickson 2009-09-25 15:47:01 EDT
I would say go for it... if some complains we can always put it back or figure out why  they need it...
Comment 11 Peter Lemenkov 2009-09-26 08:33:40 EDT
Done (in devel branch).
Comment 12 Susi Lehtola 2009-09-26 08:40:11 EDT
Hmm, you shouldn't need to obsolete the static library since it hasn't been in existence as a separate package and you just added the static provide a day ago.

**

All issues have been fixed and this package has been

APPROVED
Comment 13 Peter Lemenkov 2009-09-26 08:53:52 EDT
(In reply to comment #12)
> Hmm, you shouldn't need to obsolete the static library since it hasn't been in
> existence as a separate package and you just added the static provide a day
> ago.

I did it just to be sure that everything will be ok. :)

> All issues have been fixed and this package has been
> 
> APPROVED  

Good.
I suppose that it's safe to close this ticket.
Comment 14 Fedora Update System 2009-10-06 23:11:59 EDT
libgssapi-0.11-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-10-06 23:13:10 EDT
libgssapi-0.11-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.