Bug 226054 - Merge Review: libuser
Merge Review: libuser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 14:28 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 00:33:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
tibbs: fedora‑review+


Attachments (Terms of Use)
Patch to split off libuser-python (1.50 KB, patch)
2007-06-22 09:08 EDT, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:28:27 EST
Fedora Merge Review: libuser

http://cvs.fedora.redhat.com/viewcvs/devel/libuser/
Initial Owner: mitr@redhat.com
Comment 1 Yanko Kaneti 2007-06-22 09:08:00 EDT
Created attachment 157616 [details]
Patch to split off libuser-python
Comment 2 Miloslav Trmač 2007-08-08 11:40:24 EDT
Patch applied, thanks!
Comment 3 Yanko Kaneti 2007-08-08 16:52:52 EDT
Just a notice that the python split affects the Requires for at least anaconda,
firstboot, system-config-rootpassword, system-config-samba and system-config-users.
Comment 4 Miloslav Trmač 2007-08-08 17:05:46 EDT
Yes, I have filed bugs against all of the packages.
Comment 5 Jason Tibbitts 2008-01-07 16:27:10 EST
As discussed on IRC, there's no upstream for this package.  So the various
rpmlint complaints like:
  libuser.x86_64: W: no-url-tag
are OK.  Following http://fedoraproject.org/wiki/Packaging/SourceURL this
needs a comment in the spec, which I'll commit shortly.

This shows up when you run rpmlint on the installed package:
  libuser.x86_64: W: unused-direct-shlib-dependency 
   /usr/lib64/libuser.so.1.1.10 /lib64/libdl.so.2
I don't think it's a big issue but perhaps you know what causes it.  It just
looks like libuser.so is linked against libdl.so but doesn't actually call any
symbols from it.

I've seen the "WITH_SELINUX" stuff in other formerly core packages and I have
to say I'm not quite sure what utility it has these days where everything is
always built with selinux support.

I think the bit at the end of %install really should be in a %check section
instead, but that's not the kind of change I want to commit without consulting
you.

This file in the -devel package looks a bit odd:
  /usr/include/libuser/default.-c
Any idea if that's a typo?

Checklist:
* No upstream source to compare against.
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* summary is OK.
* description is OK.
* build root is OK.
* license field matches the actual license.
* license is open source-compatible.
* license text included in package.
* BuildRequires are proper.
* compiler flags are appropriate.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly
* debuginfo package looks complete.
* rpmlint has acceptable complaints.
* final provides and requires are sane:


  libuser-0.56.6-4.x86_64.rpm
   config(libuser) = 0.56.6-4
   libuser.so.1()(64bit)
   libuser_files.so()(64bit)
   libuser_ldap.so()(64bit)
   libuser_shadow.so()(64bit)
   libuser = 0.56.6-4
  =
   /sbin/ldconfig
   config(libuser) = 0.56.6-4
   libglib-2.0.so.0()(64bit)
   libgmodule-2.0.so.0()(64bit)
   libgobject-2.0.so.0()(64bit)
   libldap-2.4.so.2()(64bit)
   libpam.so.0()(64bit)
   libpam.so.0(LIBPAM_1.0)(64bit)
   libpam_misc.so.0()(64bit)
   libpam_misc.so.0(LIBPAM_MISC_1.0)(64bit)
   libpopt.so.0()(64bit)
   libpopt.so.0(LIBPOPT_0)(64bit)
   libselinux.so.1()(64bit)
   libuser.so.1()(64bit)
   
  libuser-devel-0.56.6-4.x86_64.rpm
   libuser-devel = 0.56.6-4
  =
   glib2-devel
   libuser = 0.56.6-4
   libuser.so.1()(64bit)
   
  libuser-python-0.56.6-4.x86_64.rpm
   libusermodule.so()(64bit)
   libuser-python = 0.56.6-4
  =
   libglib-2.0.so.0()(64bit)
   libgobject-2.0.so.0()(64bit)
   libpam.so.0()(64bit)
   libpam.so.0(LIBPAM_1.0)(64bit)
   libpam_misc.so.0()(64bit)
   libpam_misc.so.0(LIBPAM_MISC_1.0)(64bit)
   libselinux.so.1()(64bit)
   libuser = 0.56.6-4
   libuser.so.1()(64bit)
   python(abi) = 2.5

* ldconfig called properly
* unversioned .so files are in the -devel package.
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* scriptlets look OK (ldconfig)
* code, not content.
* documentation is small, so no -docs subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.
* headers are in the -devel package and are in a subdirectory to avoid
   conflicts.
* pkgconfig file is in the -devel package.
* no static libraries.
* no libtool .la files.
Comment 6 Miloslav Trmač 2008-01-08 08:00:47 EST
Thanks for the review!

(In reply to comment #5)
> This shows up when you run rpmlint on the installed package:
>   libuser.x86_64: W: unused-direct-shlib-dependency 
>    /usr/lib64/libuser.so.1.1.10 /lib64/libdl.so.2
> I don't think it's a big issue but perhaps you know what causes it.  It just
> looks like libuser.so is linked against libdl.so but doesn't actually call any
> symbols from it.
The -ldl is added by libgmodule's pkgconfig files.  I'm not happy about it but I
don't think this should be hacked around in libuser.
 
> I've seen the "WITH_SELINUX" stuff in other formerly core packages and I have
> to say I'm not quite sure what utility it has these days where everything is
> always built with selinux support.
Yes, it only encourages bug reports when !WITH_SELINUX breaks.  I'll remove it.

> I think the bit at the end of %install really should be in a %check section
> instead, but that's not the kind of change I want to commit without consulting
> you.
Probably, I'll try that.

> This file in the -devel package looks a bit odd:
>   /usr/include/libuser/default.-c
> Any idea if that's a typo?
That's not a typo.  I should really get rid of this file...
Comment 7 Jason Tibbitts 2008-01-08 19:27:23 EST
I updated my CVS tree but don't see any updates; please do let me know when you
commit your changes.
Comment 8 Miloslav Trmač 2008-01-09 11:26:24 EST
Available now; or get libuser-0.56.7-1 from rawhide.
Comment 9 Jason Tibbitts 2008-01-11 00:33:00 EST
Looks quite clean now.  I'd say we're done.

APPROVED

Note You need to log in before you can comment on or make changes to this bug.