Bug 226107 - Merge Review: lslk
Summary: Merge Review: lslk
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 19:35 UTC by Nobody's working on this, feel free to take it
Modified: 2010-10-06 09:50 UTC (History)
2 users (show)

Fixed In Version: lslk-1.29-24.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 09:50:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora-review+


Attachments (Terms of Use)
spec cleanup (1.72 KB, patch)
2010-10-05 15:48 UTC, Parag AN(पराग)
no flags Details | Diff

Description Nobody's working on this, feel free to take it 2007-01-31 19:35:27 UTC
Fedora Merge Review: lslk

http://cvs.fedora.redhat.com/viewcvs/devel/lslk/
Initial Owner: kzak@redhat.com

Comment 1 Parag AN(पराग) 2010-10-05 15:48:56 UTC
Created attachment 451705 [details]
spec cleanup

This git patch clean this package for this review. Please commit this patch or allow to commit.

Comment 2 Karel Zak 2010-10-06 08:28:22 UTC
Committed, pushed to rawhide. THANKS!

Comment 3 Parag AN(पराग) 2010-10-06 08:47:58 UTC
oops! looks like my patch just added %doc but when I locally built this new package, missed to add them actually and thus rpmlint was clean.

With the new build rpmlint is complaining

lslk.x86_64: E: non-standard-executable-perm /usr/share/doc/lslk-1.29/Inventory 0555L
A standard executable should have permission set to 0755. If you get this
message, it means that you have a wrong executable permissions in some files
included in your package.

lslk.x86_64: W: spurious-executable-perm /usr/share/doc/lslk-1.29/Inventory
The file is installed with executable permissions, but was identified as one
that probably should not be executable.  Verify if the executable bits are
desired, and remove if not.

This can be fixed by adding following line in end of %prep section
chmod 644 Inventory

Can you please fix this?

Comment 4 Karel Zak 2010-10-06 09:42:55 UTC
(In reply to comment #3)
> This can be fixed by adding following line in end of %prep section
> chmod 644 Inventory
>
> Can you please fix this?

 Fixed.

Comment 5 Parag AN(पराग) 2010-10-06 09:50:16 UTC
Thanks for quick fix.

APPROVED this review.


Note You need to log in before you can comment on or make changes to this bug.