Bug 226116 - Merge Review: mailcap
Merge Review: mailcap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 14:36 EST by Nobody's working on this, feel free to take it
Modified: 2008-01-24 08:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 08:08:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: fedora‑review+


Attachments (Terms of Use)
Patch to correct macro in changelog. (425 bytes, patch)
2007-12-26 16:02 EST, Jon Ciesla
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:36:32 EST
Fedora Merge Review: mailcap

http://cvs.fedora.redhat.com/viewcvs/devel/mailcap/
Initial Owner: mlichvar@redhat.com
Comment 1 Jon Ciesla 2007-12-26 15:11:42 EST
rpmlint:
SRPM:
mailcap.src:164: W: macro-in-%changelog variables
Macros are expanded in %changelog too, which can in unfortunate cases lead
to the package not building at all, or other subtle unexpected conditions that
affect the build.  Even when that doesn't happen, the expansion results in
possibly "rewriting history" on subsequent package revisions and generally
odd entries eg. in source rpms, which is rarely wanted.  Avoid use of macros
in %changelog altogether, or use two '%'s to escape them, like '%%foo'.

mailcap.src: W: no-url-tag
The URL tag is missing.


RPM:
mailcap.noarch: W: no-url-tag
The URL tag is missing.


These are fixed by changing %variables in 164 to %%variables, and including a
URL tag.  Who is techincally upstream, Red Hat or Fedora?
Comment 2 Ville Skyttä 2007-12-26 15:30:16 EST
See also bug 388481
Comment 3 Jon Ciesla 2007-12-26 15:37:32 EST
Agreed.
Comment 4 Jon Ciesla 2007-12-26 16:02:45 EST
Created attachment 290424 [details]
Patch to correct macro in changelog.
Comment 5 Miroslav Lichvar 2008-01-22 10:49:13 EST
mailcap currently doesn't have a home page. It will be moved to
hosted.fedoraproject.org once there is a place to upload tarballs.

In mailcap-2.1.26, the macro in changelog is escaped and there is a comment
added how to create the tarball.
Comment 6 Jon Ciesla 2008-01-22 12:28:42 EST
When will that be?  Because everything else about this checks out, except for
issues stemming from the lack of an "upstream", i.e. Source0 URL, URL tag,
source MD5 check, etc.  Those are the only blockers.
Comment 7 Miroslav Lichvar 2008-01-24 08:00:02 EST
The packaging guidelines don't seem to require URL tag and for the source tag
there is a comment explaining how to recreate the tarball from CVS, so I think
it's ok to approve the package if there are no other issues.
Comment 8 Jon Ciesla 2008-01-24 08:08:56 EST
Ok. works for me.

APPROVED.

Note You need to log in before you can comment on or make changes to this bug.