Bug 226125 - Merge Review: man-pages-it
Merge Review: man-pages-it
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrea Musuruane
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:37 EST by Nobody's working on this, feel free to take it
Modified: 2008-06-17 15:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 18:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmlint output (12.52 KB, text/plain)
2007-11-21 03:20 EST, Andrea Musuruane
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:37:36 EST
Fedora Merge Review: man-pages-it

http://cvs.fedora.redhat.com/viewcvs/devel/man-pages-it/
Initial Owner: bgroh@redhat.com
Comment 1 Andrea Musuruane 2007-11-21 03:20:26 EST
Created attachment 265771 [details]
rpmlint output
Comment 2 Andrea Musuruane 2007-11-21 03:20:49 EST
 [x] Spec file name must match the base package %{name}, in the format %{name}.spec.
 [!] Package meets the Packaging Guidelines.
 [x] Package successfully compiles and builds into binary rpms on at least one
supported architecture.
     Tested on: f8-i386
 [!] Rpmlint output:
     Attached to this review because it is too long.
 [x] Package is not relocatable.
 [!] Buildroot is correct
 [x] Package is licensed with an open-source compatible license and meets other
legal requirements as defined in the legal section of Packaging Guidelines.
 [!] License field in the package spec file matches the actual license.
     License type: Distributable
 [x] If (and only if) the source package includes the text of the license(s) in
its own file, then that file, containing the text of the license(s) for the
package is included in %doc.
 [x] Spec file is legible and written in American English.
 [x] Sources used to build the package matches the upstream source, as provided
in the spec URL.

577fec8545d9050da0f4695468a7a29e  man-pages-it-2.65.tar.gz
73a11e61f5f42806e20f53f0a5b8446b  man-pages-it-extra-0.5.0.tar.gz

 [x] Package is not known to require ExcludeArch
 [x] All build dependencies are listed in BuildRequires, except for any that are
listed in the exceptions section of Packaging Guidelines.
 [-] The spec file handles locales properly.
 [-] ldconfig called in %post and %postun if required.
 [x] Package must own all directories that it creates.
 [!] Package requires other packages for directories it uses.
 [x] Package does not contain duplicates in %files.
 [-] Permissions on files are set properly.
 [x] Package has a %clean section, which contains rm -rf %{buildroot} (or
$RPM_BUILD_ROOT).
 [!] Package consistently uses macros.
 [x] Package contains code, or permissable content.
 [-] Large documentation files are in a -doc subpackage, if required.
 [-] Package uses nothing in %doc for runtime.
 [-] Header files in -devel subpackage, if present.
 [-] Static libraries in -devel subpackage, if present.
 [-] Package requires pkgconfig, if .pc files are present.
 [-] Development .so files in -devel subpackage, if present.
 [-] Fully versioned dependency in subpackages, if present.
 [-] Package does not contain any libtool archives (.la).
 [-] Package contains a properly installed %{name}.desktop file if it is a GUI
application.
 [x] Package does not own files or directories owned by other packages.

=== SUGGESTED ITEMS ===
 [x] Latest version is packaged.
 [x] Package does not include license text files separate from upstream.
 [x] Description and summary sections in the package spec file contains
translations for supported Non-English languages, if available.
 [x] Reviewer should test that the package builds in mock.
     Tested on: f8-i386
 [x] Package functions as described.
 [-] Scriptlets must be sane, if used.
 [-] The placement of pkgconfig(.pc) files are correct.
 [-] File based requires are sane.


=== Issues ===

1. Summary ends with a period.

2. "Distributable" is not a valid license:
http://fedoraproject.org/wiki/Packaging/LicensingGuidelines?highlight=%28guidelines%29%7C%28licensing%29#head-0e7556b4f56a6612e7334b142107e709b3886449

3. BuildRoot is not good:
http://fedoraproject.org/wiki/Packaging/Guidelines#head-b4fdd45fa76cbf54c885ef0836361319ab962473

4. Source files should use %{name} macro.

5. The following sentence should be removed from the Italian descriptions: "E'
possibile scaricare la versione più aggiornata di queste pagine all'indirizzo
ftp://ftp.pluto.it/pub/pluto/ildp/man". The user should not manually download
and install the Italian man pages on his own.

6. The description file should not be packaged. This info is already used in the
metadata of the RPM.

7. smp_mflag is not used in make. If the parallel building is not supported, it
should be inserted a remark before the make invocation.

8. Man pages are encoded in ISO-8859-1. They must be converted to UTF-8.

9. Doc files have spurious executable permissions.

10. In man-pages-it-extra package a line in the description field is too long.

11. man-pages-it should Requires man, because /usr/share/man/it belongs to that
package.

12. Buildarchitecture tag is obsolete. Use Buildarch.

13. Maybe it is a good idea to define a extra_name macro too.

14. It should be wise to define macros at the beginning of the spec file.


NEEDSWORK.
Comment 3 Andrea Musuruane 2007-11-22 04:11:27 EST
Added current maintainer to CC list.
Comment 4 Ding-Yi Chen 2007-12-04 18:46:52 EST
Issued fixed except the license of this package is POSIX. Wait for the respond
from fedora-legal-list.
Comment 5 Ding-Yi Chen 2007-12-04 21:44:37 EST
Respond from fedora-legal-list:

This copyright is equivalent with IEEE. Fixed the package accordingly
Comment 6 Ding-Yi Chen 2007-12-06 01:43:37 EST
- Fix the conflict with man-1.6e-3.fc7
- man7/iso_8859-1.7 and man7/iso_8859-7.7 are back.
- Upstream change version scheme.
Comment 7 Ding-Yi Chen 2007-12-06 01:45:26 EST
Hi Andrea,

Please ignore the previous comment, unless you are interested in man-pages-ko as
well. :-P

man-pages-it is ready now, would you mind to have a look?

Comment 8 Andrea Musuruane 2007-12-06 08:18:14 EST
(In reply to comment #7)
> Please ignore the previous comment, unless you are interested in man-pages-ko as
> well. :-P

If time permits I'll be glad to :)

> man-pages-it is ready now, would you mind to have a look?

OK. Here we go on again.

New issues:

15. You should not use dos2unix. Use sed instead:
http://fedoraproject.org/wiki/Packaging/Guidelines#head-41d4336fa1af8d74500eb89d3a22410cccc4117d

16. I missed this in the main review. There is no need to specify the builddir
path. You can (and really should) write the lines like the following:

mv %{_builddir}/%{name}-%{version}/description
%{_builddir}/%{name}-%{version}/DESCRIPTION-IT
mv %{_builddir}/%{name}-%{version}/%{extra_pkg_name}/changelog
%{_builddir}/%{name}-%{version}/EXTRA-CHANGELOG

in this way:

mv description DESCRIPTION-IT
mv %{extra_pkg_name}/changelog %{extra_pkg_name}/EXTRA-CHANGELOG

I suggest you to leave extra package docs in %{extra_pkg_name} and then use 

%doc {extra_pkg_name}/EXTRA-CHANGELOG   

but this is not mandatory at all.

Issues still to be solved: 

4, 13, 14. Write the following lines

Source0: ftp://ftp.pluto.it/pub/pluto/ildp/man/man-pages-it-%{version}.tar.gz
Source1:
ftp://ftp.pluto.it/pub/pluto/ildp/man/man-pages-it-extra-%{extra_ver}.tar.gz

in this way:
%define extra_name %{name}-extra
%define extra_ver 0.5.0
%define extra_pkg_name %{extra_name}-%{extra_ver}
Source0: ftp://ftp.pluto.it/pub/pluto/ildp/man/%{name}-%{version}.tar.bz2
Source1: ftp://ftp.pluto.it/pub/pluto/ildp/man/%{extra_pkg_name}.tar.gz

like you did for man-pages-es.

10. rpmlint returns:
man-pages-it-extra.noarch: E: description-line-too-long ufficiale, e che di
solito vengono distribuite assieme ai software. Cerchiamo di
man-pages-it-extra.noarch: E: description-line-too-long indietro rispetto
all'ultima versione del pacchetto di riferimento. E' possibile

5, 6, 12. All these issues were not addressed.

Please do also update the other man packages you own where applicable and notify
the changes to the relevant bugs when done.

Thanks.

Bye,

Andrea.
Comment 9 Andrea Musuruane 2007-12-06 09:14:17 EST
Also missed:

17. You must always use macros instead of full paths: %{_mandir} instead of
/usr/share/man

18. There is no really %build section. Move its content to %prep. Rpmlint will
give a warning with an empty %build section, but in this case it is OK. 

19. You should use 

make install MANDIR=$RPM_BUILD_ROOT%{_mandir}/it

to copy man pages to thier destination. This avoid the checks to update current
installed man pages (there are no current installed man pages since they go in
the buildroot).

Bye,

Andrea.
Comment 10 Fedora Update System 2007-12-06 15:49:26 EST
man-pages-it-2.65-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update man-pages-it'
Comment 11 Fedora Update System 2007-12-06 15:56:10 EST
man-pages-it-2.65-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update man-pages-it'
Comment 12 Fedora Update System 2007-12-07 16:34:36 EST
man-pages-it-2.65-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update man-pages-it'
Comment 13 Andrea Musuruane 2007-12-09 12:55:20 EST
Issues still present:

10. In man-pages-it-extra package a line in the description field is too long.

$ rpmlint man-pages-it-extra-2.65-6.fc8.noarch.rpm
man-pages-it-extra.noarch: E: description-line-too-long ufficiale, e che di
solito vengono distribuite assieme ai software. Cerchiamo di

Format the description text as the following one:
Questo pacchetto contiene la traduzione a cura dell'Italian Linux Documentation
Project (ILDP) delle pagine di manuale che non fanno parte del pacchetto
ufficiale, e che di solito vengono distribuite assieme ai software. Cerchiamo
di mantenere le pagine aggiornate, tuttavia è possibile che alcune pagine
restino indietro rispetto all'ultima versione del pacchetto di riferimento. 

17. You must always use macros instead of full paths. Use %{_mandir} instead of
/usr/share/man in this line:

rm -rf $RPM_BUILD_ROOT/usr/share/man/it/'man??'

Bye,

Andrea.
Comment 14 Andrea Musuruane 2007-12-10 10:44:29 EST
Everything is fine for me in 2.65-7.

APPROVED.

Since this package has been already built, please close this bugzilla review
ticket as NEXTRELEASE.
Comment 15 Ding-Yi Chen 2007-12-10 18:35:05 EST
Andrea,

Thanks for your effort. :-)
Comment 16 Fedora Update System 2008-01-11 17:14:42 EST
man-pages-it-2.65-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update man-pages-it'
Comment 17 Fedora Update System 2008-01-11 17:23:58 EST
man-pages-it-2.65-7.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update man-pages-it'

Note You need to log in before you can comment on or make changes to this bug.