Bug 226126 - Merge Review: man-pages-ja
Merge Review: man-pages-ja
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:37 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 01:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:37:43 EST
Fedora Merge Review: man-pages-ja

http://cvs.fedora.redhat.com/viewcvs/devel/man-pages-ja/
Initial Owner: tagoh@redhat.com
Comment 1 Parag AN(पराग) 2007-09-21 05:52:31 EDT
Preliminary review =>
rpmlint on SRPM gave me
man-pages-ja.src:43: W: rpm-buildroot-usage %build perl %{SOURCE1}
$RPM_BUILD_ROOT | make
$RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
will break short circuiting.

rpmlint on RPM gave me
man-pages-ja.noarch: W: file-not-utf8
/usr/share/doc/man-pages-ja-20070815/translation_lists/SysVinit.translation_list
The character encoding of this file is not UTF-8.  Consider converting it
in the specfile for example using iconv(1).
for all the files in /usr/share/doc/man-pages-ja-20070815/translation_lists/

also,
  Dunno why so many messages in build.log
Use of uninitialized value in numeric comparison (<=>) at script/configure.perl
line 239.

SHOULD:
   preserve timestamps.
   use %defattr(-,root,root,-)
   Update to new upstream release.  
      http://www.linux.or.jp/JM/man-pages-ja-20070915.tar.gz
   Use disttag
    
Comment 3 Parag AN(पराग) 2007-09-27 05:36:07 EDT
I think you should preserve timestamps.
Comment 4 Akira TAGOH 2007-09-27 08:43:03 EDT
Which one are you talking about?

Since the original man pages are encoded in EUC-JP and we want to see the
Japanese man pages in UTF-8, it's being converted at the build time. the content
itself is the same though, actually it's the different files IMHO.
Comment 5 Parag AN(पराग) 2007-09-27 23:19:42 EDT
(In reply to comment #4)
> Which one are you talking about?
> 
> Since the original man pages are encoded in EUC-JP and we want to see the
> Japanese man pages in UTF-8, it's being converted at the build time. the content
> itself is the same though, actually it's the different files IMHO.
 Oh yes. Sorry. I Forgot that we used iconv and that created new files with new
timestamp.
Comment 6 Parag AN(पराग) 2007-09-27 23:20:12 EDT
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and RPM.
+ source files match upstream.
40af705db14a4ef92bacc0d3e78a4aff  man-pages-ja-20070915.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc files present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code.
+ no static libraries.
+ no .pc file present.
+ no -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ no scriptlets are used.
+ Not a GUI app.

APPROVED.
Comment 7 Akira TAGOH 2007-09-28 01:07:46 EDT
Thanks for reviewing. the updated package has been built.

Note You need to log in before you can comment on or make changes to this bug.