Bug 226155 (mod_perl) - Merge Review: mod_perl
Summary: Merge Review: mod_perl
Status: CLOSED ERRATA
Alias: mod_perl
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords: Reopened
Depends On: 228429
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 19:42 UTC by Nobody's working on this, feel free to take it
Modified: 2016-12-10 05:20 UTC (History)
9 users (show)

Fixed In Version: mod_perl-2.0.4-12.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-10 05:20:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
emmanuel: needinfo+


Attachments (Terms of Use)
Patch to the mod_perl spec file (3.31 KB, patch)
2009-09-26 21:16 UTC, Emmanuel Seyman
no flags Details | Diff
Patch to mod_perl.spec (3.88 KB, patch)
2010-10-31 16:57 UTC, Emmanuel Seyman
no flags Details | Diff
The new spec file (9.20 KB, text/plain)
2010-10-31 16:58 UTC, Emmanuel Seyman
no flags Details
New patch to the spec file (4.12 KB, patch)
2010-11-04 13:18 UTC, Emmanuel Seyman
no flags Details | Diff

Description Nobody's working on this, feel free to take it 2007-01-31 19:42:38 UTC
Fedora Merge Review: mod_perl

http://cvs.fedora.redhat.com/viewcvs/devel/mod_perl/
Initial Owner: jorton@redhat.com

Comment 1 Marcela Mašláňová 2008-07-22 13:54:16 UTC
mod_perl.src:55: W: rpm-buildroot-usage %build PREFIX=$RPM_BUILD_ROOT/usr \
mod_perl.src: W: mixed-use-of-spaces-and-tabs (spaces: line 3, tab: line 55)
mod_perl.src: W: strange-permission filter-provides.sh 0775
mod_perl.src: W: strange-permission filter-requires.sh 0775

mod_perl.i386: W: hidden-file-or-dir
/usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-inline
mod_perl.i386: W: hidden-file-or-dir
/usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-register
mod_perl.i386: W: hidden-file-or-dir
/usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-xs
mod_perl.i386: E: wrong-script-interpreter
/usr/share/doc/mod_perl-2.0.4/docs/os/win32/mpinstall "C:/Perl/bin"
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/c.pod
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/Changes
mod_perl.i386: W: hidden-file-or-dir
/usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-init
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/docs/user/Changes.pod
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/SVN-MOVE
mod_perl.i386: W: file-not-utf8
/usr/share/doc/mod_perl-2.0.4/docs/devel/core/explained.pod
mod_perl.i386: E: useless-explicit-provides perl(Apache2::Connection)
mod_perl.i386: E: useless-explicit-provides perl(Apache2::RequestRec)

Comment 2 Marcela Mašláňová 2008-07-22 13:59:06 UTC
spec:
missing dist tag


Comment 3 Itamar Reis Peixoto 2008-10-03 13:01:29 UTC
Hi.

I am using 

mod_perl-2.0.4-6.x86_64
httpd-2.2.9-4.x86_64

and I receiving the flowing error.


[root@localhost ~]# service httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax error on line 10 of /etc/httpd/conf.d/perl.conf: Cannot load /etc/httpd/modules/mod_perl.so into server: /etc/httpd/modules/mod_perl.so: undefined symbol: modperl_io_perlio_restore_stdout
                                                           [FAILED]


Can you help with this issue, or Can I open a new bug report ?

Comment 4 Marcela Mašláňová 2008-10-06 08:18:48 UTC
I opened new bug #465743 for this problem.

Comment 5 Emmanuel Seyman 2009-09-26 21:16:22 UTC
Created attachment 362781 [details]
Patch to the mod_perl spec file

Here's a patch that removes all the errors that can be removed.

Comment 6 Emmanuel Seyman 2010-07-10 17:20:15 UTC
Joe, per the recent discussion on devel@l.fp.o on merge reviews, do you think we can get this one closed ? I'ld gladly review it if so.

Comment 7 Joe Orton 2010-07-12 07:17:32 UTC
Emmanuel - if you are a provenpackager please go ahead and commit your fixes, if not please request commit privs for this package and I'll approve that!

Comment 8 Emmanuel Seyman 2010-07-14 09:17:17 UTC
(In reply to comment #7)
>
> Emmanuel - if you are a provenpackager please go ahead and commit your fixes,
> if not please request commit privs for this package and I'll approve that!    

This kind of defeats the point of having merge reviews. The whole point is that two people collaborate on raising the package's quality level.

http://lists.fedoraproject.org/pipermail/devel/2010-July/138649.html

That said, the changes look to be minor. Would anybody else care to review the package so that I can play the part of the maintainer ?

Comment 9 Parag AN(पराग) 2010-09-06 09:22:28 UTC
Emmanuel,
  Its official that if maintainer approves reviewer to commit on behalf of him then please go ahead and commit the changes and close yourself this review. 
  This has been approved in http://lists.fedoraproject.org/pipermail/devel/2010-August/141204.html

Let's help merge-review maintainers to review their packages by committing approved changes by them and reviewing their packages.

Comment 10 Marcela Mašláňová 2010-10-04 12:40:08 UTC
Hello Emmanuel,
I can review it again.
rpmlint mod_perl-2.0.4-11.fc15.src.rpm 
mod_perl.src: W: spelling-error %description -l en_US perl -> Perl, peel, perk
mod_perl.src: W: spelling-error %description -l en_US runtime -> run time, run-time, runtish
mod_perl.src: W: strange-permission filter-provides.sh 0755L
mod_perl.src: W: strange-permission filter-requires.sh 0755L
mod_perl.src:59: W: rpm-buildroot-usage %build PREFIX=$RPM_BUILD_ROOT/usr \
mod_perl.src:108: W: macro-in-comment %{_mandir}
mod_perl.src:109: W: macro-in-comment %{perl_vendorarch}
mod_perl.src:59: W: mixed-use-of-spaces-and-tabs (spaces: line 3, tab: line 59)
1 packages and 0 specfiles checked; 0 errors, 8 warnings.
rpmlint i386/* | grep -v private
mod_perl.i386: W: spelling-error %description -l en_US runtime -> run time, run-time, runtish
mod_perl.i386: E: useless-provides perl(Apache2::Connection)
mod_perl.i386: E: useless-provides perl(Apache2::RequestRec)
mod_perl.i386: W: hidden-file-or-dir /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-inline
mod_perl.i386: W: hidden-file-or-dir /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-register
mod_perl.i386: W: hidden-file-or-dir /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-xs
mod_perl.i386: E: wrong-script-interpreter /usr/share/doc/mod_perl-2.0.4/docs/os/win32/mpinstall C:/Perl/bin
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/c.pod
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/Changes
mod_perl.i386: W: hidden-file-or-dir /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-init
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/docs/user/Changes.pod
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/SVN-MOVE
mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/docs/devel/core/explained.pod
mod_perl.i386: W: no-manual-page-for-binary mp2bug
And there is also a lot of *.so in provides. This could be easily filtered by perl_default_filter.
That's for start ;-)

Comment 11 Marcela Mašláňová 2010-10-13 08:07:25 UTC
Ping Emmanuel, do you want still fix it?

Comment 12 Emmanuel Seyman 2010-10-13 10:20:55 UTC
(In reply to comment #11)
>
> Ping Emmanuel, do you want still fix it?

Yup, I've just been busy these last two weeks and haven't had time to spare to reviews. I'll make time by the end of the week.

Comment 13 Emmanuel Seyman 2010-10-31 16:57:10 UTC
Created attachment 456737 [details]
Patch to mod_perl.spec

Comment 14 Emmanuel Seyman 2010-10-31 16:58:12 UTC
Created attachment 456738 [details]
The new spec file

Comment 15 Emmanuel Seyman 2010-10-31 17:04:57 UTC
(In reply to comment #12)
>
> Yup, I've just been busy these last two weeks and haven't had time to spare to
> reviews. I'll make time by the end of the week.

Well, make that next week. :-)

(In reply to comment #10)
>
> mod_perl.src: W: spelling-error %description -l en_US perl -> Perl, peel, perk

False positive.

> mod_perl.src: W: spelling-error %description -l en_US runtime -> run time,
> run-time, runtish

Fixed.

> mod_perl.src: W: strange-permission filter-provides.sh 0755L
> mod_perl.src: W: strange-permission filter-requires.sh 0755L

Removed (see below).

> mod_perl.src:59: W: rpm-buildroot-usage %build PREFIX=$RPM_BUILD_ROOT/usr \

Not fixed (and harmless, imho).

> mod_perl.src:108: W: macro-in-comment %{_mandir}
> mod_perl.src:109: W: macro-in-comment %{perl_vendorarch}

Removed.

> mod_perl.src:59: W: mixed-use-of-spaces-and-tabs (spaces: line 3, tab: line 59)

Ugh. Fixed.

> mod_perl.i386: E: useless-provides perl(Apache2::Connection)
> mod_perl.i386: E: useless-provides perl(Apache2::RequestRec)

Filtered. I also moved the filtering inline.

> mod_perl.i386: W: hidden-file-or-dir
> /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-inline
> mod_perl.i386: W: hidden-file-or-dir
> /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-register
> mod_perl.i386: W: hidden-file-or-dir
> /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-xs
> mod_perl.i386: E: wrong-script-interpreter

False postives.

> /usr/share/doc/mod_perl-2.0.4/docs/os/win32/mpinstall C:/Perl/bin

False positive.

> mod_perl.i386: W: file-not-utf8
> /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/c.pod
> mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/Changes
> mod_perl.i386: W: hidden-file-or-dir
> /usr/share/doc/mod_perl-2.0.4/docs/devel/debug/code/.debug-modperl-init
> mod_perl.i386: W: file-not-utf8
> /usr/share/doc/mod_perl-2.0.4/docs/user/Changes.pod
> mod_perl.i386: W: file-not-utf8 /usr/share/doc/mod_perl-2.0.4/SVN-MOVE
> mod_perl.i386: W: file-not-utf8
> /usr/share/doc/mod_perl-2.0.4/docs/devel/core/explained.pod

All fixed.

> mod_perl.i386: W: no-manual-page-for-binary mp2bug

Probably something to report to upstream.

Comment 16 Marcela Mašláňová 2010-11-01 07:03:28 UTC
Buildroot and rm -rf in build section are not needed since F-13. These could be removed, but everything else looks allright.

Comment 17 Emmanuel Seyman 2010-11-04 13:18:12 UTC
Created attachment 457786 [details]
New patch to the spec file

(In reply to comment #16)
>
> Buildroot and rm -rf in build section are not needed since F-13. These could be
> removed, but everything else looks allright.

You're right. The new patch does this (and adds the correct changelog).
Can you commit this ? I don't have provenpackager rights.

Comment 18 Marcela Mašláňová 2010-11-04 16:58:17 UTC
(In reply to comment #17)
> Created attachment 457786 [details]
> New patch to the spec file
> 
> (In reply to comment #16)
> >
> > Buildroot and rm -rf in build section are not needed since F-13. These could be
> > removed, but everything else looks allright.
> 
> You're right. The new patch does this (and adds the correct changelog).
> Can you commit this ? I don't have provenpackager rights.

Built in rawhide.

Comment 19 Joe Orton 2010-11-11 11:08:39 UTC
mod_perl has broken dependencies in the rawhide tree:
On x86_64:
        mod_perl-devel-2.0.4-12.fc15.x86_64 requires perl(Apache::TestConfigPerl)
        mod_perl-devel-2.0.4-12.fc15.x86_64 requires perl(Apache::TestConfigParse)
        mod_perl-devel-2.0.4-12.fc15.x86_64 requires perl(Data::Flow)

Comment 20 Marcela Mašláňová 2010-11-11 13:28:42 UTC
Should be fixed in last commit. I'm sorry, we missed these.

Comment 21 Andres Garcia 2011-10-19 21:44:10 UTC
Hi Guys,

i'm having issues with the package mod_perl (mod_perl-2.0.5-5).  The httpd service crashed after installed

The httpd version is 2.2.21 and this is the error message i'm getting everytime I tried to run the service:


Restarting httpd (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [FAILED]
# systemctl status httpd

# systemctl status httpd.service 
httpd.service - The Apache HTTP Server (prefork MPM)
      Loaded: loaded (/lib/systemd/system/httpd.service; enabled)
      Active: failed since Wed, 19 Oct 2011 16:40:07 -0500; 27s ago
     Process: 5233 ExecStop=/usr/sbin/httpd $OPTIONS -k stop (code=exited, status=0/SUCCESS)
     Process: 5235 ExecStart=/usr/sbin/httpd $OPTIONS -k start (code=dumped, signal=SEGV)
    Main PID: 4794 (code=exited, status=0/SUCCESS)
      CGroup: name=systemd:/system/httpd.service

Please let me know if you need more details

Comment 22 Fedora Update System 2016-11-24 09:53:45 UTC
mod_perl-2.0.10-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-4e7927a6eb

Comment 23 Fedora Update System 2016-11-25 00:22:55 UTC
mod_perl-2.0.10-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-4e7927a6eb

Comment 24 Fedora Update System 2016-12-10 05:20:07 UTC
mod_perl-2.0.10-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.