Bug 226162 - Merge Review: mtools
Merge Review: mtools
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mtools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Hill
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:43 EST by Nobody's working on this, feel free to take it
Modified: 2015-02-12 04:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-12 03:18:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:43:37 EST
Fedora Merge Review: mtools

http://cvs.fedora.redhat.com/viewcvs/devel/mtools/
Initial Owner: atkac@redhat.com
Comment 1 Ed Hill 2007-02-03 15:22:16 EST
Hi there, here's a quick review:

good:
 + source matches upstream
 + license is OK and correctly included (GPL)
 + specfile is legible and looks good
 + dir ownership and permissions look good
 + has %clean and "rm -rf $RPM_BUILD_ROOT"
 + pot/preun scriptlets look good
 + dir ownership and perms OK

needswork:
 - please see the rpmlint output at:
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/mtools-3.9.10-3.fc7.src.rpm/result/rpmlint.log
   which lists a few items that need attention

 - please use the preferred BuildRoot:
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

Comment 2 Roozbeh Pournader 2007-02-03 17:34:32 EST
Assigning to owner who should fix the problems.
Comment 3 Adam Tkac 2007-02-05 07:53:45 EST
problems are fixed in mtools-3.9.10-4.fc7
Comment 4 Warren Togami 2007-02-05 13:36:15 EST
Assigning back to the reviewer.
Comment 5 Kevin Fenzi 2007-02-08 22:48:51 EST
Setting flag back to ? to notify ed to re-check things. 
Comment 6 Adam Tkac 2009-02-05 06:22:59 EST
Ed, are you going to review mtools, please?
Comment 7 Ed Hill 2009-02-05 09:20:00 EST
Yes, I'll do it this weekend!
Comment 8 Cole Robinson 2015-02-11 15:38:02 EST
Mass reassigning all merge reviews to their component. For more details, see this FESCO ticket:

  https://fedorahosted.org/fesco/ticket/1269

If you don't know what merge reviews are about, please see:

  https://fedoraproject.org/wiki/Merge_Reviews

How to handle this bug is left to the discretion of the package maintainer.
Comment 9 Ondrej Oprala 2015-02-12 03:18:38 EST
Since Ed's review +'s still hold true and rpmlint's pretty happy apart from 3 bogus dates, I consider this issue resolved.
Comment 10 Parag AN(पराग) 2015-02-12 04:25:58 EST
Few additional things you can improve in spec like we have following tags now optional and can be removed safely

1) Group:
2) Buildroot:
3) in %install no need of
rm -rf $RPM_BUILD_ROOT
4) %clean section
5) %defattr(-,root,root)

Then we have macro for /etc which is %{_sysconfdir}

Every patch used should provide information in comment above to that patch line like why patch is needed and if it is upstream or not?

Please look http://fedoraproject.org/wiki/Packaging:Guidelines#Why_the_.25makeinstall_macro_should_not_be_used and see if you can avoid using %makeinstall

Note You need to log in before you can comment on or make changes to this bug.