Bug 226181 - Merge Review: nano
Merge Review: nano
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Package Reviews List
:
Depends On: 220527
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:14 EST by Nobody's working on this, feel free to take it
Modified: 2007-12-08 02:24 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-08 02:24:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tibbs: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:14:32 EST
Fedora Merge Review: nano

http://cvs.fedora.redhat.com/viewcvs/devel/nano/
Initial Owner: dwmw2@redhat.com
Comment 1 Jason Tibbitts 2007-02-03 12:22:28 EST
Nice, a CC got added and I lost the entire review.  Let's try this again in an external editor.

First, a couple of rpmlint complaints:

W: nano file-not-utf8 /usr/share/man/fr/man1/rnano.1.gz
   Just needs judicious application of iconf like the other two manpages.
W: nano prereq-use /sbin/install-info
   The Prereq: line should be replaced with:
   Requires(post): /sbin/install-info
   Requires(preun): /sbin/install-info

Other than those two items, the issues are the BuildRoot:, the scriptlets and
perhaps checking to see if it would be reasonable to update to 2.0.3.

Review:
* source files match upstream:
   f5537b8a988618fa8524b6a4b0a6950184d37db983b4521ad843b98845da571c
   nano-1.3.12.tar.gz
O package meets naming and versioning guidelines.
   Release: should probably be an integer, but since the dist tag isn't being
   used, this looks like a sub-release bump and I don't believe it violates
   any guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
O dist tag is not present.
X build root is not correct; should be
  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  Whether this is absolutely mandatory depends on a decision by FESCo, which
  should happen over the weekend.
* license field matches the actual license.
* license is open source-compatible.  License text included in package.
O latest version is not being packaged.
   The current upstream version seems to be 2.0.3.
* BuildRequires are proper.
* compiler flags are appropriate.
* %clean is present.
* package builds in mock.
* debuginfo package looks complete.
X rpmlint is silent.
* final provides and requires are sane:
   nano = 1.3.12-1.1
  =
   /bin/sh
   /sbin/install-info
   libncursesw.so.5
* %check is not present, no test suite upstream.
* no shared libraries are added to the regular linker search paths.
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
X scriptlets not OK:
   The install-info calls need "||:" at the end or a nodocs install will fail.
* code, not content.
* documentation is small, so no -docs subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.
* no headers.
* no pkgconfig files.
* no libtool .la droppings.
* not a GUI app.
Comment 2 Jason Tibbitts 2007-02-23 11:04:11 EST
Setting flags appropriately according to the finally finalized procedure.

There's really not much to be fixed here, just a few easy tweaks to the
specfile.    If I can find the time I'll try to make a patch to the specfile.
Comment 3 Jason Tibbitts 2007-12-08 02:24:35 EST
Looks like Florian fixed most of the issues back in February.  The only
remaining thing was a missed call to iconv for the rnano manpage, which I've added.

I committed the changed package and went ahead and pushed a build.  That should
close out this review.

Note You need to log in before you can comment on or make changes to this bug.