Bug 2262 - gtcd fails for when theme is Marble3D
gtcd fails for when theme is Marble3D
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
6.0
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-19 04:25 EDT by jay
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-15 07:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jay 1999-04-19 04:25:28 EDT
If I set the theme to Marble3D with the GNOME config tool,
gtcd fails; it starts up maximised and then exits with a
"Bad Pixmap" X error.   It works fine under the default
theme.

Details:-
Current theme is Marble3D, window manager is Enlightenment.
This does *not* occur in the default theme.
Red Hat 5.9 (Starbuck).



Script started on Sat Apr 17 13:47:20 1999
[james@periwinkle james]$ gtcd

Gdk-ERROR **: BadPixmap (invalid Pixmap parameter)
  serial 782 error_code 4 request_code 56 minor_code 0

aborting...
Aborted (core dumped)
[james@periwinkle james]$ gdb gtcd
GNU gdb 4.17.0.11 with Linux support
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public
License, and you are
welcome to change it and/or distribute copies of it under
certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show
warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) core core
Core was generated by `gtcd'.
Program terminated with signal 6, Aborted.
Reading symbols from /usr/lib/libgnomeui.so.32...done.
Reading symbols from /usr/lib/libart_lgpl.so.2...done.
Reading symbols from /usr/lib/libgdk_imlib.so.1...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/lib/libgtk-1.2.so.0...done.
Reading symbols from /usr/lib/libgdk-1.2.so.0...done.
Reading symbols from /usr/lib/libgmodule-1.2.so.0...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /usr/lib/libgnome.so.32...done.
Reading symbols from /usr/lib/libgnomesupport.so.0...done.
Reading symbols from /usr/lib/libesd.so.0...done.
Reading symbols from /usr/lib/libaudiofile.so.0...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/libdb.so.2...done.
Reading symbols from /usr/lib/libglib-1.2.so.0...done.
Reading symbols from /lib/libdl.so.2...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /usr/lib/libz.so.1...done.
Reading symbols from /lib/ld-linux.so.2...done.
---Type <return> to continue, or q <return> to quit---
Reading symbols from /lib/libnss_files.so.2...done.
Reading symbols from /usr/lib/gconv/ISO8859-1.so...done.
Reading symbols from
/usr/lib/gtk/themes/engines/libpixmap.so...done.
Reading symbols from /usr/lib/libimlib-png.so...done.
Reading symbols from /usr/lib/libpng.so.2...done.
Reading symbols from /usr/lib/libimlib-xpm.so...done.
#0  0x403a4c41 in __kill ()
(gdb) where
#0  0x403a4c41 in __kill ()
#1  0x403a4882 in raise (sig=6) at
../sysdeps/posix/raise.c:27
#2  0x403a5ee3 in abort () at ../sysdeps/generic/abort.c:88
#3  0x40375641 in g_logv ()
#4  0x403756f2 in g_log ()
#5  0x4023da4a in gdk_x_error ()
#6  0x402a6979 in _XError ()
#7  0x402a51f1 in _XReply ()
#8  0x402a0ca1 in XSync ()
#9  0x400f94cc in gdk_imlib_render ()
#10 0x404917b0 in apply_theme_image ()
#11 0x404940d1 in draw_flat_box ()
#12 0x401ddc89 in gtk_paint_flat_box ()
#13 0x4020a349 in gtk_window_paint ()
#14 0x4020a412 in gtk_window_expose ()
#15 0x4020a4ed in gtk_marshal_BOOL__POINTER ()
#16 0x401d1558 in gtk_signal_real_emit ()
#17 0x401cf7f0 in gtk_signal_emit ()
#18 0x40202358 in gtk_widget_event ()
#19 0x401a6a1a in gtk_main_do_event ()
#20 0x40249962 in gdk_event_dispatch ()
#21 0x40373296 in g_main_dispatch ()
#22 0x403737d1 in g_main_iterate ()
---Type <return> to continue, or q <return> to quit---
#23 0x40373949 in g_main_run ()
#24 0x401a63da in gtk_main ()
#25 0x804f667 in main (argc=1, argv=0xbffff854) at
gtcd.c:1012
#26 0x4039eca7 in __libc_start_main (main=0x804f514 <main>,
argc=1,
    argv=0xbffff854, init=0x804c614 <_init>, fini=0x805553c
<_fini>,
    rtld_fini=0x40009c30 <_dl_fini>, stack_end=0xbffff84c)
    at ../sysdeps/generic/libc-start.c:78
(gdb) q
[james@periwinkle james]$ exit

Script done on Sat Apr 17 13:49:05 1999
Comment 1 Jeff Johnson 1999-06-14 13:58:59 EDT
*** Bug 3459 has been marked as a duplicate of this bug. ***

When booting with the Red Hat floppy, you can use,
after some menus, virtual console 2 with Alt-F2,
where you have a bash prompt:  bash#
Listed in /bin are some programs (not much), amongst
others vi and vim. However, when you call vi or vim,
you get this error:

"vi: error in loading shared libraries: libX11.so.6:
 cannot open shared object: No such file or directory"

This is somewhat awkward, as I wanted to edit a file
on the Win98 (vfat) partition, namely a log file of
what I was doing :-)
Note that I was able to mount it:
  /bin/insmod fat.o
  /bin/insmod vfat.o
  mkdir /dos
  mount -t vfat /dev/hda1 /dos
I also was not able to run 'more' (or 'less') and gpm
at installation time.
My idea was to keep a log of what I was doing and
copy it with gpm, so I would not have to write it on
paper and type it in again, should I need to install
again (which I did :-)
Comment 2 Jeff Johnson 1999-06-15 07:32:59 EDT
Bug #3459 is a duplicate of #2439, not #2262.

Note You need to log in before you can comment on or make changes to this bug.