Bug 226211 - Merge Review: openhpi
Merge Review: openhpi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:18 EST by Nobody's working on this, feel free to take it
Modified: 2010-03-03 19:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 08:02:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhlavink: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:18:21 EST
Fedora Merge Review: openhpi

http://cvs.fedora.redhat.com/viewcvs/devel/openhpi/
Initial Owner: pknirsch@redhat.com
Comment 1 Dan Horák 2008-10-22 02:39:22 EDT
Package Change Request
======================
Package Name: openhpi
New Branches: F-10
Owners: sharkcz
Comment 2 Huzaifa S. Sidhpurwala 2008-10-22 05:20:23 EDT
cvs done
Comment 3 Michal Hlavinka 2009-12-03 13:02:22 EST
in short:

Legend: + = PASSED, - = FAILED, 0 = Not Applicable

- MUST[1]: rpmlint must be run on every package. The output should be posted in the review
+ MUST: package named according to the Package Naming Guidelines
+ MUST: The spec file name must match the base package %{name}
+ MUST: The package must meet the Packaging Guidelines .
+ MUST: The package licensed with a Fedora approved license and meets the Licensing Guidelines
+ MUST: The License field in the package spec file matches the actual license
+ MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.[4]
+ MUST[2]: The spec file must be written in American English.
+ MUST[3]: The spec file for the package MUST be legible.
- MUST[4]: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task
+ MUST: The package successfully compiles and builds into binary rpms on at least one primary architecture
+ MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch
+ MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines
+ MUST: The spec file handles locales properly. This is done by using the %find_lang macro
+ MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun. [10]
+ MUST: Packages must NOT bundle copies of system libraries
+ MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker
+ MUST: Package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory
+ MUST: Package must not list a file more than once in the spec file's %files listings
+ MUST: Permissions on files must be set properly. Every %files section must include a %defattr(...) line.
+ MUST: Each package must have a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
+ MUST: Each package must consistently use macros
+ MUST: The package must contain code, or permissable content
0 MUST: Large documentation files must go in a -doc subpackage
+ MUST: If a package includes something as %doc, it must not affect the runtime of the application
+ MUST: Header files must be in a -devel package
0 MUST: Static libraries must be in a -static package
+ MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'
- MUST[1]: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package
+ MUST: devel packages must require the base package using a fully versioned dependency: Requires: %{name} = %{version}-%{release}
+ MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built
+ MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section
+ MUST: Packages must not own files or directories already owned by other packages
+ MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot} (or $RPM_BUILD_ROOT)

fails, but this is no longer required ( https://fedoraproject.org/wiki/Packaging/Guidelines#PreppingBuildRootForInstall )

+ MUST: All filenames in rpm packages must be valid UTF-8

--------------------------------

comments:

1) rpmlint *.spec *.src.rpm x86_64/*
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libsnmp_bc.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libipmi.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libsimulator.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libwatchdog.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libipmidirect.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/liboa_soap.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libilo2_ribcl.so
openhpi.x86_64: W: devel-file-in-non-devel-package /usr/lib64/openhpi/libsysfs2hpi.so

https://fedoraproject.org/wiki/Packaging:Guidelines#Devel_Packages :
""".... The following are examples of file types which should be in -devel:
    * Header files (e.g. .h files)
    * Unversioned shared libraries (e.g. libfoo.so).
"""

these files should go to -devel package

---------

openhpi.x86_64: E: non-standard-dir-perm /var/lib/openhpi 01777

are these permissions really required? I've done only quick testing/googling (without proper configuration), but didn't find anything about this

-----------------

openhpi-libs.x86_64: W: obsolete-not-provided openhpi

why openhpi-libs obsoletes openhpi? for version specified, there were no openhpi-libs provided, but this line would lead to yum replacing openhpi with just openhpi-libs -> openhpid and other files will be missing

what is your rationale for this?

-----------

openhpi-libs.x86_64: W: no-documentation

no problem with this one

2) Correct english - see WordUsage.html

%description

hot swap
--------
    Correct. Two words, lower case. Capitalize when used at the beginning of a sentence only. Do not use ‘hotswap’ or ‘hot-swap’.

plug-in
-------
    Correct. Do not use "plugin".
    A hardware or software module that adds a specific feature or service to a larger system. For example, a number of plug-ins are available for the Netscape Navigator browser that enable it to display different types of audio or video messages. Navigator plug-ins are based on MIME file types.

but these are not blockers ;-)


3) too much wildcards under %files section

If upstream makes some changes to it's tarball and add/remove some files, this is not going to catch anything. It's good practice to list at least all files under %{_bindir} and %{_sbindir}. This will let you know if there is any new/missing one.

4) sources does not match upstream
$ curl -s http://downloads.sourceforge.net/openhpi/openhpi-2.14.1.tar.gz | md5sum
d41d8cd98f00b204e9800998ecf8427e  -
$ cat sources
1533972a05f2ed61f3ae441ecd3df5a9  openhpi-2.14.1.tar.gz

Please fix these issues, thanks
Comment 4 Dan Horák 2010-01-12 05:08:34 EST
(In reply to comment #3)
> comments:
> 
> 1) rpmlint *.spec *.src.rpm x86_64/*
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libsnmp_bc.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libipmi.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libsimulator.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libwatchdog.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libipmidirect.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/liboa_soap.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libilo2_ribcl.so
> openhpi.x86_64: W: devel-file-in-non-devel-package
> /usr/lib64/openhpi/libsysfs2hpi.so
> 
> https://fedoraproject.org/wiki/Packaging:Guidelines#Devel_Packages :
> """.... The following are examples of file types which should be in -devel:
>     * Header files (e.g. .h files)
>     * Unversioned shared libraries (e.g. libfoo.so).
> """
> 
> these files should go to -devel package

these files are plugins loaded with dlopen from the main process, no libraries, so they belong to the main package
 
> ---------
> 
> openhpi.x86_64: E: non-standard-dir-perm /var/lib/openhpi 01777
> 
> are these permissions really required? I've done only quick testing/googling
> (without proper configuration), but didn't find anything about this

this is what upstream uses, but I can ask them about reasoning
 
> -----------------
> 
> openhpi-libs.x86_64: W: obsolete-not-provided openhpi
> 
> why openhpi-libs obsoletes openhpi? for version specified, there were no
> openhpi-libs provided, but this line would lead to yum replacing openhpi with
> just openhpi-libs -> openhpid and other files will be missing
> 
> what is your rationale for this?

this is a result from splitting the openhpi package into openhpi and openhpi-libs (https://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks#Splitting_libraries_into_separate_packages - can't find a more official doc now)
 
> -----------
> 
> openhpi-libs.x86_64: W: no-documentation
> 
> no problem with this one
> 
> 2) Correct english - see WordUsage.html
> 
> %description
> 
> hot swap
> --------
>     Correct. Two words, lower case. Capitalize when used at the beginning of a
> sentence only. Do not use ‘hotswap’ or ‘hot-swap’.
> 
> plug-in
> -------
>     Correct. Do not use "plugin".
>     A hardware or software module that adds a specific feature or service to a
> larger system. For example, a number of plug-ins are available for the Netscape
> Navigator browser that enable it to display different types of audio or video
> messages. Navigator plug-ins are based on MIME file types.
> 
> but these are not blockers ;-)

hm, I didn't expect a spell-checker in review :-)
 
> 
> 3) too much wildcards under %files section
> 
> If upstream makes some changes to it's tarball and add/remove some files, this
> is not going to catch anything. It's good practice to list at least all files
> under %{_bindir} and %{_sbindir}. This will let you know if there is any
> new/missing one.

I don't agree. Using wildcards copies upstream intentions what belongs where. There are other tools and processes that should check differences between 2 versions of the package.
 
> 4) sources does not match upstream
> $ curl -s http://downloads.sourceforge.net/openhpi/openhpi-2.14.1.tar.gz |
> md5sum
> d41d8cd98f00b204e9800998ecf8427e  -
> $ cat sources
> 1533972a05f2ed61f3ae441ecd3df5a9  openhpi-2.14.1.tar.gz

running spectool -g on the spec file returns the right source archive (with the 1533... md5sum)
Comment 5 Michal Hlavinka 2010-01-13 08:02:39 EST
(In reply to comment #4)
> (In reply to comment #3)
> > comments:
> > 
> > 1) rpmlint *.spec *.src.rpm x86_64/*
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libsnmp_bc.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libipmi.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libsimulator.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libwatchdog.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libipmidirect.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/liboa_soap.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libilo2_ribcl.so
> > openhpi.x86_64: W: devel-file-in-non-devel-package
> > /usr/lib64/openhpi/libsysfs2hpi.so
> > 
> > https://fedoraproject.org/wiki/Packaging:Guidelines#Devel_Packages :
> > """.... The following are examples of file types which should be in -devel:
> >     * Header files (e.g. .h files)
> >     * Unversioned shared libraries (e.g. libfoo.so).
> > """
> > 
> > these files should go to -devel package
> 
> these files are plugins loaded with dlopen from the main process, no libraries,
> so they belong to the main package

ok

> 
> > ---------
> > 
> > openhpi.x86_64: E: non-standard-dir-perm /var/lib/openhpi 01777
> > 
> > are these permissions really required? I've done only quick testing/googling
> > (without proper configuration), but didn't find anything about this
> 
> this is what upstream uses, but I can ask them about reasoning

if it's really suggested by upstream, it's ok

> > -----------------
> > 
> > openhpi-libs.x86_64: W: obsolete-not-provided openhpi
> > 
> > why openhpi-libs obsoletes openhpi? for version specified, there were no
> > openhpi-libs provided, but this line would lead to yum replacing openhpi with
> > just openhpi-libs -> openhpid and other files will be missing
> > 
> > what is your rationale for this?
> 
> this is a result from splitting the openhpi package into openhpi and
> openhpi-libs
> (https://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks#Splitting_libraries_into_separate_packages
> - can't find a more official doc now)

ok, fine for me

> > 2) Correct english - see WordUsage.html
> > 
> > %description
> > 
> > hot swap
> > --------
> >     Correct. Two words, lower case. Capitalize when used at the beginning of a
> > sentence only. Do not use ‘hotswap’ or ‘hot-swap’.
> > 
> > plug-in
> > -------
> >     Correct. Do not use "plugin".
> >     A hardware or software module that adds a specific feature or service to a
> > larger system. For example, a number of plug-ins are available for the Netscape
> > Navigator browser that enable it to display different types of audio or video
> > messages. Navigator plug-ins are based on MIME file types.
> > 
> > but these are not blockers ;-)
> 
> hm, I didn't expect a spell-checker in review :-)
> 

it depends how you interpret 'must: The spec file must be written in American English.' As I've already said, this is not a blocker, but using correct words is going to make your packages look more professional. No need to rebuild, but commit itself would be nice :-)

> > 
> > 3) too much wildcards under %files section
> > 
> > If upstream makes some changes to it's tarball and add/remove some files, this
> > is not going to catch anything. It's good practice to list at least all files
> > under %{_bindir} and %{_sbindir}. This will let you know if there is any
> > new/missing one.
> 
> I don't agree. Using wildcards copies upstream intentions what belongs where.
> There are other tools and processes that should check differences between 2
> versions of the package.

well, if openhpi-2.14.1 would have /bin/foo and /bin/bar and openhpi-2.14.2 would have only /bin/foo for example because /bin/bar requires new ./configure option or build dependency, you won't catch this change with wildcards. Having (manually) filled %files section with just wildcards is imho pointless. Anyway, this is not explicitly written in policy, so even if I disagree, this is not a blocker
 
> > 4) sources does not match upstream
> > $ curl -s http://downloads.sourceforge.net/openhpi/openhpi-2.14.1.tar.gz |
> > md5sum
> > d41d8cd98f00b204e9800998ecf8427e  -
> > $ cat sources
> > 1533972a05f2ed61f3ae441ecd3df5a9  openhpi-2.14.1.tar.gz
> 
> running spectool -g on the spec file returns the right source archive (with the
> 1533... md5sum)

ok, source file is correct, odd this does not work here, because it was working earlier for other sources.

to sum it up: no blockers remains, closing
Comment 6 Dan Horák 2010-03-02 09:13:20 EST
Package Change Request
======================
Package Name: openhpi
New Branches: EL-4
Owners: sharkcz
Comment 7 Jason Tibbitts 2010-03-02 17:47:22 EST
Just EL-4?  Not EL-5 as well?
Comment 8 Dan Horák 2010-03-03 02:15:54 EST
(In reply to comment #7)
> Just EL-4?  Not EL-5 as well?    

Right, RHEL-5 already contains openhpi.
Comment 9 Jason Tibbitts 2010-03-03 19:27:54 EST
OK, CVS done.

Note You need to log in before you can comment on or make changes to this bug.