Bug 226229 - Merge Review: pango
Merge Review: pango
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:20 EST by Nobody's working on this, feel free to take it
Modified: 2010-09-03 01:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 01:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)
pango spec cleanup (2.24 KB, text/plain)
2010-07-20 02:59 EDT, Parag AN(पराग)
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:20:33 EST
Fedora Merge Review: pango

http://cvs.fedora.redhat.com/viewcvs/devel/pango/
Initial Owner: besfahbo@redhat.com
Comment 1 Roozbeh Pournader 2007-02-03 07:54:01 EST
BLOCKER:
  MUST: The License field in the package spec file must match the actual license.

The license is actually more complicated than the LGPL that the spec file
currently says. See bug 224135.
Comment 2 Behdad Esfahbod 2007-02-03 10:58:14 EST
So, "LGPL plus/minus exception"?
Comment 3 Roozbeh Pournader 2007-02-03 15:33:13 EST
(In reply to comment #2)
> So, "LGPL plus/minus exception"?

"LGPL with additional restrictions", I think. The additional restrictions would
be whatever FTL/GPL would impose.
Comment 4 Roozbeh Pournader 2007-02-06 07:59:27 EST
Bad news! <http://fedoraproject.org/wiki/Packaging/Guidelines#Legal> says that
the license must be in one of the three lists. Since FTL is nowhere on those
lists, unless FSF reviews it or OSI approves it, we may need to consider pango
and freetype GPL.
Comment 5 Behdad Esfahbod 2007-02-06 12:16:39 EST
We're kinda out of it: 2 of 3 FreeType developers have agreed to changing the
GPL+FTL to LGPL+FTL for HarfBuzz.
Comment 6 Behdad Esfahbod 2008-12-09 13:16:27 EST
This has happened by the way.  We've gone with the Old MIT license which doesn't have any advertising requirement.
Comment 7 Behdad Esfahbod 2008-12-09 15:12:56 EST
The license and the license field have long been fixed.  Closing.
Comment 8 Dennis Gilmore 2008-12-09 16:26:10 EST
package has not been reviewed and approved.  you cant close it until review is complete.
Comment 9 Parag AN(पराग) 2010-07-20 02:49:48 EDT
1) rpmlint reported

pango.src: W: spelling-error %description -l en_US backends -> backbends, back ends, back-ends
pango.src:505: W: macro-in-%changelog %{version}
pango.src:505: W: macro-in-%changelog %{release}
pango.src: W: no-cleaning-of-buildroot %clean
pango.src: W: no-buildroot-tag
pango.src: W: no-%clean-section
pango.src:83: W: mixed-use-of-spaces-and-tabs (spaces: line 82, tab: line 83)
pango.x86_64: W: spelling-error %description -l en_US backends -> backbends, back ends, back-ends
pango.x86_64: W: conffile-without-noreplace-flag /etc/pango/pangox.aliases
pango.x86_64: W: no-manual-page-for-binary pango-querymodules-64
3 packages and 0 specfiles checked; 0 errors, 10 warnings.

2)also build.log from latest build on koji showed
warning: File listed twice: /usr/share/man/man1/pango-view.1.gz

3)this package should follow https://fedoraproject.org/wiki/Packaging/Guidelines#Parallel_make

4)this package should follow https://fedoraproject.org/wiki/Packaging/Guidelines#Why_the_.25makeinstall_macro_should_not_be_used
Comment 10 Parag AN(पराग) 2010-07-20 02:59:09 EDT
Created attachment 433083 [details]
pango spec cleanup

Also, scratch build with this patch applied is successful
http://koji.fedoraproject.org/koji/taskinfo?taskID=2330361
Comment 11 Parag AN(पराग) 2010-07-20 03:00:18 EDT
to above patch Changelog entry need to be added.

mclasen,
  Can you please help to complete this review by applying above patch?

Thanks.
Comment 12 Parag AN(पराग) 2010-08-09 01:42:40 EDT
ping behdad or mclasen,
  Can anyone please update this package for its merge-review?
Comment 13 Parag AN(पराग) 2010-08-11 00:22:57 EDT
After repetitive pings on bz, looking into discussion happened in yesterday's FESCo meeting where X/Desktop team members almost shown un-willingness to fix this review, I am pushing back this to NEW queue.
Comment 14 Matthias Clasen 2010-08-11 10:15:04 EDT
not sure what you are talking about. the changes in your patch certainly don't look like they are worth loosing more than 5 minutes about. Feel free to commit it.
Comment 16 Parag AN(पराग) 2010-09-02 00:05:07 EDT
(In reply to comment #14)
> not sure what you are talking about. the changes in your patch certainly don't
> look like they are worth loosing more than 5 minutes about. Feel free to commit
> it.

Thanks. I will build new pango-1.28.1-5.fc15 in rawhide by applying above patch and close this review.
Comment 17 Parag AN(पराग) 2010-09-03 01:07:09 EDT
I have built above approved changes in rawhide. Closing this review now.

Note You need to log in before you can comment on or make changes to this bug.