Bug 226262 - Merge Review: perl-Inline
Merge Review: perl-Inline
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:36 EST by Nobody's working on this, feel free to take it
Modified: 2014-07-09 06:30 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.44-18.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 00:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:36:06 EST
Fedora Merge Review: perl-Inline

http://cvs.fedora.redhat.com/viewcvs/devel/perl-Inline/
Initial Owner: rnorwood@redhat.com
Comment 1 Parag AN(पराग) 2007-10-22 02:54:46 EDT
1)perl as BR is not needed. mock build without it worked successfully.
   remove redundant dependency on perl >= 1:5.6.1
2)drop "|| :" from %check
3)you may like to use disttag
4)rpmlint only complained ->
perl-Inline.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 3)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.
==>Use "sed -i -e 's|\t|  |g' perl-Inline.spec"

5) I saw that make test skipped one test
t/05files.....skipped
        all skipped: no reason given
==> Does this mean this package is any missing BR to make this test work?
Comment 2 Robin Norwood 2007-10-25 00:11:38 EDT
1, 2, 3, and 4: all fixed.

5) yep, this is another case where fedora doesn't have a perl package needed to
run those tests - in this case perl(Inline::Files)

Here's a package review for perl-Inline-Files:
https://bugzilla.redhat.com/show_bug.cgi?id=351711

For now the BR: perl(Inline::Files) is commented out.

New version: perl-Inline-0.44-17.fc9 fixes all of the other issues.
Comment 3 Parag AN(पराग) 2007-10-25 00:43:20 EDT
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
840f47d9b6cef39e68370faf9dceab2c  Inline-0.44.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ make test outputs
 PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib/lib', 'blib/arch')" t/*.t
t/00init......ok
t/01usages....ok
t/02config....ok
t/03errors....ok
t/04create....ok
t/05files.....skipped
        all skipped: no reason given
All tests successful, 1 test skipped.
Files=6, Tests=14, 11 wallclock secs ( 0.88 cusr +  0.09 csys =  0.97 CPU)
make[1]: Entering directory `/builddir/build/BUILD/Inline-0.44/C'
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'../blib/lib', '../blib/arch')" t/*.t
t/00init.......ok
t/01syntax.....ok
t/02config.....ok
t/03typemap....ok
t/04perlapi....ok
t/05xsmode.....ok
All tests successful.
Files=6, Tests=12, 13 wallclock secs ( 9.42 cusr +  1.59 csys = 11.01 CPU)

+ Package perl-Inline-0.44-17.fc8  ->
Provides: perl(Foo::Tester) perl(Inline) = 0.44 perl(Inline::C) = 0.44
perl(Inline::C::ParseRecDescent) perl(Inline::C::ParseRegExp) perl(Inline::Foo)
= 0.01 perl(Inline::MakeMaker) = 0.44 perl(Inline::denter)
Requires: perl >= 0:5.005 perl(:MODULE_COMPAT_5.8.8) perl(AutoLoader) perl(Carp)
perl(Config) perl(Cwd) perl(Data::Dumper) perl(ExtUtils::MakeMaker)
perl(File::Spec) perl(File::Spec::Unix) perl(Inline) perl(Inline::denter)
perl(base) perl(strict)

Comment 4 Parag AN(पराग) 2007-10-25 00:44:21 EDT
make test skipped one test. Is that ok or you are missing any BR ?
Comment 5 Robin Norwood 2007-10-25 16:43:43 EDT
See comment #2 :

"""
5) yep, this is another case where fedora doesn't have a perl package needed to
run those tests - in this case perl(Inline::Files)

Here's a package review for perl-Inline-Files:
https://bugzilla.redhat.com/show_bug.cgi?id=351711

For now the BR: perl(Inline::Files) is commented out.
"""

That test is the test that was skipped.  We can wait until bug #351711 is fixed
if you want that test to pass before approving this package.
Comment 6 Parag AN(पराग) 2007-10-26 01:53:43 EDT
thanks.
Comment 7 Parag AN(पराग) 2007-11-19 01:31:35 EST
can you update package?
Comment 8 Robin Norwood 2007-11-19 14:05:39 EST
Built with new BR: http://koji.fedoraproject.org/koji/taskinfo?taskID=248860
Comment 9 Parag AN(पराग) 2007-11-19 20:09:54 EST
APPROVED.
Comment 10 Robin Norwood 2007-12-17 11:11:22 EST
Reopening for EPEL branch request:

Package Change Request
======================
Package Name: perl-Inline
New Branches: EL-4 EL-5

Comment 11 Parag AN(पराग) 2007-12-17 11:47:32 EST
Robin,
  As you reassigned this to your convenience, kindly reassign back to me when
closing this so that this will be on my radar of CLOSED bugs as I can see this
bug goes off my radar.
  And I am still waiting for updated packages from you which are still in
NEEDINFO on you.
 
Comment 12 Parag AN(पराग) 2007-12-17 11:50:20 EST
also, I really don't see any use of assigning review from reporter(assuming you
are maintainer for this package) to himself for CVS request as reporter is in CC
list.
Comment 13 Robin Norwood 2007-12-17 12:19:01 EST
I assigned this bug from you to me since I'm the one who needs to take action on
it (once the CVS work is done), and so you wouldn't get BZ notifications about
the progress of the package through EPEL, which you might not care about.  I
don't mind if you want to reassign it back to yourself, or I'll do so when the
EPEL builds are done.
Comment 14 Tom "spot" Callaway 2007-12-17 14:02:44 EST
cvs done.
Comment 15 Robin Norwood 2008-01-03 11:00:58 EST
Built for EL-4 and EL-5
Comment 16 Petr Pisar 2014-07-09 04:44:18 EDT
Rel-engs, please add `perl-sig' pseudouser watchbugzilla and watchcommits permissions for all perl-Inline branches.
Comment 17 Jon Ciesla 2014-07-09 06:30:49 EDT
Complete.

Note You need to log in before you can comment on or make changes to this bug.