Bug 226314 - Merge Review: prctl
Merge Review: prctl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:42 EST by Nobody's working on this, feel free to take it
Modified: 2009-01-28 12:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 12:16:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oget.fedora: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:42:47 EST
Fedora Merge Review: prctl

http://cvs.fedora.redhat.com/viewcvs/devel/prctl/
Initial Owner: karsten@redhat.com
Comment 1 Karsten Hopp 2007-02-21 10:38:03 EST
prctl-1.5-2 prepared for review
Comment 2 Orcan Ogetbil 2008-11-13 17:31:50 EST
Why is there an explicit ExclusiveArch: ia64 ?
I can't find any documentation that indicates this software is only for ia64. Also, do we have a branch for the ia64 architecture at Fedora?
Comment 3 Orcan Ogetbil 2009-01-16 15:06:23 EST
ping?
Comment 4 Karsten Hopp 2009-01-28 06:25:33 EST
The only parameters of prctl that do anything other than printing help are 
--unaligned= and --fpemu=. Both work only on ia64, on other archs you'll get this
output: 'ERROR: Kernel on this platform may not implement this prctl feature.'

I've added this as a comment before the ExclusiveArch: in the spec file and
commited it to CVS.

As IA64 is a secondary arch in Fedora, a build will need to be done by the secondary arch maintainers. See https://fedoraproject.org/wiki/Architectures/IA64
for more info about Fedora-IA64
Comment 5 Orcan Ogetbil 2009-01-28 11:48:53 EST
Thanks for the explanation.
So I can't to do a test to evaluate the software but I could do a generic package review since it is a simple one.
There is one minor issue and a few suggestions. Let me know whenever you update the package so we can close the bug.

* rpmlint says
  prctl.src:22: W: setup-not-quiet
You need to use 
  %setup -q

! no disttag. I think it could be better to have a disttag to avoid incompatibilities between the binaries produced by different versions of the compiler. What do you think?

! The patch is trivial. I don't think it is necessary to submit upstream. It would be nice though.

! You can make use of the %{name} macro a little more frequent
Comment 6 Karsten Hopp 2009-01-28 12:05:52 EST
I've added changes for those in CVS:
- added disttag
- setup -q
- frequent use of %{name} macro with the exception of the URL, because that's
  the string I use with cut&paste and firefox to check if there's a new version.
Comment 7 Orcan Ogetbil 2009-01-28 12:16:45 EST
Great! Thanks.

---------------------------------------------
This Merge Review (prctl) is APPROVED by oget
---------------------------------------------

Note You need to log in before you can comment on or make changes to this bug.