Bug 226319 - Merge Review: procps
Merge Review: procps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 15:43 EST by Nobody's working on this, feel free to take it
Modified: 2008-12-28 17:09 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.2.7-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-28 17:09:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
redhat: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:43:23 EST
Fedora Merge Review: procps

http://cvs.fedora.redhat.com/viewcvs/devel/procps/
Initial Owner: kzak@redhat.com
Comment 1 Jason Tibbitts 2007-06-01 01:35:37 EDT
If someone's reviewing this, they should assign it to themselves and set the
state to ASSIGNED.  Otherwise the fedora-cvs flag should be cleared so it shows
up in the review queue.
Comment 2 Jason Tibbitts 2007-12-20 14:05:25 EST
Given that there was no response, I went ahead and cleared the fedora-review flag.
Comment 3 Michael Schwendt 2008-01-10 08:35:42 EST
* The files in the source tarball use the LGPLv2+ not just the GPLv2+.

* There's no reason why the %post scriptlet is not simply
%post -p /sbin/ldconfig

* From the build.log:
/usr/bin/strip: unable to copy file
'/home/qa/tmp/rpm/tmp/procps-3.2.7-17.fc8-root-qa/lib/libproc-3.2.7.so' reason:
Permission denied

That is because the lib is installed u-w and only later gets attr(0755,...).
Easy to fix at end of %install section.

* When you use "install" in the spec or modify the install
options, prefer "install -p ..." to preserve file timestamps.
Users appreciate it when the age of files in packages can be
seen, and e.g. documentation from several years ago does not
get a fresh timestamp as if it were new.

This is easy to fix in the make install line.


* All these can be fixed in CVS. Hence: APPROVED
Comment 4 Jason Tibbitts 2008-01-17 15:20:00 EST
I don't see that any of these changes have been made in CVS, yet this package
has been approved.

Because we have a situation where many of the maintainers either do not see the
bugzilla notices (because the tickets are not assigned, because they get too
much bugspam already, or because the maintainer has changed since these tickets
were opened) or simply do not pay attention to the merge reviews, please do not
approve merge reviews until after you have verified that the changes are in CVS.
 It's not generally necessary to wait until the package is built and pushed to
rawhide; I usually just set the flags and close the ticket once I've seen the
changes in a checkout.

By the way, the licensing situation seems more complicated.  I see that free.c
is LGPLv2 only, most bits are LGPLv2+, kill.1 says in its comments GPLv2, top.1
is GFDL.  Ugh.
Comment 5 Michael Schwendt 2008-01-17 19:10:38 EST
pgreg.c : GPL referring to the file COPYING (which is the GPLv2)

pwdx.c : LGPLv2
Comment 6 Tomas Smetana 2008-01-18 03:17:50 EST
I have committed the suggested changes to the devel branch.
Comment 7 Michel Alexandre Salim 2008-01-25 13:21:54 EST
Is this package's status supposed to be NEW, ASSIGNED, or CLOSED RAWHIDE?
Comment 8 Michael Schwendt 2008-07-16 18:22:05 EDT
Then somebody else re-review this and see whether LGPLv2 and
GPLv2 must be added to the licence tag (comment 5).
The GFDL is not a code licence.
Comment 9 Robert Scheck 2008-07-26 14:19:13 EDT
Tom, can you please clarify the licensing here? IMHO it should be "GPLv2 and 
GFDL", but I'm not so good with dealing such nasty licensing things ;-)
Comment 10 Tom "spot" Callaway 2008-07-28 09:56:01 EDT
You can list the GFDL if you want to. We're not requiring that the License tag
reflect packaged documentation unless it is the only thing in a package/subpackage.

As to the code license, it is up to you, but I would say that the combined work
as generated from the procps source is GPLv2 (the most restrictive of the
several GPL versions listed in the code bits). If you wanted to list GPLv2 and
LGPLv2 as the license, that would also be fine.
Comment 11 Robert Scheck 2008-12-28 17:09:09 EST
The MUST changes have been applied to CVS some time ago already. The license 
stuff has been clarified by Tom some time ago and is in CVS acceptable, too.
Thanks to Michael, Jason, Tom and Tomas for their work: APPROVED.

Note You need to log in before you can comment on or make changes to this bug.