Bug 226330 - Merge Review: pychecker
Merge Review: pychecker
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Susi Lehtola
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:45 EST by Nobody's working on this, feel free to take it
Modified: 2013-05-08 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 10:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
susi.lehtola: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:45:07 EST
Fedora Merge Review: pychecker

http://cvs.fedora.redhat.com/viewcvs/devel/pychecker/
Initial Owner: mitr@redhat.com
Comment 1 Susi Lehtola 2009-04-11 06:19:07 EDT
- Drop
Requires: python
and
BuildRequires: python
since both of these are redundant (first is automatically picked up and second is a requirement of python-devel).

- Remove
CFLAGS="$RPM_OPT_FLAGS"
from the build phase since this is a noarch package.

**

rpmlint output:
pychecker.noarch: W: summary-ended-with-dot A python source code checking tool.
pychecker.noarch: E: tag-not-utf8 %changelog
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/Stack.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/OP.py 0644
pychecker.noarch: W: file-not-utf8 /usr/share/doc/pychecker-0.8.17/MAINTAINERS
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/warn.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/printer.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/CodeChecks.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/Warning.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/msgs.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/utils.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/Config.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/checker.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/function.py 0644
pychecker.noarch: E: non-executable-script /usr/lib/python2.5/site-packages/pychecker/python.py 0644
pychecker.src: W: summary-ended-with-dot A python source code checking tool.
pychecker.src: E: tag-not-utf8 %changelog
pychecker.src: E: non-utf8-spec-file /tmp/rpmlint.pychecker-0.8.17-8.fc10.src.rpm.t9ghWq/pychecker.spec
2 packages and 0 specfiles checked; 15 errors, 3 warnings.

- Fix the above. You can get rid of the non-executable script errors by removing the shebang with sed in the setup phase, e.g. 
sed -i -e '1d' pychecker/checker.py

- Maybe add "-O1 --skip-build" to the install argument of setup.py?

MUST: The spec file for the package is legible and macros are used consistently. OK
MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}. OK
MUST: The package must be licensed with a Fedora approved license and meet the  Licensing Guidelines. OK

MUST: The License field in the package spec file must match the actual license. OK
- Source code contains no license heders, please ask upstream to add them.

MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. OK
MUST: The package MUST successfully compile and build into binary rpms. OK
MUST: The spec file MUST handle locales properly. OK
MUST: Optflags are used and time stamps preserved. OK
MUST: Packages containing shared library files must call ldconfig. OK
MUST: A package must own all directories that it creates or require the package that owns the directory. OK
MUST: Files only listed once in %files listings. OK
MUST: Permissions on files must be set properly. OK
MUST: Clean section exists. OK
MUST: Large documentation files must go in a -doc subpackage. OK
MUST: All relevant items are included in %doc. Items in %doc do not affect runtime of application. OK
MUST: Header files must be in a -devel package. OK
MUST: Static libraries must be in a -static package. OK
MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'. OK
MUST: If a package contains library files with a suffix then library files ending in .so must go in a -devel package. OK
MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency. OK
MUST: Packages does not contain any .la libtool archives. OK
MUST: Desktop files are installed properly. OK
MUST: No file conflicts with other packages and no general names. OK
MUST: Buildroot cleaned before install. OK
SHOULD: %{?dist} tag is used in release. OK
SHOULD: If the package does not include license text(s) as separate files from upstream, the packager should query upstream to include it. OK
SHOULD: The package builds in mock. OK
Comment 2 Susi Lehtola 2009-06-14 12:11:53 EDT
ping vcrhonek
Comment 3 Vitezslav Crhonek 2009-06-15 10:26:54 EDT
(In reply to comment #1)
> - Drop
> Requires: python
> and
> BuildRequires: python
> since both of these are redundant (first is automatically picked up and second
> is a requirement of python-devel).

Fixed.

> 
> - Remove
> CFLAGS="$RPM_OPT_FLAGS"
> from the build phase since this is a noarch package.

Fixed.

> 
> **
> 
> rpmlint output:
> pychecker.noarch: W: summary-ended-with-dot A python source code checking tool.
> pychecker.noarch: E: tag-not-utf8 %changelog
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/Stack.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/OP.py 0644
> pychecker.noarch: W: file-not-utf8 /usr/share/doc/pychecker-0.8.17/MAINTAINERS
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/warn.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/printer.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/CodeChecks.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/Warning.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/msgs.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/utils.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/Config.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/checker.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/function.py 0644
> pychecker.noarch: E: non-executable-script
> /usr/lib/python2.5/site-packages/pychecker/python.py 0644
> pychecker.src: W: summary-ended-with-dot A python source code checking tool.
> pychecker.src: E: tag-not-utf8 %changelog
> pychecker.src: E: non-utf8-spec-file
> /tmp/rpmlint.pychecker-0.8.17-8.fc10.src.rpm.t9ghWq/pychecker.spec
> 2 packages and 0 specfiles checked; 15 errors, 3 warnings.
> 
> - Fix the above. You can get rid of the non-executable script errors by
> removing the shebang with sed in the setup phase, e.g. 
> sed -i -e '1d' pychecker/checker.py

Fixed.

> 
> - Maybe add "-O1 --skip-build" to the install argument of setup.py?

There are problems with '--skip-build'.

> 
> MUST: The spec file for the package is legible and macros are used
> consistently. OK
> MUST: The package must be named according to the Package Naming Guidelines. OK
> MUST: The spec file name must match the base package %{name}. OK
> MUST: The package must be licensed with a Fedora approved license and meet the 
> Licensing Guidelines. OK
> 
> MUST: The License field in the package spec file must match the actual license.
> OK
> - Source code contains no license heders, please ask upstream to add them.
> 
> MUST: The sources used to build the package must match the upstream source, as
> provided in the spec URL. OK
> MUST: The package MUST successfully compile and build into binary rpms. OK
> MUST: The spec file MUST handle locales properly. OK
> MUST: Optflags are used and time stamps preserved. OK
> MUST: Packages containing shared library files must call ldconfig. OK
> MUST: A package must own all directories that it creates or require the package
> that owns the directory. OK
> MUST: Files only listed once in %files listings. OK
> MUST: Permissions on files must be set properly. OK
> MUST: Clean section exists. OK
> MUST: Large documentation files must go in a -doc subpackage. OK
> MUST: All relevant items are included in %doc. Items in %doc do not affect
> runtime of application. OK
> MUST: Header files must be in a -devel package. OK
> MUST: Static libraries must be in a -static package. OK
> MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'. OK
> MUST: If a package contains library files with a suffix then library files
> ending in .so must go in a -devel package. OK
> MUST: In the vast majority of cases, devel packages must require the base
> package using a fully versioned dependency. OK
> MUST: Packages does not contain any .la libtool archives. OK
> MUST: Desktop files are installed properly. OK
> MUST: No file conflicts with other packages and no general names. OK
> MUST: Buildroot cleaned before install. OK
> SHOULD: %{?dist} tag is used in release. OK
> SHOULD: If the package does not include license text(s) as separate files from
> upstream, the packager should query upstream to include it. OK
> SHOULD: The package builds in mock. OK
Comment 4 Susi Lehtola 2009-06-15 10:44:39 EDT
Okay. Everything seems OK, but I can't check the rpmlint warnings since you haven't built the package in rawhide. Those were minor issues anyway.

APPROVED
Comment 5 Andy Grover 2013-05-08 18:49:59 EDT
Package Change Request
======================
Package Name: pychecker
New Branches: el5 el6
Owners: vcrhonek grover
InitialCC: 

Hi I'd like to get pychecker in epel, happy to help out with packaging.
Comment 6 Jon Ciesla 2013-05-08 19:40:46 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.