Bug 226350 - Merge Review: PyXML
Merge Review: PyXML
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:47 EST by Nobody's working on this, feel free to take it
Modified: 2010-03-23 09:13 EDT (History)
2 users (show)

See Also:
Fixed In Version: PyXML-0.8.4-18.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 09:13:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dnovotny: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:47:21 EST
Fedora Merge Review: PyXML

http://cvs.fedora.redhat.com/viewcvs/devel/PyXML/
Initial Owner: laroche@redhat.com
Comment 1 Daniel Novotny 2010-01-18 06:52:44 EST
I'll take this. CC-ing the maintainer
Comment 2 Daniel Novotny 2010-01-18 07:35:45 EST
OK source files match upstream:
1f7655050cebbb664db976405fdba209  PyXML-0.8.4.tar.gz
OK source contains full URL
OK package meets naming and versioning guidelines.
Packages of python modules (thus they rely on python as a parent) use a slightly different naming scheme. They should take into account the upstream name of the python module. This makes a package name format of python-$NAME. When in doubt, use the name of the module that you type to import it in a script.
There is an exception to this rule. If the upstream source has "py" (or "Py") in its name, you can use that name for the package. So, for example, pygtk is acceptable. 
=> PyXML is acceptable

OK specfile is properly named, is cleanly written and uses macros consistently.
OK dist tag is present.
OK build root is correct.
OK license field matches the actual license (MIT and Python and ZPLv1.0 and BSD).
OK license is open source-compatible. License text included in package.
OK latest version is being packaged.
OK BuildRequires are proper.
OK compiler flags are appropriate.
OK %clean is present.
OK package builds in mock.
OK debuginfo package looks complete.
BAD rpmlint is silent.

rpmlint on spec is OK, rpmlint on rpms yields:
PyXML.i386: E: non-executable-script /usr/lib/python2.6/site-packages/_xmlplus/xslt/_4xslt.py 0644 /usr/bin/env
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed.  If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

PyXML.i386: E: non-executable-script /usr/lib/python2.6/site-packages/_xmlplus/dom/html/GenerateHtml.py 0644 /usr/bin/env
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed.  If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

PyXML.i386: E: non-executable-script /usr/lib/python2.6/site-packages/_xmlplus/dom/ext/c14n.py 0644 /usr/bin/env
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed.  If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

- adding the x bit will imho fix this

PyXML.i386: W: wrong-file-end-of-line-encoding /usr/share/doc/PyXML-0.8.4/xmlproc/standard.css
This file has wrong end-of-line encoding, usually caused by creation or
modification on a non-Unix system. It could prevent it from being displayed
correctly in some circumstances.

- please examine the file


PyXML.i386: W: file-not-utf8 /usr/share/doc/PyXML-0.8.4/CREDITS
The character encoding of this file is not UTF-8.  Consider converting it in
the specfile's %prep section for example using iconv(1).

PyXML.i386: W: file-not-utf8 /usr/share/doc/PyXML-0.8.4/xml-howto.txt
The character encoding of this file is not UTF-8.  Consider converting it in
the specfile's %prep section for example using iconv(1).

PyXML.i386: W: file-not-utf8 /usr/share/doc/PyXML-0.8.4/xml-ref.txt
The character encoding of this file is not UTF-8.  Consider converting it in
the specfile's %prep section for example using iconv(1).

PyXML.i386: W: file-not-utf8 /usr/share/doc/PyXML-0.8.4/README
The character encoding of this file is not UTF-8.  Consider converting it in
the specfile's %prep section for example using iconv(1).

PyXML.i386: W: file-not-utf8 /usr/share/doc/PyXML-0.8.4/ANNOUNCE
The character encoding of this file is not UTF-8.  Consider converting it in
the specfile's %prep section for example using iconv(1).

-these are probably plaintext files, so that's OK

PyXML.i386: W: file-not-in-%lang /usr/lib/python2.6/site-packages/_xmlplus/dom/de/LC_MESSAGES/4Suite.mo
PyXML.i386: W: file-not-in-%lang /usr/lib/python2.6/site-packages/_xmlplus/dom/en_US/LC_MESSAGES/4Suite.mo
PyXML.i386: W: file-not-in-%lang /usr/lib/python2.6/site-packages/_xmlplus/dom/fr/LC_MESSAGES/4Suite.mo

-the %lang tag seems to be removed in Bug 113268
 please investigate.

OK final provides and requires look sane.
N/A %check is present and all tests pass.
OK no shared libraries are added to the regular linker search paths.
- they are in the library directory, which is OK
OK owns the directories it creates.
OK doesn't own any directories it shouldn't.
OK no duplicates in %files.
OK file permissions are appropriate.
OK no scriptlets present.
OK code, not content.
OK documentation is small, so no -docs subpackage is necessary.
OK %docs are not necessary for the proper functioning of the package.
OK no headers.
OK no pkgconfig files.
OK no libtool .la droppings.
OK not a GUI app.

overall OK, except for the rpmlint errors

also, in %files section %defattr(-,root,root) is deprecated, please use %defattr(-,root,root,-)
Comment 3 Roman Rakus 2010-03-22 10:51:27 EDT
Should be fixed in PyXML-0.8.4-17.fc14
Comment 4 Roman Rakus 2010-03-22 11:14:24 EDT
Previous version had missing build requirement. Successfully built is PyXML-0.8.4-18.fc14
Comment 5 Daniel Novotny 2010-03-23 09:13:24 EDT
everything seems OK, thanks
review +

Note You need to log in before you can comment on or make changes to this bug.