Bug 226355 - Merge Review: rarpd
Merge Review: rarpd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:48 EST by Nobody's working on this, feel free to take it
Modified: 2013-08-21 15:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: rarpd-ss981107-42.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 15:02:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jpopelka: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:48:03 EST
Fedora Merge Review: rarpd

http://cvs.fedora.redhat.com/viewcvs/devel/rarpd/
Initial Owner: pknirsch@redhat.com
Comment 1 Jiri Popelka 2010-07-14 12:43:42 EDT
NO source files match upstream.
- The source URL is not accessible.
  I think Debian's ftp can be used instead
  http://ftp.debian.org/debian/pool/main/r/rarpd/

YES package meets naming and versioning guidelines.
YES specfile is properly named, is cleanly written and uses macros consistently.
YES dist tag is present.
YES build root is correct.
YES license field matches the actual license.
YES license is open source-compatible.

NO License text included in package.

YES latest version is being packaged.
YES BuildRequires are proper.
YES compiler flags are appropriate.
YES %clean is present.
YES package builds in mock (Rawhide/x86_64).
YES debuginfo package looks complete.

NO rpmlint is silent.
 rarpd.x86_64: W: no-url-tag
 rarpd.x86_64: W: conffile-without-noreplace-flag /etc/rc.d/init.d/rarpd
 rarpd.x86_64: E: executable-marked-as-config-file /etc/rc.d/init.d/rarpd
 - do not mark initscript with %config
 - use %{_initddir} instead of /etc/rc.d/init.d

NO final provides and requires look sane.
 - Prereq should be replaced with Requires

N/A %check is present and all tests pass.
YES no shared libraries are added to the regular linker search paths.
YES owns the directories it creates.
YES doesn't own any directories it shouldn't.
YES no duplicates in %files.
YES file permissions are appropriate.
YES no scriptlets present.
YES code, not content.
YES documentation is small, so no -docs subpackage is necessary.
YES %docs are not necessary for the proper functioning of the package.
YES no headers.
YES no pkgconfig files.
YES no libtool .la droppings.
Comment 2 Honza Horak 2013-06-11 09:54:31 EDT
I'm going to add rarpd into EPEL-6, since there is some demand for it. Therefore I'd like to finish this ancient review.

Jirka, would you be willing to look at it again if there is everything ok?

(In reply to Jiri Popelka from comment #1)
> NO source files match upstream.
> - The source URL is not accessible.
>   I think Debian's ftp can be used instead
>   http://ftp.debian.org/debian/pool/main/r/rarpd/

That one doesn't include the same tarball AFAICT, but this one does:
ftp://ftp.fi.netbsd.org/.m/mirrors1/ftp.inr.ac.ru/ip-routing/dhcp.bootp.rarp/rarpd-%{version}.tar.gz

> NO License text included in package.

Added manually, since upstream is dead.

> NO rpmlint is silent.
>  rarpd.x86_64: W: no-url-tag

Upstream is dead with no official page, except man pages and package databases. I have no idea how to fix it.

>  rarpd.x86_64: W: conffile-without-noreplace-flag /etc/rc.d/init.d/rarpd
>  rarpd.x86_64: E: executable-marked-as-config-file /etc/rc.d/init.d/rarpd
>  - do not mark initscript with %config
>  - use %{_initddir} instead of /etc/rc.d/init.d

We use systemd unit files now.

> NO final provides and requires look sane.
>  - Prereq should be replaced with Requires

Fixed.

NEW SRPM: http://pkgs.fedoraproject.org/cgit/rarpd.git/tree/rarpd.spec
KOJI BUILD: http://koji.fedoraproject.org/koji/buildinfo?buildID=425941
Comment 3 Jiri Popelka 2013-06-11 12:16:19 EDT
Everything looks good to me. APPROVED!
Comment 4 Honza Horak 2013-06-11 13:53:44 EDT
Package Change Request
======================
Package Name: rarpd
New Branches: el6
Owners: hhorak
Comment 5 Jon Ciesla 2013-06-11 14:17:47 EDT
Git done (by process-git-requests).
Comment 6 Fedora Update System 2013-06-12 06:06:44 EDT
rarpd-ss981107-42.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rarpd-ss981107-42.el6
Comment 7 Fedora Update System 2013-06-12 16:07:24 EDT
rarpd-ss981107-42.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 8 Fedora Update System 2013-08-21 15:02:49 EDT
rarpd-ss981107-42.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.