Bug 226358 - Merge Review: rdesktop
Merge Review: rdesktop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:48 EST by Nobody's working on this, feel free to take it
Modified: 2014-08-22 17:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-22 17:22:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
orion: fedora‑review+


Attachments (Terms of Use)
Patch file for the rdesktop spec file (1.68 KB, patch)
2008-11-15 08:29 EST, Fabian Affolter
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:48:39 EST
Fedora Merge Review: rdesktop

http://cvs.fedora.redhat.com/viewcvs/devel/rdesktop/
Initial Owner: besfahbo@redhat.com
Comment 1 Tyler Owen 2007-12-03 22:32:32 EST
-------------------------------------------
Summary:
-------------------------------------------
* rpmlint not silent
* License needs updating to new format
* Source0 does not contain full URL
* Desktop file not installed correctly

-------------------------------------------
Details:
------------------------------------------- 

 OK - Mock : Built on Koji dist-f8 & dist-f9 
 OK - Package meets naming and packaging guidelines
 OK - Spec file matches base package name.
 OK - Spec has consistant macro usage.
 OK - Meets Packaging Guidelines.
 FIX - License field in spec matches
 FIX - License in new format
 OK - License matches Fedora packaging policy licenses allowed
 OK - License file is included in package
 OK - Spec in American English
 OK - Spec is legible.
 FIX - Sources SHOULD match upstream md5sum:
433546f60fc0f201e99307ba188369ed  rdesktop-1.5.0.tar.gz
        * Source tag missing full path to source.  Should be: 
http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
 OK - Package has correct buildroot.
 OK - BuildRequires are not redundant.
 OK - %build and %install stages are correct and work.
 OK - Package has %defattr and permissions on files is good.
 OK - Package has a correct %clean section.
 OK - Package is code or permissible content.
 OK - Packages %doc files don't affect runtime.
 OK - Package has no duplicate files in %files.
 OK - Package doesn't own any directories that other packages own.
 OK - Changelog section is correct. 

 OK - Should function as described.
 OK - Should package latest version

-------------------------------------------
Rpmlint output:
-------------------------------------------
FIX - SRPM
rdesktop.src: W: invalid-license GPL

FIX - RPM
rdesktop.i386: W: file-not-utf8 /usr/share/doc/rdesktop-1.5.0/licensing.txt
rdesktop.i386: W: file-not-utf8 /usr/share/doc/rdesktop-1.5.0/AUTHORS
rdesktop.i386: W: invalid-license GPL
Comment 2 Tyler Owen 2008-01-11 10:41:30 EST
ping?
Comment 3 Fabian Affolter 2008-10-28 05:17:53 EDT
(In reply to comment #1)
> * License needs updating to new format

- This was fixed from Tom "spot" Callaway
  http://cvs.fedora.redhat.com/viewvc/devel/rdesktop/rdesktop.spec?r1=1.30&r2=1.31

> * Source0 does not contain full URL

- not fixed

> * Desktop file not installed correctly

- not fixed
Comment 4 Fabian Affolter 2008-11-15 08:29:00 EST
Created attachment 323691 [details]
Patch file for the rdesktop spec file 

This patch should fix the issues mentioned in Comment #1.
Comment 5 Fabian Affolter 2009-01-08 07:56:50 EST
I guess the owner is Soren Sandmann Pedersen.  Added as cc.
Comment 6 Fabian Affolter 2009-03-09 11:06:22 EDT
ping?
Comment 7 Behdad Esfahbod 2009-03-09 13:34:44 EDT
Fabian, commit please.
Comment 8 Fabian Affolter 2009-05-06 09:48:25 EDT
Behdad, I requested commit access for this package a while ago, but nothing happen.  In fact the package maintainer should patch the spec file, build the package, and a packager should do the merge review ;-)
Comment 9 Behdad Esfahbod 2009-05-11 15:48:44 EDT
Fabian, the package is owned by Soeren Sandmann these days, not me.
Comment 10 Fabian Affolter 2009-05-12 18:22:22 EDT
Check https://bugzilla.redhat.com/show_activity.cgi?id=226358 ;-)  He/she was added to cc a long time ago
Comment 11 Fabian Affolter 2009-07-18 05:56:05 EDT
The last build:  rdesktop-1.6.0-5.fc12  	ssp  	2009-05-01 20:17:58

Assignee changed.
Comment 12 Fabian Affolter 2009-07-18 05:58:48 EDT
Sorry, reassign to tyler.l.owen gmail.com since this is not a bug report but a 'Merge review'
Comment 13 Thomas Spura 2010-07-19 06:25:52 EDT
Tomas Mraz recently rebuild this package -> CC'ing

Maybe now we get some progress here.
Comment 14 Tomas Mraz 2010-08-02 06:15:04 EDT
I am sorry, I don't own this package not even as a comaintainer.
Comment 15 Jason Tibbitts 2010-08-02 07:13:01 EDT
What needs to be fixed here?  I'm a provenpackager; I'll commit needed fixes unless they're controversial.
Comment 16 Orion Poplawski 2014-08-22 17:22:32 EDT
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed

So, should make a comment on the patch and submit it upstream.  But not a must so closing this.

===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL (v3 or later)", "Unknown or generated". 3 files have unknown
     license. Detailed output of licensecheck in
     /export/home/orion/fedora/rdesktop/review-rdesktop/licensecheck.txt
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[X]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 92160 bytes in 12 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[!]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define unless justified.
     Note: %define requiring justification: %define credssp --disable-credssp,
     %define credssp --enable-credssp
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: SourceX is a working URL.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Package should not use obsolete m4 macros
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: rdesktop-1.8.2-3.fc22.x86_64.rpm
          rdesktop-1.8.2-3.fc22.src.rpm
rdesktop.x86_64: W: spelling-error %description -l en_US natively -> naively, negatively, tentatively
rdesktop.src: W: spelling-error %description -l en_US natively -> naively, negatively, tentatively
2 packages and 0 specfiles checked; 0 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint rdesktop
rdesktop.x86_64: W: spelling-error %description -l en_US natively -> naively, negatively, tentatively
rdesktop.x86_64: W: invalid-url URL: http://www.rdesktop.org/ <urlopen error [Errno -3] Temporary failure in name resolution>
1 packages and 0 specfiles checked; 0 errors, 2 warnings.
# echo 'rpmlint-done:'



Requires
--------
rdesktop (rpmlib, GLIBC filtered):
    libX11.so.6()(64bit)
    libXrandr.so.2()(64bit)
    libao.so.4()(64bit)
    libao.so.4(LIBAO4_1.1.0)(64bit)
    libc.so.6()(64bit)
    libcrypto.so.10()(64bit)
    libcrypto.so.10(libcrypto.so.10)(64bit)
    libpcsclite.so.1()(64bit)
    libpthread.so.0()(64bit)
    libsamplerate.so.0()(64bit)
    libsamplerate.so.0(libsamplerate.so.0.0)(64bit)
    libsamplerate.so.0(libsamplerate.so.0.1)(64bit)
    libssl.so.10()(64bit)
    libssl.so.10(libssl.so.10)(64bit)
    rtld(GNU_HASH)



Provides
--------
rdesktop:
    rdesktop
    rdesktop(x86-64)



Source checksums
----------------
http://downloads.sourceforge.net/rdesktop/rdesktop-1.8.2.tar.gz :
  CHECKSUM(SHA256) this package     : fbbf23d49d34c215c5a59b2d91c008b61ead4c9fbe1ccb7223973aed24061a78
  CHECKSUM(SHA256) upstream package : fbbf23d49d34c215c5a59b2d91c008b61ead4c9fbe1ccb7223973aed24061a78


Generated by fedora-review 0.5.2 (63c24cb) last change: 2014-07-14
Command line :/usr/bin/fedora-review -n rdesktop
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG

Note You need to log in before you can comment on or make changes to this bug.