Bug 226367 - Merge Review: reiserfs-utils
Merge Review: reiserfs-utils
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:49 EST by Nobody's working on this, feel free to take it
Modified: 2009-04-01 10:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:49:47 EST
Fedora Merge Review: reiserfs-utils

http://cvs.fedora.redhat.com/viewcvs/devel/reiserfs-utils/
Initial Owner: jgarzik@redhat.com
Comment 1 Jon Ciesla 2008-09-16 13:05:18 EDT
rpmlint on SRPM and RPMS are clean.

Upstream Source is 404 due to namesys.com DNS issues, but md5sum matches kernel.org version, which I think is Good Enough under the circumstances.

Any reason it's called reiserfs-utils and not the upstream reiserfsprogs?  I assume some sort of fs-util nameing convention?  If so, document in spec.

Otherwise, full review is great, very tidy package, no other blockers.
Comment 2 Jon Ciesla 2008-12-10 09:10:34 EST
Ping?
Comment 3 Jon Ciesla 2009-03-31 11:27:40 EDT
Ping again?
Comment 4 Jeff Garzik 2009-03-31 16:19:40 EDT
Somebody needs to poke Fedora Project about this package, as I have not cared about it in a long, long time.

Feel free to offer to maintain this Fedora package, if you wish!
Comment 5 Jason Tibbitts 2009-03-31 17:52:46 EDT
If you don't want to maintain it, why don't you orphan it?  The only reason it persists in the distro is because you're still listed as the owner.
Comment 6 Jason Tibbitts 2009-03-31 18:04:25 EDT
Actually, I think I'll just save you the trouble.  Sorry for the pkgdb spam you'll receive.  Maybe someone who wants this package will pick it up.
Comment 7 Jeff Garzik 2009-03-31 18:10:26 EDT
Thanks!
Comment 8 Itamar Reis Peixoto 2009-03-31 21:42:45 EDT
please tell me what's need's to be fixed.
Comment 9 acount closed by user 2009-04-01 07:50:24 EDT
(In reply to comment #8)

> please tell me what's need's to be fixed.

Latest release is 3.6.21:

This is first stable release since 2004-10-13, and it contains changes made by
Jeff Mahoney (everything got testing as a part of latest SuSE distros).

2009-01-09
        Patches from Jeff Mahoney:
        - reiserfsprogs-mkreiserfs-quiet.diff
        - reiserfsprogs-large-block-warning.diff
        - reiserfsprogs-fsck-mapid.diff
        - reiserfsprogs-external-journal-changes.diff
        - reiserfsprogs-remove-stupid-fsck_sleep.diff
        - reiserfsprogs-mkfs-use-o_excl.diff
        - reiserfsprogs-enforce-block-limit.diff
        - reiserfsprogs-large-fs.diff
        - reiserfsprogs-better-fsck-a-behavior.diff
        - reiserfsprogs-remove-dependency-on-asm_unaligned.h.diff
        - reiserfsprogs-progress.diff
        - reiserfsprogs-reorder-libs.diff

        Patches from Ludwig Nussel:
        -
mkreiserfs-set-the-owner-of-the-root-directory-to-the-calling-user.diff

        Patches from Edward Shishkin:
        - reiserfsprogs-disable-small-block.diff
        - reiserfsprogs-new-version.diff


The URL tag in the .spec file should be changed to the new $HOME at:
http://ftp.kernel.org/pub/linux/utils/fs/reiserfs/


-thanks-
Comment 10 Jon Ciesla 2009-04-01 08:46:18 EDT
Itamar, basically correct the URL tag.  I'd have liked to have had some explanation of the naming being different than upstream (reiserfs-utils/reiserfsprogs), but that would have come from Jeff, ideally, so I'll let that go.
Comment 11 Itamar Reis Peixoto 2009-04-01 10:09:20 EDT
(In reply to comment #10)
> Itamar, basically correct the URL tag.  I'd have liked to have had some
> explanation of the naming being different than upstream
> (reiserfs-utils/reiserfsprogs), but that would have come from Jeff, ideally, so
> I'll let that go.  

the future of reiserfs is still obscure [1], about the name , I recommend to let the current name, this package will probably removed in next merge review

[1] - http://en.wikipedia.org/wiki/Reiser4


http://ispbrasil.com.br/reiserfs-utils/reiserfs-utils.spec
http://ispbrasil.com.br/reiserfs-utils/reiserfs-utils-3.6.21-1.fc11.src.rpm


koji scratch build dist-f11

http://koji.fedoraproject.org/koji/taskinfo?taskID=1270246

Can I go ahead and commit to cvs ?
Comment 12 Jon Ciesla 2009-04-01 10:45:18 EDT
Looks great.  APPROVED.  Commit and build.

Thanks for finishing this, and taking over the package.

Note You need to log in before you can comment on or make changes to this bug.