Bug 226368 - Conflicting options can't be remedied, and confusing messages
Conflicting options can't be remedied, and confusing messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-01-31 15:49 EST by Jonathan Underwood
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.7.52-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 04:55:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2007-01-31 15:49:48 EST
Description of problem:
When editing in the Printer Options tab, I clicked Apply, and a message box
appeared saying "There are conflicting options. Changes can only be applied
after these conflicts are resolved." Also, the Apply and Revert buttons become
greyed out at that point. However, it didn't say where the conflict was
(unhelpful), and no matter what I changed, the Apply and Revert buttons remained
greyed out. So, I think this needs some work to be useable. Either indicate
which options are conflicting, or undo the last lot of changes so at least the
user can proceed somehow. Or even better, find a mechanism by which conflicting
options can't be selected.

[I hope I don't sound overly critical though, the new system-config-printer is a
fantastic improvement over the FC-5 and earlier one, it's a real achievement]

Version-Release number of selected component (if applicable):
system-config-printer-libs-0.7.49-1.fc6
system-config-printer-0.7.49-1.fc6

How reproducible:
everytime

Steps to Reproduce:
1.Create conflicting options
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2007-02-07 11:32:27 EST
The conflicting options should be marked with yellow warning triangles.  Perhaps
they are on a separate tab somewhere (e.g. Installable Options)?  Can you find any?
Comment 2 Jonathan Underwood 2007-02-07 11:43:59 EST
Oh, yes, so they are.

What I was doing is selecting Long-Edge Binding (previously "Off") in the
2-sided printing option in the Printer Options tab. This was throwing the
conflict i described above. Looking now, I realize this was because under the
Installable Optons, the Duplex Unit wasn't ticked.

So, i think the program is behaving as you want, and so this is less of a bug
and more of either a) me being dumb and not looking at all of the tabs b) the
GUI being a bit counterintuitive. 

A possible solution - the program knows something about the conflict, as
clicking theexclamation mark besides the (unchecked) Duplex Unit check box
brings up a dialog saying "Conflicts with: 2-Sided Printing". However, that
information is NOT displayed when I click on the exclamation button next to the
greyed out Revert and Apply - that simply brings up a dialogue saying "There are
conflicting options. Changes can only be applied after these conflicts are
resolved." If that dialogue had added the extra information "Duplex tray not
selected (see Installable Options tab) - this conflicts with Long Edged two
sided printing selected in the Options tab" I would've understood :).
Comment 3 Jonathan Underwood 2007-02-07 11:46:21 EST
Oh, also, having an exclamation mark appear by the 2 sided printing selection
box would also make sense.
Comment 4 Tim Waugh 2007-02-08 12:16:46 EST
I've committed a change so that the main warning triangle next to apply/revert
says this sort of thing when you click it:

==>
There are conflicting options.
Changes can only be applied after
these conflicts are resolved.

Tray 2
Media Source
<==

It's quite difficult to construct real sentences from a list like this because
of the translatable text, and the fact that there may be any number of options
that conflict with any number of other options (i.e. 'Tray 2' option might
conflict with three other options).

I've also made the tab labels become bold when one of their options is in conflict.
Comment 5 Jonathan Underwood 2007-02-08 12:31:41 EST
OK, great. Are you pushing an update for FC-6 with these changes, or is this
devel only?
Comment 6 Tim Waugh 2007-02-08 12:36:54 EST
I'll include these changes in the test update currently in progress before
releasing it as a final update.
Comment 7 Tim Waugh 2007-02-13 08:05:11 EST
Please try 0.7.50-1.fc7 from updates-testing:

yum --enablerepo=updates-testing update 'system-config-printer*'
Comment 8 Fedora Update System 2007-02-14 15:00:17 EST
Fixed in update: system-config-printer-0.7.52-1.fc6

Note You need to log in before you can comment on or make changes to this bug.