Bug 2264049 - dnsmasq-2.90 is available
Summary: dnsmasq-2.90 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL: https://lists.thekelleys.org.uk/piper...
Whiteboard:
Depends On:
Blocks: 2264102 2264103
TreeView+ depends on / blocked
 
Reported: 2024-02-13 15:28 UTC by Upstream Release Monitoring
Modified: 2024-02-29 01:56 UTC (History)
3 users (show)

Fixed In Version: dnsmasq-2.90-1.fc39 dnsmasq-2.90-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-19 02:28:05 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Upstream Release Monitoring 2024-02-13 15:28:43 UTC
Releases retrieved: 2.90
Upstream release that is considered latest: 2.90
Current version/release in rawhide: 2.89-9.fc40
URL: http://www.thekelleys.org.uk/dnsmasq/doc.html

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/444/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dnsmasq

Comment 1 Upstream Release Monitoring 2024-02-13 15:29:04 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Couldn't upload source /var/tmp/thn-6m2y6cgy/./SRPMS/dnsmasq-2.90-1.fc38.src.rpm to koji.

Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 252, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 477, in _scratch_build
    raise BuilderException("Couldn't upload source {} to koji.".format(source))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 3 Fedora Update System 2024-02-13 23:50:55 UTC
FEDORA-2024-e00eceb11c (dnsmasq-2.90-1.fc38) has been submitted as an update to Fedora 38.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-e00eceb11c

Comment 4 Fedora Update System 2024-02-13 23:51:34 UTC
FEDORA-2024-e24211eff0 (dnsmasq-2.90-1.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-e24211eff0

Comment 5 Fedora Update System 2024-02-14 02:11:40 UTC
FEDORA-2024-e24211eff0 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-e24211eff0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-e24211eff0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2024-02-14 02:25:40 UTC
FEDORA-2024-e00eceb11c has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-e00eceb11c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-e00eceb11c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2024-02-19 02:28:05 UTC
FEDORA-2024-e24211eff0 (dnsmasq-2.90-1.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2024-02-29 01:56:54 UTC
FEDORA-2024-e00eceb11c (dnsmasq-2.90-1.fc38) has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.