Bug 226412 - Merge Review: setup
Merge Review: setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 15:58 EST by Nobody's working on this, feel free to take it
Modified: 2009-03-24 08:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 08:46:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:58:30 EST
Fedora Merge Review: setup

http://cvs.fedora.redhat.com/viewcvs/devel/setup/
Initial Owner: pknirsch@redhat.com
Comment 1 Patrice Dumas 2007-11-14 18:03:51 EST
Currently filesystem depends on setup. Shouldn't it be the
other way around?
Comment 2 Robert Scheck 2007-11-14 18:07:33 EST
AFAIK filesystem is the first package installed, because it provides / (the 
real root) where everything else depends on.
Comment 3 Patrice Dumas 2007-11-14 18:18:43 EST
But it is not the case since it depends on setup.
Comment 4 Jon Ciesla 2008-12-11 11:43:27 EST
rpmlint on SRPM clean.

rpmlint on RPMS:

setup.noarch: E: non-readable /etc/securetty 0600
The file can't be read by everybody. If this is expected (for security
reasons), contact your rpmlint distributor to get it added to the list of
exceptions for your distro (or add it to your local configuration if you
installed rpmlint from the source tarball).

setup.noarch: E: zero-length /etc/environment
setup.noarch: E: zero-length /etc/motd
setup.noarch: E: non-readable /etc/shadow 0400
The file can't be read by everybody. If this is expected (for security
reasons), contact your rpmlint distributor to get it added to the list of
exceptions for your distro (or add it to your local configuration if you
installed rpmlint from the source tarball).

setup.noarch: E: non-readable /etc/gshadow 0400
The file can't be read by everybody. If this is expected (for security
reasons), contact your rpmlint distributor to get it added to the list of
exceptions for your distro (or add it to your local configuration if you
installed rpmlint from the source tarball).

setup.noarch: E: standard-dir-owned-by-package /etc/profile.d
This package owns a directory that is part of the standard hierarchy, which
can lead to default directory permissions or ownerships being changed to
something non-standard.

setup.noarch: E: zero-length /etc/exports
setup.noarch: W: log-files-without-logrotate /var/log/lastlog
This package contains files in /var/log/ without adding logrotate
configuration for them.

These should all be filed as rpmlint exceptions.

Page in URL is default Trac page.  Might want to look into that. :)

Source tag needs to include a URL:
https://fedoraproject.org/wiki/Packaging/SourceURL
Should also be Source0, not simply Source.

I don't see any license information in the source or the website, just the spec.  Add something to the upstream documenting the licensing, then include it in %doc.

Otherwise, very simple package, no other blockers.
Comment 5 Ondrej Vasik 2009-03-23 10:06:30 EDT
Thanks for review, accidently I was not on CC after I got that package under maintainance, so sorry for late response. will contact rpmlint maintainer as those files should really be in rpmlint exceptions list. 
I added basic "one-minute-work" starting page instead of Trac page, fixed Source (and uploaded tarball on fedorahosted.org/releases/). 
License information was also added on starting page, as .spec file is part of tarball, I guess it's not needed to add license information into separate COPYING (or something like that) file - but if you feel it's worth of it, no problem, I could create such file and ship it as %doc file.
Comment 6 Ondrej Vasik 2009-03-23 10:22:39 EDT
Adding rpmlint maintainer to CC, to keep exception list discussion within that review.
Comment 7 Jon Ciesla 2009-03-23 13:39:51 EDT
Looks good.  Based on my interpretation of the guidelines here:

https://fedoraproject.org/wiki/Packaging/LicensingGuidelines#License_Text

I'd say make the COPYING file and put it in %doc.  Makes it easier to find, since though rpm -qi is pretty easy, that won't work on a system booted from a livecd with it's hard drives under examination, etc.


Thanks for getting back to this. :)
Comment 8 Ville Skyttä 2009-03-23 15:05:25 EDT
/etc/shadow, /etc/gshadow and /etc/securetty are now ok as unreadable in upstream rpmlint, I'm not sure if the others need any exceptions (rpmlint can always be ignored...) http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1580
Comment 9 Ondrej Vasik 2009-03-24 07:22:38 EDT
(In reply to comment #8)
You are right, rpmlint can always be ignored, just as suggestion - I guess errors for empty files should be silenced or changed to warnings in the case of config files. Config files purpose is user modification and could be empty many times.

(In reply to comment #7)
Done, COPYING file in %doc shipped in setup-2.8.2-1.fc11
Comment 10 Jon Ciesla 2009-03-24 08:46:23 EDT
Great!  APPROVED.  Thanks for your work.

Note You need to log in before you can comment on or make changes to this bug.