Bug 2264130 - uhttpmock 0.9.0 available
Summary: uhttpmock 0.9.0 available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uhttpmock
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jonathan Wright
QA Contact: Fedora Extras Quality Assurance
URL: https://gitlab.freedesktop.org/pwithn...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-02-14 05:38 UTC by Jan-Michael Brummer
Modified: 2024-03-02 20:44 UTC (History)
2 users (show)

Fixed In Version: uhttpmock-0.9.0-1.fc41
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-02 20:44:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Jan-Michael Brummer 2024-02-14 05:38:08 UTC
Since end of 2022 version 0.9.0 of uhttpmock is available. This is a major update as it features the switch from soup 2.4 to 3.0 which is noawdays a recommended changes. libgdata is currently switching to libsoup 3.0 and uses uhttpmock for testing, furthermore the newly introduced OneDrive support in gvfs is making use of recent uhttpmock for testing.

Currently CI pipeline will fail as Fedora does not ship a recent version, neither in 38/39 or Rawhide.

Please update to the latest version (most likely a new package to install it beside the soup 2.4 version).

Reproducible: Always

Comment 1 Fedora Update System 2024-03-02 20:42:18 UTC
FEDORA-2024-156900b94e (uhttpmock-0.9.0-1.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-156900b94e

Comment 2 Fedora Update System 2024-03-02 20:44:18 UTC
FEDORA-2024-156900b94e (uhttpmock-0.9.0-1.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.