Bug 226419 - Merge Review: sip
Summary: Merge Review: sip
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Garrett Holmstrom
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:59 UTC by Nobody's working on this, feel free to take it
Modified: 2011-09-23 18:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-23 18:46:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gholms: fedora-review?


Attachments (Terms of Use)
Review for F14 package sip-4.10.5-2.fc14 (11.60 KB, text/plain)
2010-11-16 23:31 UTC, Garrett Holmstrom
no flags Details

Description Nobody's working on this, feel free to take it 2007-01-31 20:59:28 UTC
Fedora Merge Review: sip

http://cvs.fedora.redhat.com/viewcvs/devel/sip/
Initial Owner: than@redhat.com

Comment 1 Garrett Holmstrom 2010-11-16 23:31:27 UTC
Below are the issues I found.  I will attach a full review shortly.

- License field in spec is correct
  sipgen/parser.c is GPLv3+ with exceptions
  sipgen/parser.h is GPLv3+ with exceptions

A quick IRC discussion indicated that this likely needs to appear in the License field somewhere.  I'm hoping spot gets back to me for confirmation about it to be sure, though perhaps it would be better to just ask legal to be extra certain.

- License files installed when any subpackage combination is installed
  sip-macros package does not pull in license files

It looks like you create macros.sip yourself based on the program's API version.  What license does it have?  Can you include that license along with the sip-macros package?

- Sources match upstream unless altered to fix permissibility issues
  Upstream MD5:  No longer on upstream's server
  Your MD5:      0a591ef6e59aa16e56822d3eb9fe21b8  sip-4.10.5.tar.gz

Unfortunately, upstream seems to clean out old tarballs quite frequently.  I wouldn't block the review because of that, though.

- Each %files section contains %defattr
  The python3 packages lack %defattr macros

Please add %defattr macros to the python3 packages' %files sections.

I hope that helps!

Comment 2 Garrett Holmstrom 2010-11-16 23:31:59 UTC
Created attachment 460953 [details]
Review for F14 package sip-4.10.5-2.fc14

Comment 3 Rex Dieter 2010-11-16 23:42:08 UTC
git's master branch has the latest sip (which should be available upstream), and I *think* defattr fixed too, fwiw.

Comment 4 Rex Dieter 2010-11-16 23:42:48 UTC
nvm, defattr fail there too. :(  fixing that now, easyfix.

Comment 5 Garrett Holmstrom 2010-11-17 19:06:44 UTC
The word from spot is that the License field should read "GPLv2 or GPLv3 and (GPLv3+ with exceptions)".  The spec file should also contain a comment explaining the bison files' license.

Comment 6 Rex Dieter 2011-09-23 18:46:57 UTC
OK, updated License: accordingly in master/ branch.

Stick a fork in this sucker, finally.


Note You need to log in before you can comment on or make changes to this bug.