Bug 226436 - Merge Review: statserial
Merge Review: statserial
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:02 EST by Nobody's working on this, feel free to take it
Modified: 2012-02-13 09:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 07:44:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
wolfy: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:02:06 EST
Fedora Merge Review: statserial

http://cvs.fedora.redhat.com/viewcvs/devel/statserial/
Initial Owner: twaugh@redhat.com
Comment 1 manuel wolfshant 2007-02-08 16:43:31 EST
- there is no URL tag; please provide one if possible
- Package is marked as relocatable; since is a no-no (unless properly documented
and justified), PREFIX should disappear
- BuildRoot does not have the preferred value
- Release tag should include %{dist}
- %build does not honor $RPM_OPT_FLAGS
- %build should use SMP flags. If it doesn't work, please add a comment
- the dot at the end of Summary should be removed
- the tar.gz includes the GPL v2 license, but the package claims license to be BSD; 
- the license file (COPYING) should be included in the binary rpm
- I suggest including the provided phone_log script as %doc


Comment 2 Tim Waugh 2007-02-09 06:09:16 EST
Thanks!  Tagged and built as 1.1-39.fc7.
Comment 3 manuel wolfshant 2007-02-09 07:23:09 EST
Formal review for release 39:

MUST
- package meets naming guidelines
- package meets packaging guidelines
- license ( GPL ) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream, sha1sum 3ace36585c82238003b37f267263f06aad4f0afd 
statserial-1.1.tar.gz
- package compiles on devel (x86_64)
- no missing BR
- no unnecessary BR
- no locales
- not relocatable
- owns all files/directories that it creates, does not take ownership of foreign
files/folders
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file 
- no static, .la, .pc files
- rpmlint is silent on src.rpm; for the binary the following warnings are generated:
W: statserial spurious-executable-perm /usr/share/doc/statserial-1.1/phone_log
W: statserial doc-file-dependency /usr/share/doc/statserial-1.1/phone_log /bin/bash
Since phone_log IS a bash script and bash is supposed to be already installed
anyway, no additional packages are actually pulled so I guess both warnings can
safely be ignored.

SHOULD
- Builds fine in mock for FC6 and devel (x86_64)
- Runs as advertised on FC6/x86_64

Notes:
I have no access to 390 so I can only assume that the hardware being different,
the ExcludeArch is justified.


APPROVED
Comment 4 Tim Waugh 2007-02-09 07:44:58 EST
Thanks!
Comment 5 Dmitry Butskoy 2012-02-13 07:00:29 EST
Package Change Request
======================
Package Name: statserial
New Branches: el6
Owners: buc
Comment 6 Jon Ciesla 2012-02-13 09:48:49 EST
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.