Bug 226462 - Merge Review: system-config-lvm
Merge Review: system-config-lvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:06 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 23:35:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:06:05 EST
Fedora Merge Review: system-config-lvm

http://cvs.fedora.redhat.com/viewcvs/devel/system-config-lvm/
Initial Owner: jparsons@redhat.com
Comment 1 Parag AN(पराग) 2007-09-28 11:24:03 EDT
need some SPEC cleanups
1)  avoid makeinstall usage
http://fedoraproject.org/wiki/Packaging/Guidelines#head-fcaf3e6fcbd51194a5d0dbcfbdd2fcb7791dd002
2) update buildroot tag as said below
http://fedoraproject.org/wiki/Packaging/Guidelines#head-b4fdd45fa76cbf54c885ef0836361319ab962473
3) use make %{?_smp_mflags}

rpmlint said 
system-config-lvm.src: W: mixed-use-of-spaces-and-tabs (spaces: line 100, tab:
line 35)
system-config-lvm.src: W: summary-ended-with-dot A utility for graphically
configuring Logical Volumes.
system-config-lvm.src: W: invalid-license GPL
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/fdisk_wrapper.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/VolumeGroup.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/pixmaps/VG.xpm 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/pixmaps/PV.xpm 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/pixmaps/UV.xpm 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Segment.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Partition.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/ExtentBlock.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/execute.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/renderer.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/utilities.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Cluster.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/BlockDevice.py 0640
system-config-lvm.noarch: W: no-dependency-on usermode
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/lvmui_constants.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/lvm_model.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/parted_wrapper.py 0640
system-config-lvm.noarch: E: non-readable /usr/share/system-config-lvm/Volume.py
0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Filesystem.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/cylinder_items.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/PhysicalVolume.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/pixmaps/grad3.xpm 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/pixmaps/LV.xpm 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/CommandHandler.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/CommandError.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Volume_Tab_View.py 0640
system-config-lvm.noarch: E: non-executable-script
/usr/share/system-config-lvm/Volume_Tab_View.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Properties_Renderer.py 0640
system-config-lvm.noarch: E: non-readable /usr/share/system-config-lvm/Fstab.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/InputController.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/WaitMsg.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/LogicalVolume.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/BlockDeviceModel.py 0640
system-config-lvm.noarch: E: non-readable
/usr/share/system-config-lvm/Multipath.py 0640
system-config-lvm.noarch: W: summary-ended-with-dot A utility for graphically
configuring Logical Volumes.
system-config-lvm.noarch: W: invalid-license GPL
system-config-lvm.noarch: W: conffile-without-noreplace-flag
/etc/pam.d/system-config-lvm
system-config-lvm.noarch: W: conffile-without-noreplace-flag
/etc/security/console.apps/system-config-lvm

Update package. Better to provide new SPEC and SRPM links for this package
before actually committing in CVS.


Comment 2 Ryan McCabe 2007-09-28 13:39:17 EDT
SRPM and spec file at http://people.redhat.com/jparsons/downloads/s-c-lvm/

rpmlint -v produces no warnings now.
Comment 3 Parag AN(पराग) 2007-10-01 00:18:05 EDT
No permission to download SRPM
Comment 4 Parag AN(पराग) 2007-11-14 01:29:53 EST
ping?
Comment 5 Ryan McCabe 2007-12-06 10:28:42 EST
http://people.redhat.com/rmccabe/s-c-lvm/
Comment 6 Parag AN(पराग) 2007-12-07 00:09:45 EST
with updated SPEC,
system-config-lvm.noarch: E: invalid-desktopfile
/usr/share/applications/system-config-lvm.desktop
.desktop file is not valid, check with desktop-file-validate

system-config-lvm.src: W: strange-permission system-config-lvm.spec 0600
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

Comment 7 Parag AN(पराग) 2007-12-18 09:17:07 EST
ping?
Comment 8 Parag AN(पराग) 2007-12-27 06:03:59 EST
ping?
Comment 9 Parag AN(पराग) 2008-01-18 09:10:30 EST
ping?
Comment 10 Parag AN(पराग) 2008-01-23 00:36:46 EST
Owner of this package is not responding here.
Comment 11 Jim Parsons 2008-01-23 12:30:44 EST
Hey - So sorry. I'm here. Will look into above comment about file permissions
and write again today.
Comment 12 Parag AN(पराग) 2008-12-22 03:30:15 EST
ping?
Comment 13 Parag AN(पराग) 2009-01-08 23:37:49 EST
ping?
Comment 14 Parag AN(पराग) 2009-01-13 23:17:55 EST
ping?
Comment 15 Parag AN(पराग) 2009-01-13 23:35:21 EST
Ok. looks like some changes was already committed in rawhide without notifying here for further review.

Based on today's rawhide spec,
+ rpmlint only gave
system-config-lvm.noarch: W: no-dependency-on usermode
==> ok
+ all issues asked to fix since comment#1 looks fixed now in rawhide package.
+ Package now follows packaging guidelines.

APPROVED.

Note You need to log in before you can comment on or make changes to this bug.