Bug 226493 - Merge Review: tix
Summary: Merge Review: tix
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: José Matos
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 21:10 UTC by Nobody's working on this, feel free to take it
Modified: 2014-04-01 16:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-01 16:42:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Review report for tix merge review (50.84 KB, text/plain)
2014-04-01 16:37 UTC, José Matos
no flags Details

Description Nobody's working on this, feel free to take it 2007-01-31 21:10:45 UTC
Fedora Merge Review: tix

http://cvs.fedora.redhat.com/viewcvs/devel/tix/
Initial Owner: mitr@redhat.com

Comment 1 Miloslav Trmač 2008-08-05 08:08:38 UTC
I don't own tix anymore.  If you feel you must assign the bug to anyone, Vitezslav <vcrhonek@redhat.com> is the current package owner.

Comment 2 Brennan Ashton 2008-08-05 08:35:04 UTC
Sorry, trying to get these bugs out of new and onto someone who will deal with them

Comment 3 Vitezslav Crhonek 2008-11-25 14:10:02 UTC
I don't think that doing Merge Review to package owned by myself is good idea. Changing to NEW, adding myself to CC list.

Hope that somebody will take it and go through Merge Review process.

Comment 4 José Matos 2009-01-26 11:47:09 UTC
I would like to take this review. My interest in tix comes from the python side and it is always nice to have one more merge review finished. :-)

I noticed the open review since comment #3 but I have been busy meanwhile. Sorry. :-)

The first standard question regarding this issue is the output of rpmlint over the produced rpms:

tix.i686: W: non-conffile-in-etc /etc/ld.so.conf.d/tix-i386.conf
tix.i686: E: script-without-shebang /usr/lib/tcl8.5/Tix8.4.3/pref/WmDefault.tcl
tix.src: W: patch-not-applied Patch1: tix-8.4.2-tcl8.5.patch
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/twofont.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/notebook.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/combo.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/hierarchy.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/dirlist.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/relation.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/dirtree.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/sl-bar.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/exfile.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/oop/arrows.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/select1.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/pane_vert.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/widgets.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/law_comp.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist_ex3.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/tlist.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tix32.png
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/sl-nobar.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/ARROWS.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist_ex1.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hierarchy.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/pane_horz.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/dirtree.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/lawyer.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/horizontal.gif
tix-doc.i686: W: wrong-file-end-of-line-encoding /usr/share/doc/tix-doc-8.4.3/Release-8.4.0.txt
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/fb_comp.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/ctl_wopt.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/select-vert.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist_ex2.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/joe.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hierarchy.png
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/ctl_subw.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/pane_add.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/vertical.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tix32.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/twofont2.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/select.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/arrows.png
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist1.gif
tix-doc.i686: W: spurious-executable-perm /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/ctl_noopt.gif

Note that I am quite aware that some of the those warnings are bogus, with the firts one being too obvious. :-)

Nevertheless I would like to hear about the others.

Comment 5 Vitezslav Crhonek 2009-02-09 15:28:47 UTC
(In reply to comment #4)
> I would like to take this review. My interest in tix comes from the python side
> and it is always nice to have one more merge review finished. :-)
Thanks for taking it.

> 
> I noticed the open review since comment #3 but I have been busy meanwhile.
> Sorry. :-)
> 
> The first standard question regarding this issue is the output of rpmlint over
> the produced rpms:
> 
> tix.i686: W: non-conffile-in-etc /etc/ld.so.conf.d/tix-i386.conf
As you said, this is OK (it's not real config file).

> tix.i686: E: script-without-shebang /usr/lib/tcl8.5/Tix8.4.3/pref/WmDefault.tcl
Hm, WmDefault.tcl is used as module if I understand it correctly, so missing shebang is OK, but it's probably also OK to remove executable permission... But I don't know much about it (only what's written in WmDefault.txt), so what do you think?

> tix.src: W: patch-not-applied Patch1: tix-8.4.2-tcl8.5.patch
> tix-doc.i686: W: spurious-executable-perm
Fixed.

> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/twofont.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/notebook.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/combo.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/hierarchy.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/dirlist.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/relation.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/dirtree.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/sl-bar.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/exfile.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/oop/arrows.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/select1.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/pane_vert.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/widgets.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/law_comp.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist_ex3.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/tlist.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tix32.png
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/sl-nobar.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/ARROWS.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist_ex1.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hierarchy.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/pane_horz.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/dirtree.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/lawyer.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/horizontal.gif
Fixed.

> tix-doc.i686: W: wrong-file-end-of-line-encoding
> /usr/share/doc/tix-doc-8.4.3/Release-8.4.0.txt
Fixed.

> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/filesel/fb_comp.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/ctl_wopt.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/select-vert.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist_ex2.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/joe.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hierarchy.png
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/ctl_subw.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/container/pane_add.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/vertical.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tix32.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/tlist/twofont2.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/select.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/arrows.png
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/hlist/hlist1.gif
> tix-doc.i686: W: spurious-executable-perm
> /usr/share/doc/tix-doc-8.4.3/html/gif/tix/intro/ctl_noopt.gif
Fixed.

> 
> Note that I am quite aware that some of the those warnings are bogus, with the
> firts one being too obvious. :-)
> 
> Nevertheless I would like to hear about the others.

Comment 6 Vitezslav Crhonek 2010-01-14 14:52:08 UTC
Ping?

Comment 7 José Matos 2014-04-01 16:37:39 UTC
Created attachment 881445 [details]
Review report for tix merge review

Comment 8 José Matos 2014-04-01 16:42:46 UTC
Pong.

I have been busy with two lovely kids in between. :-)

The package is approved. There are small warnings like the man pages macros not defined or the bogus dates on the spec file but those are minor.

So tix is approved. Hurray. :-)


Note You need to log in before you can comment on or make changes to this bug.