Bug 226504 - Merge Review: tsclient
Merge Review: tsclient
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tyler Owen
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:12 EST by Nobody's working on this, feel free to take it
Modified: 2012-06-15 12:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 15:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:12:38 EST
Fedora Merge Review: tsclient

http://cvs.fedora.redhat.com/viewcvs/devel/tsclient/
Initial Owner: besfahbo@redhat.com
Comment 1 Tyler Owen 2008-01-11 13:21:01 EST
OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name.
FIX - Spec has consistant macro usage.
        - Do not use %makeinstall macro
OK - Meets Packaging Guidelines.

OK - License
OK - License field in spec matches
OK - License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:

OK - Package needs ExcludeArch
OK - BuildRequires correct
OK - Spec handles locales/find_lang
OK - Package is relocatable and has a reason to be.
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
OK - Package has correct buildroot
      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
OK - Package is code or permissible content.
OK - Doc subpackage needed/used.
OK - Packages %doc files don't affect runtime.

FIX - Package is a GUI app and has a .desktop file
        - Vendor should be set to fedora instead of tsclient
        - remove the " --add-category Utility " entry
OK - Package compiles and builds on at least one arch.

OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
FIX - No rpmlint output.
        SRPM: 
                tsclient.src: W: mixed-use-of-spaces-and-tabs (spaces: line 50,
tab: line 53)
        RPM:
                tsclient.i386: W: incoherent-version-in-changelog 0.150.5
0.150-5.fc8
                tsclient.i386: E: incorrect-locale-el
/usr/share/locale/gr/LC_MESSAGES/tsclient.mo
 - final provides and requires are sane:
     (include output of for i in *rpm; do echo $i; rpm -qp --provides $i; echo
=; rpm -qp --requires $i; echo; done
      manually indented after checking each line.  I also remove the rpmlib junk
and anything provided by glibc.)

SHOULD Items:

OK - Should build in mock.
OK - Should build on all supported archs
OK - Should function as described.
OK - Should have sane scriptlets.
OK - Should have subpackages require base package with fully versioned depend.
OK - Should have dist tag
OK - Should package latest version
FIX - check for outstanding bugs on package. (For core merge reviews)
        242315 - remove the Utility category (see above)

Issues:

1. Do not use %makeinstall macro
2. Fix vendor in desktop file, should be fedora
3. Fix bug 242315
4. rpmlint not quiet

        rpm:    Changelog should use - instead of . to denote release
                Need to notify upstream that the Greek local has changed from el
to gr
Comment 2 Tyler Owen 2008-01-14 22:12:55 EST
Adding davidz to this ticket

I am doing this b/c he is listed as the owner in the pkgdb
Comment 3 Matthias Clasen 2009-01-23 21:44:18 EST
1. The current tsclient spec file doesn't use %makeinstall
2. Adding a vendor prefix is a bad idea, it has the potential to break code that
   assumes that it can refer to the tsclient desktop file by the id 'tsclient'. 
   We are moving away from blindly forcing a vendor prefix.
3. Fixed
4. I'm not going to patch old ChangeLog entries. tsclient 2.0.1 doesn't ship Greek translations, el or gr.
Comment 4 Christopher Brown 2010-07-04 12:23:53 EDT
Old bug - long since merged so closing.
Comment 5 Dan Horák 2010-07-04 12:40:11 EDT
(In reply to comment #4)
> Old bug - long since merged so closing.    

Yes, it's old, but I can't see that the merge review was finished.
Comment 6 Christopher Brown 2010-07-04 13:26:25 EDT
Errr, okay. So are you going to complete the review?

Not sure I can see the value in keeping it open however as all issues raised were addressed.

Happy for this to be re-opened if someone is going to do the paperwork to get it completed but this appears to be rather bureaucratic.
Comment 7 Filipe Rosset 2012-04-23 15:32:00 EDT
I'm closing this bug since tsclient was removed due to dead upstream and at least two superior alternatives (remmina and gnome-rdp)
Comment 8 Parag AN(पराग) 2012-06-15 12:26:45 EDT
This bug just popped out when I searched for packages under review but looks like this package was retired already.

Dropping the flag fedora-review?

Note You need to log in before you can comment on or make changes to this bug.