Bug 22652 - Update RH6.2 -> 7.0 : inetd & xinetd running at the same time
Update RH6.2 -> 7.0 : inetd & xinetd running at the same time
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-21 04:40 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 11:37:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-21 04:40:29 EST
If you take a RH6.2 computer & upgrade it to RH7.0, then you have
with /etc/rc.d/rc3.d/S50inetd & /etc/rc.d/rc3.d/S50xinetd at the
same time.

So when you reboot, a daemon may take ports for telnet & ftp, while
the other may  manage talk & finger! (I had such a case!)

Solution: the upgrade process must withdraw S50inetd.
Comment 1 Michael Fulbright 2000-12-21 14:09:53 EST
I have not seen this happen in my testing - assigning to xinted owner.
Comment 2 Trond Eivind Glomsrxd 2000-12-26 17:56:39 EST
xinetd obsoletes inetd, this can't happen. What does "rpm -qf /usr/sbin/inetd" 
give you?
Comment 3 Need Real Name 2000-12-27 11:37:17 EST
It says netkit-base-0.10-37

I had this problem on 2 computers moving from RH6.2 to RH7.0 out
of a bunch of about 10.
Comment 4 Trond Eivind Glomsrxd 2000-12-28 15:51:11 EST
6.2 should have inetd in the inetd rpm... anyway, netkit-base has also been
marked obsolete since 2000-10-31, so the fix should be part of
xinetd-2.1.8.9pre12-2 and newer,

Note You need to log in before you can comment on or make changes to this bug.