This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 226521 - Merge Review: uucp
Merge Review: uucp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:14 EST by Nobody's working on this, feel free to take it
Modified: 2011-09-06 08:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-15 09:41:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
atkac: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:14:24 EST
Fedora Merge Review: uucp

http://cvs.fedora.redhat.com/viewcvs/devel/uucp/
Initial Owner: pvrabec@redhat.com
Comment 1 Adam Tkac 2009-12-15 06:45:04 EST
Review of uucp-1.07-20.fc13 package:

+ MUST: The package must be named according to the Package Naming Guidelines
+ MUST: The spec file name must match the base package %{name}, in the format %{name}.spec
+ MUST: The package must meet the Packaging Guidelines
+ MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .
+ MUST: The License field in spec match the actual license
+ MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file must be included in %doc
+ MUST: The spec file written in American English
- MUST(1): The spec file for the package is legible
+ MUST: The sources used to build the package must match the upstream source, as provided in the spec URL
+ MUST: The package successfully compile
+ MUST: All build dependencies must be listed in BuildRequires
+ MUST: The spec file handle locales properly
+ MUST: Every package which stores shared library files in any of the dynamic linker's default paths, must call ldconfig in %post and %postun
+ MUST: Packages does not bundle copies of system libraries
+ MUST: Package own all directories that it creates
+ MUST: Package does not list a file more than once in the spec file
+ MUST: Permissions on files must be set properly. Every %files section must include a %defattr(...) line
+ MUST: Package has a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT)
+ MUST: Package use macros consistently
+ MUST: Package contains code, or permissable content
+ MUST: Large documentation files must go in a -doc subpackage
+ MUST: If a package includes something as %doc, it must not affect the runtime of the application
+ MUST: Header files in a -devel package
+ MUST: Static libraries in a -static package
+ MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'
+ MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package
+ MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name} = %{version}-%{release}
+ MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built
+ MUST: Packages containing GUI applications must include a %{name}.desktop file
+ MUST: Packages must not own files or directories already owned by other packages
+ MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot} (or $RPM_BUILD_ROOT)
+ MUST: All filenames in rpm packages must be valid UTF-8.

1 - please fix all rpmlint warnings or explain them.
2 - please add %{?_smp_mflags} macro to "make" command in build section and remove implicit "all" target.
Comment 2 Ondrej Vasik 2009-12-15 08:30:30 EST
Thanks for review, Adam.

- added _smp_mflags to make
- removed implicit target
- fixed all .srpm rpmlint warnings
- commented patches
- fixed build root
- use buildrequires/requires instead of prereq

For the #1 and rpm - there is a lot of setuid/setgid binaries, some scripts and other "old style" files/things. I would say those rpmlint warnings/errors are required for the package propper functionality, but feel free to discuss them specifically.

Updated package built as uucp-1.07-21.fc13
Comment 3 Ondrej Vasik 2009-12-15 08:57:33 EST
We just discussed rpmlint warnings about the scripts in doc dir. All those rpmlint warnings come from the contrib directory with sample scripts. Those scripts have shebangs and are intended to be executable. Uucp is very old near-dead package with "old-style" packaging, so I would prefer to keep those as they are at the moment.
Comment 4 Adam Tkac 2009-12-15 09:41:43 EST
Ok, package looks fine now. Reviewed.
Comment 5 Ondrej Vasik 2011-09-06 06:58:52 EDT
Package Change Request
======================
Package Name: uucp
New Branches: el6
Owners: ovasik
InitialCC:
Comment 6 Gwyn Ciesla 2011-09-06 08:01:23 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.