Bug 2265210 - Firefox does not show in GNOME Software anymore
Summary: Firefox does not show in GNOME Software anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 40
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: BetaFreezeException, F40BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2024-02-20 22:34 UTC by Daniel Rusek
Modified: 2024-03-03 17:22 UTC (History)
9 users (show)

Fixed In Version: firefox-123.0-2.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-03 17:22:28 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Daniel Rusek 2024-02-20 22:34:04 UTC
Firefox seems to have broken AppStream metadata in Fedora 40, its details page is completely missing and does not show in GNOME Software. The Flatpak version gets shown instead.

This is most likely caused by the desktop file name not matching the AppStream id. It looks like that the desktop file was renamed to "org.mozilla.firefox.desktop", however the appdata file name is still just "firefox.appdata.xml.in" (instead of org.mozilla.firefox.appdata.xml.in) and the app id is "firefox.desktop" (instead of org.mozilla.firefox.desktop):

https://src.fedoraproject.org/rpms/firefox/blob/rawhide/f/firefox.appdata.xml.in#_4

Also, a new "<launchable type="desktop-id">org.mozilla.firefox.desktop</launchable>" tag should be added as well since it is now required by many AppStream parsers.

And "<component type="desktop">" should ideally be changed to "<component type="desktop-application">" since the former is considered deprecated.

Reproducible: Always

Comment 1 Fedora Blocker Bugs Application 2024-02-20 22:42:47 UTC
Proposed as a Freeze Exception for 40-beta by Fedora user asciiwolf using the blocker tracking app because:

 Firefox have broken AppStream metadata in Fedora 40, its details page is completely missing and does not show in GNOME Software. The Flatpak version gets shown instead. This is confusing for users, can lead to Flatpak version of Firefox being installed by accident and other problems. The fix should be easy and is already described in the bz.

Comment 2 Daniel Rusek 2024-02-21 14:12:13 UTC
Fix: https://src.fedoraproject.org/rpms/firefox/pull-request/65

Comment 3 Martin Stransky 2024-02-22 10:05:17 UTC
Committed, Thanks.

Comment 4 František Zatloukal 2024-02-27 12:10:20 UTC
Discussed during the 2024-02-26 blocker review meeting: [1]

The decision to classify this bug as a AcceptedFreezeException (Beta) was made:

"It is an easy and low-risk fix for something that may fit final blocking criterions. There is no harm in fixing it earlier in the beta stage.".

[1] https://meetbot.fedoraproject.org/blocker-review_matrix_fedoraproject-org/2024-02-26/f40-blocker-review.2024-02-26-17.01.log.html

Comment 5 Fedora Update System 2024-03-01 21:43:42 UTC
FEDORA-2024-8df8fac20b (firefox-123.0-2.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-8df8fac20b

Comment 6 Adam Williamson 2024-03-01 21:44:09 UTC
Fix for this was committed before firefox-123.0-2.fc40 was built, so marked that update as fixing this.

Comment 7 Fedora Update System 2024-03-03 17:22:28 UTC
FEDORA-2024-8df8fac20b (firefox-123.0-2.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.