Bug 226532 - Merge Review: vorbis-tools
Merge Review: vorbis-tools
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:16 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 11:43:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
michel: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:16:07 EST
Fedora Merge Review: vorbis-tools

http://cvs.fedora.redhat.com/viewcvs/devel/vorbis-tools/
Initial Owner: besfahbo@redhat.com
Comment 1 Hans de Goede 2007-11-14 10:15:00 EST
To all interested reviewers, I've become a vorbis-tools co-maitainer recently and
I would like to push gnome-games through its merge review. I've taken an initial
look and the specfile looks ok. Please review and tell me what needs fixing.
Comment 2 Michel Alexandre Salim 2007-11-14 10:29:54 EST
Will be able to do the review in a couple of hours. Hans, do you want to
officially assign yourself the bug?
Comment 3 Hans de Goede 2007-11-14 10:41:21 EST
(In reply to comment #2)
> Will be able to do the review in a couple of hours. Hans, do you want to
> officially assign yourself the bug?

Normal reviews are always assigned to the reviewer, not the one requesting the
review, is this different for merge reviews?
Comment 4 Michel Alexandre Salim 2007-11-14 17:39:52 EST
Ah, I mean the reporter, but I just realized it cannot be changed.
Comment 5 Michel Alexandre Salim 2007-11-14 17:51:18 EST
- License field needs updating (should be GPLv2)
- Provides and Obsoletes should probably be versioned

Provides: oldpackagename = $provEVR
Obsoletes: oldpackagename < $obsEVR

- This is probably cosmetic, but rpmlint suggests that the summary should not
end with a period.
Comment 6 Hans de Goede 2007-11-15 03:34:41 EST
Thanks for the comments sofar, I'm waiting with doing a new revision until
you've done a complete review, so that hopefully I can get everything fixed in
one iteration.

Comment 7 Michel Alexandre Salim 2007-11-15 13:18:12 EST
Here's the full review; didn't find anything else to fix.

MUST
failed:
• license field accurate

passed:
• rpmlint: OK
• package name: OK
• spec file name: OK
• package guideline-compliant: OK
• license complies with guidelines: OK
• license file not deleted: OK
• spec in US English: OK
• spec legible: OK
• source matches upstream: OK
• builds under >= 1 archs, others excluded: OK
• build dependencies complete: OK
• locales handled using %find_lang, no %{_datadir}/locale: OK
• library -> ldconfig: NA
• relocatable: give reason: NA
• own all directories: OK
• no dupes in %files: OK
• permission: OK
• %clean RPM_BUILD_ROOT: OK
• macros used consistently: OK
• Package contains code: OK
• large docs => -doc: NA
• doc not runtime dependent: NA
• headers in -devel: NA
• static in -static: NA
• if contains *.pc, req pkgconfig: NA
• if libfiles are suffixed, the non-suffixed goes to devel: NA
• devel requires versioned base package: NA
• desktop file uses desktop-file-install: NA
• clean buildroot before install: OK
• filenames UTF-8: OK

SHOULD
failed:
• other subpackages should require versioned base
  Obsoletes/Provides should be versioned as well
• summary ending with period


passed:
• if license text missing, ask upstream to include it: NA
• desc and summary contain translations if available
• package build in mock on all architectures: OK
• package functioned as described: OK
• scriplets are sane: OK
• if main pkg is development-wise, pkgconfig can go in main package: NA
• require package not files: OK
Comment 8 Hans de Goede 2007-11-15 14:03:02 EST
Ok,

1:1.1.1.svn20070412-5 has just been committed to CVS and is now building, this
fixes:
• license field accurate
• other subpackages should require versioned base
  Obsoletes/Provides should be versioned as well
• summary ending with period

Note You need to log in before you can comment on or make changes to this bug.