Bug 226545 - Merge Review: wsdl4j
Merge Review: wsdl4j
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Spike
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:17 EST by Nobody's working on this, feel free to take it
Modified: 2013-07-09 00:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 00:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
SpikeFedora: fedora‑review?


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:17:15 EST
Fedora Merge Review: wsdl4j

http://cvs.fedora.redhat.com/viewcvs/devel/wsdl4j/
Initial Owner: dbhole@redhat.com
Comment 1 Spike 2010-11-04 15:25:34 EDT
I'll do this one
Comment 2 Spike 2010-11-04 15:47:19 EDT
=== REQUIRED ITEMS ===
[x]  Rpmlint output: silent
[x]  Package is named according to the Package Naming Guidelines[1].
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines[2].
[x]  Package successfully compiles and builds into binary rpms.
[!]  Buildroot is correct (%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n))
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines[3,4].
[x]  License field in the package spec file matches the actual license.
License type: CPL
[x]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[x]  All independent sub-packages have license of their own
[x]  Spec file is legible and written in American English.
[x]  Sources used to build the package matches the upstream source, as provided in the spec URL.
MD5SUM this package    : 46825152eda7b8674ac62c28736c24d8
MD5SUM upstream package: 46825152eda7b8674ac62c28736c24d8
[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines[5].
[x]  Package must own all directories that it creates.
[-]  Package requires other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[x]  Permissions on files are set properly.
[x]  Package has a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
[x]  Package consistently uses macros.
[x]  Package contains code, or permissable content.
[-]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[x]  Javadoc documentation files are generated and included in -javadoc subpackage
[x]  Packages have proper BuildRequires/Requires on jpackage-utils
[x]  Javadoc subpackages have Require: jpackage-utils
[x]  Package uses %global not %define
[-]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)
[-]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.

=== Maven ===
[-]  Use %{_mavenpomdir} macro for placing pom files instead of %{_datadir}/maven2/poms
[-]  If package uses "-Dmaven.test.skip=true" explain why it was needed in a comment
[-]  If package uses custom depmap "-Dmaven2.jpp.depmap.file=*" explain why it's needed in a comment
[-]  Package uses %update_maven_depmap in %post/%postun
[-]  Packages have Requires(post) and Requires(postun) on jpackage-utils (for %update_maven_depmap macro)

=== Other suggestions ===
[x]  If possible use upstream build method (maven/ant/javac)
[x]  Javadocs are placed in %{_javadocdir}/%{name}-%{version} with %{_javadocdir}/%{name} symlink
[!]  Jar files are installed to %{_javadir}/%{name}-%{version}.jar with %{_javadir}/%{name}.jar (unversioned) symlink
[-]  If package contains pom.xml files install it (including depmaps) even when building with ant 
[x]  Avoid having BuildRequires on exact NVR unless necessary
[x]  Package has BuildArch: noarch (if possible)
[x]  Latest version is packaged.
[x]  Reviewer should test that the package builds in mock.
Tested on: fedora-rawhide-i386


=== Issues ===
1. Buildroot
2. The ant target compile will result in two jar files: 

/build/lib/qname.jar
/build/lib/wsdl4j.jar

The loop that installs these files and generates an unversioned symlink is broken. It installs wsdl4j.jar to %{name}-%{version}.jar (with a correct symlink) but it also installs the same wsdl4j.jar to qname-%{version}.jar. You end up with

149K /usr/share/java/qname-1.6.2.jar
149K /usr/share/java/wsdl4j-1.6.2.jar
15   /usr/share/java/wsdl4j.jar -> qname-1.6.2.jar

Note: qname-1.6.2.jar and wsdl4j-1.6.2.jar are actually the same file.

=== Final Notes ===
1. From the Java packaging guidelines:
* If the number of provided JAR files exceeds two, you MUST place them into a sub-directory named %{name}.
Comment 3 Spike 2010-11-04 15:50:56 EDT
(In reply to comment #2)
> === Final Notes ===
> 1. From the Java packaging guidelines:
> * If the number of provided JAR files exceeds two, you MUST place them into a
> sub-directory named %{name}.

Of course, it's exacly two here (not sure if the symlinks count), but it might be a good idea anyway, since qname.jar is not necessarily associated with wsdl4j. It also avois cluttering up /usr/share/java

Note You need to log in before you can comment on or make changes to this bug.