Bug 226552 - Merge Review: xdelta
Merge Review: xdelta
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: manuel wolfshant
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:18 EST by Nobody's working on this, feel free to take it
Modified: 2009-12-04 11:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 15:04:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
adam: fedora‑review+


Attachments (Terms of Use)
fixed spec, silences rpmlint (modulo "xdelta-devel: W: no-documentation ") (8.63 KB, text/plain)
2008-12-30 20:08 EST, manuel wolfshant
no flags Details
fixed my mail address in changelog (8.64 KB, text/plain)
2008-12-30 20:13 EST, manuel wolfshant
no flags Details
separate static libs into their own package (9.04 KB, text/plain)
2008-12-31 04:06 EST, manuel wolfshant
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:18:31 EST
Fedora Merge Review: xdelta

http://cvs.fedora.redhat.com/viewcvs/devel/xdelta/
Initial Owner: atkac@redhat.com
Comment 1 manuel wolfshant 2008-12-30 18:48:26 EST
BuildRoot ( %{_tmppath}/%{name}-root ) is not one of the values accepted in the packaging guidelines.

License seems to be GPLv2+ (not GPLv2) and the file COPYING should be included in %docs. I suggest to also add AUTHORS.

Source0 should be
http://xdelta.googlecode.com/files/xdelta-1.1.4.tar.gz
Latest version is xdelta3.0u (http://xdelta.googlecode.com/files/xdelta3.0u.tar.gz), I had to dig below "deprecated" to locate the source0 URL for 1.1.4.

Current URL is http://xdelta.org/.

There are duplicate BRs: pkgconfig (by glib2-devel), automake (by libtool), autoconf (by libtool). however this is mostly cosmetic .

rpmlint is unhappy, most notably is the rpath signaled in the binary rpm:
Source RPM:
xdelta.src:223: W: macro-in-%changelog doc
xdelta.src:225: W: macro-in-%changelog defattr
xdelta.src:235: W: macro-in-%changelog defattr
xdelta.src:240: W: macro-in-%changelog setup
xdelta.src:250: W: macro-in-%changelog doc
xdelta.src:251: W: macro-in-%changelog post
xdelta.src:254: W: macro-in-%changelog defattr
xdelta.src: W: summary-ended-with-dot A binary file delta generator and an RCS replacement library.
1 packages and 0 specfiles checked; 0 errors, 8 warnings.

rpmlint of xdelta-debuginfo:
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/generic.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/getopt.h
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/sha.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xdeltapriv.h
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/md5c.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/library.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/simple.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/edsio_edsio.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/edsio_edsio.h
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/default.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xdmain.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/partime.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/base64.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/partime.h
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/edsio.h
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xdapply.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/maketime.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/edsio.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/libedsio/fh.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xd_edsio.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xdelta.c
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xdelta.h
xdelta-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/xdelta-1.1.4/xd_edsio.h
1 packages and 0 specfiles checked; 0 errors, 23 warnings.


rpmlint of xdelta:
xdelta.x86_64: W: spurious-executable-perm /usr/share/doc/xdelta-1.1.4/xdelta.magic
xdelta.x86_64: W: spurious-executable-perm /usr/share/doc/xdelta-1.1.4/NEWS
xdelta.x86_64: W: spurious-executable-perm /usr/share/doc/xdelta-1.1.4/README
xdelta.x86_64: W: summary-ended-with-dot A binary file delta generator and an RCS replacement library.
xdelta.x86_64: E: binary-or-shlib-defines-rpath /usr/bin/xdelta ['/usr/lib64']
1 packages and 0 specfiles checked; 1 errors, 4 warnings.

rpmlint of xdelta-devel:
xdelta-devel.x86_64: W: no-documentation
xdelta-devel.x86_64: W: summary-ended-with-dot Static library and header files for Xdelta development.
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

I also notice that the devel package includes two static libs (/usr/lib64/libedsio.a, /usr/lib64/libxdelta.a). If including them is really intended, according to https://fedoraproject.org/wiki/Packaging/Guidelines#Packaging_Static_Libraries a separate xdelta-static package should be created for them.

According to https://fedoraproject.org/wiki/Packaging/ReviewGuidelines, the xdelta-devel package should require pkgconfig, although I guess that the /usr/bin/pkg-config included automatically by rpmbuild is enough.
Comment 2 manuel wolfshant 2008-12-30 20:08:25 EST
Created attachment 327984 [details]
fixed spec, silences rpmlint (modulo "xdelta-devel: W: no-documentation ")
Comment 3 manuel wolfshant 2008-12-30 20:13:19 EST
Created attachment 327985 [details]
fixed my mail address in changelog
Comment 4 manuel wolfshant 2008-12-31 04:06:24 EST
Created attachment 327999 [details]
separate static libs into their own package



I am pretty sure the static libs are not needed (repoquery --repoid=development  --whatrequires "/usr/lib*/libxdelta.a" returns only xdelta-devel), but the attached spec will provide them, in a separate package. Most probably the files should be nuked together with the libtool files, but I am not in position to evaluate that, I've never developed anything based on xdelta
Comment 5 Adam Tkac 2009-11-30 10:36:02 EST
All issues should be fixed in xdelta-1.1.4-8.fc13.
Comment 6 manuel wolfshant 2009-12-02 15:04:46 EST
Indeed, most of the issues are solved. However there are 2 cosmetic issues left which would be nice to see fixed (especially the first one):
- please either remove the buildroot line completely or use one of the forms accepted by http://fedoraproject.org/wiki/Packaging/Guidelines#BuildRoot_tag
- there are duplicate BuildRequires: pkgconfig (by glib2-devel), automake (by libtool), autoconf (by libtool)


Since both issues are purely cosmetic now, I'll leave their fixing to your appreciation.

Closing the review as done and fixed. Thank you, Adam.
Comment 7 Adam Tkac 2009-12-03 06:22:07 EST
(In reply to comment #6)
> Indeed, most of the issues are solved. However there are 2 cosmetic issues left
> which would be nice to see fixed (especially the first one):
> - please either remove the buildroot line completely or use one of the forms
> accepted by http://fedoraproject.org/wiki/Packaging/Guidelines#BuildRoot_tag

Fixed.

> Closing the review as done and fixed. Thank you, Adam.  

Thank you for the review.

Note You need to log in before you can comment on or make changes to this bug.