Bug 226557 - Merge Review: xfig
Merge Review: xfig
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Package Reviews List
: Reopened
Depends On: 201992 211796
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:19 EST by Nobody's working on this, feel free to take it
Modified: 2009-04-22 05:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 05:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
susi.lehtola: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:19:12 EST
Fedora Merge Review: xfig

http://cvs.fedora.redhat.com/viewcvs/devel/xfig/
Initial Owner: than@redhat.com
Comment 1 Chitlesh GOORAH 2007-02-04 06:35:20 EST
There should be another alternative for using a pdf viewer.
If I use KDE, having evince pull out as a pdf viewer would mean that i have to
install another pdf viewer even kpdf is install by default.

The spec needs work to be compatible with the usual FE guidelines
Comment 2 Patrice Dumas 2007-02-05 09:46:23 EST
(In reply to comment #1)
> There should be another alternative for using a pdf viewer.

Maybe xdg-open could be used?
Comment 3 Patrice Dumas 2008-01-28 17:13:58 EST
rpmlint says:
xfig.i386: W: no-documentation
xfig.i386: W: obsolete-not-provided xfig-Xaw3d
xfig-plain.i386: W: no-documentation
xfig-common.i386: E: non-executable-script
/usr/share/xfig/Libraries/Maps/USA/assemble 0644
xfig-common.i386: E: non-executable-script
/usr/share/xfig/Libraries/Maps/Canada/assemble 0644

The xfig.i386: W: obsolete-not-provided xfig-Xaw3d should certainly
be fixed.

I think that the non-executable script should be ignored, otherwise
csh will become a dependency. Maybe a comment could be added (when 
doing chmods in %prep?).

Some timestamps could be kept, for example after the iconv call, 
there could be
  touch -r $i $i.UTF-8
But fixing all would require more work, not really that important.

I would have preferred to have virtual provides with parenthesis
like  %{name}(executable)

Otherwise it is very clean.
Comment 4 Hans de Goede 2008-10-30 06:35:07 EDT
Hi all,

As can be seen from the ChangeLog I'm a co-maintainer of xfig and I've been doing most of the work on xfig lately. While looking at open xfig bugs to fix, I forgot to look for a merge review. But I've found it now :)

So I'll be working on fixing the small list of Issues mentioned by Patrice.

(In reply to comment #3)
> rpmlint says:
> xfig.i386: W: no-documentation
> xfig.i386: W: obsolete-not-provided xfig-Xaw3d
> xfig-plain.i386: W: no-documentation
> xfig-common.i386: E: non-executable-script
> /usr/share/xfig/Libraries/Maps/USA/assemble 0644
> xfig-common.i386: E: non-executable-script
> /usr/share/xfig/Libraries/Maps/Canada/assemble 0644
> 
> The xfig.i386: W: obsolete-not-provided xfig-Xaw3d should certainly
> be fixed.
> 

Will do.

> I think that the non-executable script should be ignored, otherwise
> csh will become a dependency. Maybe a comment could be added (when 
> doing chmods in %prep?).
> 

Actually, I just tried them and those scripts are broken (tail +# should be tail -n +#), and the output of them is already included, these are really utility scripts for people editing these maps, so I think it would be best to completely remove them, agreed?

> Some timestamps could be kept, for example after the iconv call, 
> there could be
>   touch -r $i $i.UTF-8
> But fixing all would require more work, not really that important.
> 

I'll fix the easy ones.

> I would have preferred to have virtual provides with parenthesis
> like  %{name}(executable)
> 

I agree, but it is too late for that now.

I don't want to make changes to the F-10 version of xfig so late in the game, so I'm first going to do a branch request.
Comment 5 Hans de Goede 2008-10-30 06:36:49 EDT
Package Change Request
======================
Package Name: xfig
New Branches: F-10

Note this is an early branch request.
Comment 6 Kevin Fenzi 2008-10-30 14:47:24 EDT
cvs done.
Comment 7 Hans de Goede 2008-11-08 15:18:00 EST
A new fixed version (as discussed in comment #4), is in devel / F11 now, the build of it is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=922755
Comment 8 Chitlesh GOORAH 2009-03-04 15:55:55 EST
should not this bug be close now ?
Comment 9 Susi Lehtola 2009-03-21 17:53:13 EDT
(In reply to comment #8)
> should not this bug be close now ?  

No, Patrice hasn't reviewed the package yet.

Patrice: could you finish the review?
Comment 10 Patrice Dumas 2009-03-22 06:19:44 EDT
I don't use fedora anymore so I cannot have the final say, nor do many of the checks, but it looks good from reading the spec. Only 3 comments, 

* some patches could have a comment, namely xfig-3.2.5-color-resources.patch and xfig-3.2.5-debian.patch, others were rather straightforward, or explained by corresponding entries in changelog
* I'd prefer xfig-3.2.4-redhat.patch not to be named like that, but rather along xfig-3.2.4-commands.patch for downstream reuse of spepc and patches
* I's still prefer 
Provides: %{name}(executable) = %{version}-%{release}

I am not sure that any of these constitutes a blocker.

I'll remove myself to the assignee, since I cannot really formally do the review, but from my point of view it is fine.
Comment 11 Peter Lemenkov 2009-04-21 11:03:36 EDT
What's the status of this ticket?
Comment 12 Hans de Goede 2009-04-21 13:18:19 EDT
As far as I'm concerned it can be closed, all comments made have been addressed,
but I'm the xfig maintainer so it is not up to me to close it.
Comment 13 Peter Lemenkov 2009-04-21 13:26:02 EDT
Ok, I'm closing this.
Comment 14 Susi Lehtola 2009-04-21 13:36:52 EDT
Actually, there are still some things to fix, at least directory ownership: the package should Requires: hicolor-icon-theme.

And maybe also explicitly libXt, since it owns /usr/share/X11/app-defaults/ (the lib dependency is however already picked up automatically).
Comment 15 Hans de Goede 2009-04-21 13:48:28 EDT
(In reply to comment #14)
> Actually, there are still some things to fix, at least directory ownership: the
> package should Requires: hicolor-icon-theme.
> 

Good catch, fixed in CVS, will get picked up the next build.
Comment 16 Susi Lehtola 2009-04-21 15:03:10 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > Actually, there are still some things to fix, at least directory ownership: the
> > package should Requires: hicolor-icon-theme.
> > 
> 
> Good catch, fixed in CVS, will get picked up the next build.  

Maybe I'd better do a full review still, just in case.

Reopening; don't do a release until I reclose.
Comment 17 Susi Lehtola 2009-04-21 15:35:47 EDT
Reviewing version 3.2.5-19.a found in koji.


- Other missing Requires:
Common uses update-desktop-database =>
  Requires(post): desktop-file-utils

rpmlint output:
xfig.x86_64: W: no-documentation
xfig-plain.x86_64: W: no-documentation
5 packages and 0 specfiles checked; 0 errors, 2 warnings.


MUST: The spec file for the package is legible and macros are used consistently. ~OK
- Quite a few undocumented patches. A reason SHOULD be documented for having each patch.

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}. OK
MUST: The package must be licensed with a Fedora approved license and meet the  Licensing Guidelines. OK
MUST: The License field in the package spec file must match the actual license. OK

MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. NEEDSFIX
- Source not available upstream for this release.

MUST: The package MUST successfully compile and build into binary rpms. OK
MUST: The spec file MUST handle locales properly. OK
MUST: Optflags are used and time stamps preserved. OK
MUST: Packages containing shared library files must call ldconfig. OK
MUST: A package must own all directories that it creates or require the package that owns the directory. OK [fixed in CVS]
MUST: Files only listed once in %files listings. OK
MUST: Permissions on files must be set properly. OK
MUST: Clean section exists. OK
MUST: Large documentation files must go in a -doc subpackage. OK

MUST: All relevant items are included in %doc. Items in %doc do not affect runtime of application. NEEDSFIX
- Include in package: CHANGES, README, LATEX.AND.XFIG*, FIGAPPS

MUST: Header files must be in a -devel package. OK
MUST: Static libraries must be in a -static package. OK
MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'. OK
MUST: If a package contains library files with a suffix then library files ending in .so must go in a -devel package. OK
MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency. OK
MUST: Packages does not contain any .la libtool archives. OK
MUST: Desktop files are installed properly. OK
MUST: No file conflicts with other packages and no general names. OK
MUST: Buildroot cleaned before install. OK
SHOULD: %{?dist} tag is used in release. OK

SHOULD: If the package does not include license text(s) as separate files from upstream, the packager should query upstream to include it. NEEDSFIX
- README contains license, which should be added in %doc as mentioned above.

SHOULD: The package builds in mock. OK
Comment 18 Hans de Goede 2009-04-22 05:34:16 EDT
(In reply to comment #17)
> Reviewing version 3.2.5-19.a found in koji.
> 
> 
> - Other missing Requires:
> Common uses update-desktop-database =>
>   Requires(post): desktop-file-utils
> 

Fixed in CVS

> MUST: The sources used to build the package must match the upstream source, as
> provided in the spec URL. NEEDSFIX

I cannot fix this, all I can do is replace this with a link the _orig tarbal
on one of Debian mirrors. I've asked upstream to make this release available
on the official webpage but he hasn't gotten around to this yet.

> MUST: All relevant items are included in %doc. Items in %doc do not affect
> runtime of application. NEEDSFIX
> - Include in package: CHANGES, README, LATEX.AND.XFIG*, FIGAPPS
> 

Fixed in CVS

Thanks for the review!
Comment 19 Susi Lehtola 2009-04-22 05:56:23 EDT
No problem.

Closing.

Note You need to log in before you can comment on or make changes to this bug.