Bug 22659 - laptop display problem while installing
laptop display problem while installing
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Gold
Depends On:
  Show dependency treegraph
Reported: 2000-12-21 06:52 EST by Tim Waugh
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-12 18:22:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2000-12-21 06:52:22 EST
On an Inspiron 3500 with a Neomagic 256AV chipset, the framebuffer works
fine during installation right up until I click 'Test Settings' for 16-bit
1024x768 display.  The test card looks fine, but when I click on 'Yes, I
can see this' the X configuration screen I came from is _all_ messed up:
most of the colours are black.

- online help panel is entirely black
- radio buttons are entirely black (can't see which is selected any more)
- shadow man's face is black, although his hat is red
- 'redhat Linux Beta 1' is black with white outline
- while installing, status panel is black so I can't see how many packages
to go etc.
Comment 1 Michael Fulbright 2000-12-21 14:01:32 EST
Assigning to a developer.
Comment 2 Brent Fox 2000-12-22 08:35:57 EST
When you get to the syslinux prompt, try typing 'nofb'  This should force the
installer to skip framebuffer mode and try the regular X server instead.  I'm
trying to figure out if this is a framebuffer problem.
Comment 3 Tim Waugh 2000-12-22 08:44:06 EST
With 'nofb' the problem doesn't happen.
Comment 4 Brent Fox 2000-12-28 14:02:35 EST
This is what we were afraid of.  Some video cards do not work well with
framebuffer mode.  Some of them will fail when the graphical installer first
tries to come up.  If it fails here, we can catch the error and start a
non-framebuffer X server.  However, if it fails later in the installation, as in
this case, then we're in a bit of a bind.  We can't fall back and the user
probably can't go forward if they can't read the screen.
Comment 5 Brent Fox 2000-12-28 14:05:34 EST
Did you pass any special video modes at the syslinux prompt?  Like vga=791 or
something like that?
Comment 6 Tim Waugh 2000-12-28 14:18:06 EST
No.  The first time I just hit enter; the second time just 'linux nofb'.
Comment 7 Brent Fox 2001-01-03 18:01:46 EST
Can you give me the output of lspci?
Comment 8 Tim Waugh 2001-01-03 18:06:25 EST
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1220 (rev 02)
00:04.1 CardBus bridge: Texas Instruments PCI1220 (rev 02)
00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV] (rev
01:00.1 Multimedia audio controller: Neomagic Corporation [MagicMedia 256AV
Audio] (rev 20)
Comment 9 Brent Fox 2001-01-04 13:51:47 EST
Thanks.  We've reproduced the problem on an IBM Thinkpad with a neomagic
graphics board.  On our machine, after testing X, all the white areas of the
screen have turned purple.  Very odd.
Comment 10 Glen Foster 2001-01-11 16:04:54 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 11 Brent Fox 2001-01-12 18:22:36 EST
This isfixed now in cvs.  Brock, please verify.  I can point you toward a
laptop with this graphics chip.  What happends is that we don't try to use the
framebuffer server on NeoMagic cards anymore.
Comment 12 Brock Organ 2001-01-19 12:30:30 EST
verified the test setting works with a laptop with this chipset for 1024x768 @
16 bit (Neomagic (laptop/notebook)) ... this was verified in qa0118.2 test tree

Note You need to log in before you can comment on or make changes to this bug.