Bug 22660 - rpm -tb segfaults
Summary: rpm -tb segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-21 11:55 UTC by Gerald Teschl
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 21:10:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2000-12-21 11:55:48 UTC
------------------------
[root@soliton autoupdate]# rpm -tb -clean autoupdate-0.9.8-1.tar.gz
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.42738

<snip>

Finding  Requires: (using /usr/lib/rpm/find-requires)...
objdump: /var/tmp/autoupdate-buildroot/usr/sbin/autoupdate: File format not
recognized
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: perl perl-libnet rpm sh-utils /usr/bin/perl
Segmentation fault
-------------------------
This is a noarch rpm and /var/tmp/autoupdate-buildroot/usr/sbin/autoupdate
is a perl
script btw.

Comment 1 Jeff Johnson 2000-12-21 21:09:57 UTC
Fixed in rpm-4.0.2-0.3 and later (latest is rpm-4.0.2-0.7, building now).


Note You need to log in before you can comment on or make changes to this bug.